summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Kolmodin <kolmodin@gentoo.org>2010-03-28 15:51:19 +0000
committerLennart Kolmodin <kolmodin@gentoo.org>2010-03-28 15:51:19 +0000
commit52bc55debd78372b23e6d9e957405ca7a78d2f46 (patch)
tree6bbc57fe4787d769df1d09dd31dd30746b351f7f /dev-haskell/test-framework-quickcheck2
parentInitial version of dev-haskell/test-framework. (diff)
downloadhistorical-52bc55debd78372b23e6d9e957405ca7a78d2f46.tar.gz
historical-52bc55debd78372b23e6d9e957405ca7a78d2f46.tar.bz2
historical-52bc55debd78372b23e6d9e957405ca7a78d2f46.zip
Initial version of dev-haskell/test-framework-quickcheck2.
Package-Manager: portage-2.1.7.17/cvs/Linux x86_64
Diffstat (limited to 'dev-haskell/test-framework-quickcheck2')
-rw-r--r--dev-haskell/test-framework-quickcheck2/ChangeLog10
-rw-r--r--dev-haskell/test-framework-quickcheck2/metadata.xml8
-rw-r--r--dev-haskell/test-framework-quickcheck2/test-framework-quickcheck2-0.2.5.ebuild24
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-haskell/test-framework-quickcheck2/ChangeLog b/dev-haskell/test-framework-quickcheck2/ChangeLog
new file mode 100644
index 000000000000..0924a244bd19
--- /dev/null
+++ b/dev-haskell/test-framework-quickcheck2/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-haskell/test-framework-quickcheck2
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/test-framework-quickcheck2/ChangeLog,v 1.1 2010/03/28 15:51:19 kolmodin Exp $
+
+*test-framework-quickcheck2-0.2.5 (28 Mar 2010)
+
+ 28 Mar 2010; Lennart Kolmodin <kolmodin@gentoo.org>
+ +test-framework-quickcheck2-0.2.5.ebuild, +metadata.xml:
+ Initial version.
+
diff --git a/dev-haskell/test-framework-quickcheck2/metadata.xml b/dev-haskell/test-framework-quickcheck2/metadata.xml
new file mode 100644
index 000000000000..8c66906af531
--- /dev/null
+++ b/dev-haskell/test-framework-quickcheck2/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>haskell</herd>
+<maintainer>
+ <email>haskell@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-haskell/test-framework-quickcheck2/test-framework-quickcheck2-0.2.5.ebuild b/dev-haskell/test-framework-quickcheck2/test-framework-quickcheck2-0.2.5.ebuild
new file mode 100644
index 000000000000..2b6b355329f0
--- /dev/null
+++ b/dev-haskell/test-framework-quickcheck2/test-framework-quickcheck2-0.2.5.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/test-framework-quickcheck2/test-framework-quickcheck2-0.2.5.ebuild,v 1.1 2010/03/28 15:51:19 kolmodin Exp $
+
+CABAL_FEATURES="lib profile haddock"
+inherit haskell-cabal
+
+DESCRIPTION="QuickCheck2 support for the test-framework package."
+HOMEPAGE="http://batterseapower.github.com/test-framework/"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+
+# works with ghc 6.8 too if we add this dependency
+# >=dev-haskell/extensible-exceptions-0.1.1
+
+RDEPEND=">=dev-lang/ghc-6.6.1
+ >=dev-haskell/quickcheck-2.1.0.3
+ >=dev-haskell/test-framework-0.2.0"
+DEPEND=">=dev-haskell/cabal-1.2.3
+ ${RDEPEND}"