summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuncan Coutts <dcoutts@gentoo.org>2006-03-11 20:41:25 +0000
committerDuncan Coutts <dcoutts@gentoo.org>2006-03-11 20:41:25 +0000
commitf0bf55194521b3acc307f897acc0d7d3139b7174 (patch)
tree3453ae2bfaad74930ed8188243d5fa6c8abfc7f6 /dev-haskell/hdbc/hdbc-0.99.0.ebuild
parentFix the uclibc patchset; bug #125395 (diff)
downloadhistorical-f0bf55194521b3acc307f897acc0d7d3139b7174.tar.gz
historical-f0bf55194521b3acc307f897acc0d7d3139b7174.tar.bz2
historical-f0bf55194521b3acc307f897acc0d7d3139b7174.zip
Remove the backends from PDEPEND. Use a message in pkg_postinst instead.
Package-Manager: portage-2.1_pre5-r4
Diffstat (limited to 'dev-haskell/hdbc/hdbc-0.99.0.ebuild')
-rw-r--r--dev-haskell/hdbc/hdbc-0.99.0.ebuild23
1 files changed, 15 insertions, 8 deletions
diff --git a/dev-haskell/hdbc/hdbc-0.99.0.ebuild b/dev-haskell/hdbc/hdbc-0.99.0.ebuild
index 9640efdf7018..dd9cdb295515 100644
--- a/dev-haskell/hdbc/hdbc-0.99.0.ebuild
+++ b/dev-haskell/hdbc/hdbc-0.99.0.ebuild
@@ -1,22 +1,29 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc/hdbc-0.99.0.ebuild,v 1.4 2006/03/09 17:39:20 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc/hdbc-0.99.0.ebuild,v 1.5 2006/03/11 20:41:25 dcoutts Exp $
CABAL_FEATURES="lib haddock"
-inherit haskell-cabal
+inherit ghc-package haskell-cabal
DESCRIPTION="Haskell Database Connectivity"
HOMEPAGE="http://quux.org/devel/hdbc/"
SRC_URI="http://quux.org/devel/hdbc/${PN}_${PV}.tar.gz"
+
LICENSE="LGPL-2.1"
SLOT="0"
-
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~sparc"
-IUSE="postgres sqlite odbc"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
DEPEND=">=virtual/ghc-6.4.1"
-PDEPEND="postgres? ( =dev-haskell/hdbc-postgresql-${PV}* )
- sqlite? ( =dev-haskell/hdbc-sqlite-${PV}* )
- odbc? ( =dev-haskell/hdbc-odbc-${PV}* )"
S="${WORKDIR}/${PN}"
+
+pkg_postinst () {
+ ghc-package_pkg_postinst
+
+ einfo "You will probably want to emerge one or more HDBC backend."
+ einfo "These backends are available:"
+ einfo " hdbc-postgresql"
+ einfo " hdbc-sqlite"
+ einfo " hdbc-odbc"
+}