summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Kolmodin <kolmodin@gentoo.org>2009-04-19 15:20:37 +0000
committerLennart Kolmodin <kolmodin@gentoo.org>2009-04-19 15:20:37 +0000
commit3eb0bd9a54cc516bf5b147f8056928d5600263f0 (patch)
treec9ac4d6bd36963764f23f63ac7935b3074c6dbe2 /dev-haskell/haddock/haddock-2.4.2.ebuild
parentamd64/x86 stable, bug #266664 (diff)
downloadhistorical-3eb0bd9a54cc516bf5b147f8056928d5600263f0.tar.gz
historical-3eb0bd9a54cc516bf5b147f8056928d5600263f0.tar.bz2
historical-3eb0bd9a54cc516bf5b147f8056928d5600263f0.zip
Version bump dev-haskell/haddock-2.4.2, currently masked for testing.
Package-Manager: portage-2.1.6.7/cvs/Linux x86_64
Diffstat (limited to 'dev-haskell/haddock/haddock-2.4.2.ebuild')
-rw-r--r--dev-haskell/haddock/haddock-2.4.2.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-haskell/haddock/haddock-2.4.2.ebuild b/dev-haskell/haddock/haddock-2.4.2.ebuild
new file mode 100644
index 000000000000..daf445c82833
--- /dev/null
+++ b/dev-haskell/haddock/haddock-2.4.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haddock/haddock-2.4.2.ebuild,v 1.1 2009/04/19 15:20:37 kolmodin Exp $
+
+CABAL_FEATURES="bin lib"
+# don't enable profiling as the 'ghc' package is not built with profiling
+inherit haskell-cabal autotools
+
+DESCRIPTION="A documentation-generation tool for Haskell libraries"
+HOMEPAGE="http://www.haskell.org/haddock/"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="~dev-lang/ghc-6.10.2
+ dev-haskell/filepath
+ dev-haskell/ghc-paths"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+ doc? ( ~app-text/docbook-xml-dtd-4.2
+ app-text/docbook-xsl-stylesheets
+ >=dev-libs/libxslt-1.1.2 )"
+
+src_unpack() {
+ unpack ${A}
+
+ if use doc; then
+ cd "${S}/doc"
+ eautoreconf
+ fi
+
+}
+
+src_compile () {
+ cabal_src_compile
+ if use doc; then
+ cd "${S}/doc"
+ ./configure --prefix="${D}/usr/" \
+ || die 'error configuring documentation.'
+ emake html || die 'error building documentation.'
+ fi
+}
+
+src_install () {
+ cabal_src_install
+ if use doc; then
+ dohtml -r "${S}/doc/haddock/"*
+ fi
+ dodoc CHANGES README
+}
+