summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndres Loeh <kosmikus@gentoo.org>2003-09-22 12:21:03 +0000
committerAndres Loeh <kosmikus@gentoo.org>2003-09-22 12:21:03 +0000
commit5a796bff818951d1d44a79cbfa48ac8a11aaf774 (patch)
treed7fa089b60cb66ee8199ae2b73193f4ffde3b47e /dev-haskell/alex/alex-2.0.ebuild
parentnew ebuild for alex (diff)
downloadhistorical-5a796bff818951d1d44a79cbfa48ac8a11aaf774.tar.gz
historical-5a796bff818951d1d44a79cbfa48ac8a11aaf774.tar.bz2
historical-5a796bff818951d1d44a79cbfa48ac8a11aaf774.zip
new ebuild for alex
Diffstat (limited to 'dev-haskell/alex/alex-2.0.ebuild')
-rw-r--r--dev-haskell/alex/alex-2.0.ebuild77
1 files changed, 77 insertions, 0 deletions
diff --git a/dev-haskell/alex/alex-2.0.ebuild b/dev-haskell/alex/alex-2.0.ebuild
new file mode 100644
index 000000000000..a60a4ed05bfa
--- /dev/null
+++ b/dev-haskell/alex/alex-2.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/alex/alex-2.0.ebuild,v 1.1 2003/09/22 12:20:54 kosmikus Exp $
+#
+# USE variable summary:
+# doc - Build extra documenation from DocBook sources,
+# in HTML format.
+# tetex - Build the above docs as PostScript as well.
+
+
+inherit base
+IUSE="doc tetex"
+
+DESCRIPTION="A lexical analyser generator for Haskell"
+SRC_URI="http://www.haskell.org/alex/dist/${P}-src.tar.bz2"
+HOMEPAGE="http://www.haskell.org/alex"
+
+SLOT="0"
+KEYWORDS="~x86 ~sparc"
+LICENSE="as-is"
+
+DEPEND=">=virtual/ghc-5.04
+ doc? ( >=app-text/openjade-1.3.1
+ >=app-text/sgml-common-0.6.3
+ =app-text/docbook-sgml-dtd-3.1-r1
+ >=app-text/docbook-dsssl-stylesheets-1.64
+ tetex? ( >=app-text/tetex-1.0.7
+ >=app-text/jadetex-3.12 ) )"
+
+RDEPEND=""
+
+# extend path to /opt/ghc/bin to guarantee that ghc-bin is found
+GHCPATH="${PATH}:/opt/ghc/bin"
+
+src_compile() {
+ # unset SGML_CATALOG_FILES because documentation installation
+ # breaks otherwise ...
+ PATH="${GHCPATH}" SGML_CATALOG_FILES="" econf
+ # using make because emake behaved strangely on my machine
+ make || die
+
+ # if documentation has been requested, build documentation ...
+ if use doc; then
+ cd ${S}/haddock/doc
+ emake html || die
+ if use tetex; then
+ emake ps || die
+ fi
+ fi
+}
+
+src_install() {
+ local mydoc
+
+ use doc && mydoc="html" || mydoc=""
+ use doc && use tetex && mydoc="${mydoc} ps"
+
+ echo SGMLDocWays="${mydoc}" >> mk/build.mk
+ make install install-docs \
+ prefix="${D}/usr" \
+ datadir="${D}/usr/share/doc/${PF}" \
+ infodir="${D}/usr/share/info" \
+ mandir="${D}/usr/share/man" || die
+
+ cd ${S}/haddock
+ dodoc CHANGES LICENSE README TODO
+
+ if [ "`use doc`" ]; then
+ cd ${S}/alex/doc
+ dohtml -r alex/* || die
+ dosym alex.html /usr/share/doc/${PF}/html/index.html
+ if [ "`use tetex`" ]; then
+ docinto ps
+ dodoc alex.ps || die
+ fi
+ fi
+}