summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip Walls <malverian@gentoo.org>2005-05-21 18:00:31 +0000
committerPhilip Walls <malverian@gentoo.org>2005-05-21 18:00:31 +0000
commit359e5051e7ae66728d1ceffe98c0767242d0ab25 (patch)
treef263c5f54e5f036e5141de0cbb995135e0faa4d7 /dev-games/crystalspace
parentupdating to cvs snapshot for planeshift (diff)
downloadhistorical-359e5051e7ae66728d1ceffe98c0767242d0ab25.tar.gz
historical-359e5051e7ae66728d1ceffe98c0767242d0ab25.tar.bz2
historical-359e5051e7ae66728d1ceffe98c0767242d0ab25.zip
cvs snapshot for planeshift
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'dev-games/crystalspace')
-rw-r--r--dev-games/crystalspace/ChangeLog8
-rw-r--r--dev-games/crystalspace/Manifest6
-rw-r--r--dev-games/crystalspace/crystalspace-0.99_pre20050518.ebuild77
-rw-r--r--dev-games/crystalspace/files/digest-crystalspace-0.99_pre200505181
4 files changed, 89 insertions, 3 deletions
diff --git a/dev-games/crystalspace/ChangeLog b/dev-games/crystalspace/ChangeLog
index 1176aed4e250..241071c9a86f 100644
--- a/dev-games/crystalspace/ChangeLog
+++ b/dev-games/crystalspace/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-games/crystalspace
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/ChangeLog,v 1.13 2005/02/28 17:31:50 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/ChangeLog,v 1.14 2005/05/21 18:00:31 malverian Exp $
+
+*crystalspace-0.99_pre20050518 (21 May 2005)
+
+ 21 May 2005; Philip Walls <malverian@gentoo.org>
+ +crystalspace-0.99_pre20050518.ebuild:
+ CVS snapshot for Planeshift
28 Feb 2005; Michael Sterrett <mr_bones_@gentoo.org>
crystalspace-0.98.4.20050224.ebuild, crystalspace-0.98.4.ebuild:
diff --git a/dev-games/crystalspace/Manifest b/dev-games/crystalspace/Manifest
index ccbe7169884b..e5d10217e6ff 100644
--- a/dev-games/crystalspace/Manifest
+++ b/dev-games/crystalspace/Manifest
@@ -1,7 +1,9 @@
-MD5 0da720205c15a58cce1ba2911b6bf9e4 ChangeLog 2107
+MD5 5bf01725b028785d728208127fbbe540 ChangeLog 2276
MD5 e4c7a49ca08eb200cfa0a9f9246e2257 metadata.xml 959
-MD5 5a3a3244a021fd624028affd3447e74b crystalspace-0.98.4.ebuild 1894
MD5 9341ad08ebcbcc0c158a0188265b9b3f crystalspace-0.98.4.20050224.ebuild 1958
+MD5 5a3a3244a021fd624028affd3447e74b crystalspace-0.98.4.ebuild 1894
+MD5 fcd003abef1e99351b72a688b8ab6214 crystalspace-0.99_pre20050518.ebuild 2231
+MD5 dadfba3b28652426c1b1ff2cf91e07a9 files/digest-crystalspace-0.99_pre20050518 84
MD5 bb4bd5565667c14a0d7377fda90db568 files/crystalspace-0.98.4-gl.patch 10653
MD5 bec0edb0863c282510494dc014bbf750 files/digest-crystalspace-0.98.4 63
MD5 dc4db504020f9a21fe8e24ecd6ceac67 files/digest-crystalspace-0.98.4.20050224 83
diff --git a/dev-games/crystalspace/crystalspace-0.99_pre20050518.ebuild b/dev-games/crystalspace/crystalspace-0.99_pre20050518.ebuild
new file mode 100644
index 000000000000..04e1dfc7c69c
--- /dev/null
+++ b/dev-games/crystalspace/crystalspace-0.99_pre20050518.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/crystalspace-0.99_pre20050518.ebuild,v 1.1 2005/05/21 18:00:31 malverian Exp $
+
+inherit debug
+
+DESCRIPTION="portable 3D Game Development Kit written in C++"
+HOMEPAGE="http://crystal.sourceforge.net/"
+SRC_URI="mirror://sourceforge/crystal/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="${IUSE} oggvorbis mikmod openal truetype 3ds mng python"
+
+RDEPEND="sys-libs/zlib
+ >=media-libs/libpng-1.2.1
+ >=media-libs/jpeg-6b
+ mng? ( media-libs/libmng )
+ mikmod? ( media-libs/libmikmod )
+ 3ds? ( media-libs/lib3ds )
+ truetype? ( >=media-libs/freetype-2.0 )
+ openal? ( media-libs/openal )
+ oggvorbis? (
+ >=media-libs/libogg-1.0
+ >=media-libs/libvorbis-1.0 )
+ dev-games/ode
+ >=dev-lang/perl-5.6.1
+ =media-libs/cal3d-0.11.0_pre*"
+
+DEPEND="${RDEPEND}
+ >=sys-apps/portage-2.0.51
+ dev-util/jam
+ x86? ( dev-lang/nasm )"
+
+S="${WORKDIR}/${PN}"
+
+CRYSTAL_PREFIX="/opt/crystal"
+
+src_compile() {
+ # Disabling python entirely, some parts don't build
+ #use python || \
+ my_conf="${my_conf} --without-python"
+
+ use debug && my_conf="${my_conf} --enable-debug"
+
+ # Clear out the maya2spr stuff.. it fails to build properly (left as example)
+ #sed 's/SubInclude TOP apps import maya2spr ;//' -i apps/import/Jamfile
+
+ ./configure --prefix=${CRYSTAL_PREFIX} ${my_conf}
+
+ jam all || die "compile failed"
+ jam cs-config || die "compile failed"
+}
+
+src_install() {
+ jam -sprefix="${D}"${CRYSTAL_PREFIX} install
+
+ # Fix cs-config file to point to ${CRYSTAL_PREFIX}
+ sed -i 's/^CRYSTAL=.*/CRYSTAL=\/opt\/crystal/' "${D}/${CRYSTAL_PREFIX}/bin/cs-config"
+
+ # Symlink cs-config into /usr/bin
+ dodir /usr/bin
+ dosym ${CRYSTAL_PREFIX}/bin/cs-config /usr/bin/cs-config
+
+ # Make sure these files dont have $D
+ dosed ${CRYSTAL_PREFIX}/{bin/cs-config,etc/crystalspace/vfs.cfg}
+
+ # Fix perms so everyone can read these
+ find "${D}"/${CRYSTAL_PREFIX} -type f -exec chmod a+r '{}' \;
+ find "${D}"/${CRYSTAL_PREFIX} -type d -exec chmod a+rx '{}' \;
+ chmod a+rx "${D}"/${CRYSTAL_PREFIX}/bin/*
+
+ dodir /etc/env.d
+ echo "CRYSTAL=\"${CRYSTAL_PREFIX}\"" > 90crystalspace
+ doenvd 90crystalspace
+}
diff --git a/dev-games/crystalspace/files/digest-crystalspace-0.99_pre20050518 b/dev-games/crystalspace/files/digest-crystalspace-0.99_pre20050518
new file mode 100644
index 000000000000..7d5daa769d52
--- /dev/null
+++ b/dev-games/crystalspace/files/digest-crystalspace-0.99_pre20050518
@@ -0,0 +1 @@
+MD5 de058bc224e244170bb15c120eeb3b8d crystalspace-0.99_pre20050518.tar.bz2 22357635