summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDominik Kapusta <ayoy@gentoo.org>2010-01-17 18:36:02 +0000
committerDominik Kapusta <ayoy@gentoo.org>2010-01-17 18:36:02 +0000
commit6c68299d4f649e5e1803943fa4708f0a46a58315 (patch)
tree5d2dd6008b1a6bff8aede41db9991e69bff93307 /dev-embedded/scratchbox-toolchain-cs2009q1-eglibc2_8/scratchbox-toolchain-cs2009q1-eglibc2_8-1.0.14.ebuild
parentVersion bump. (diff)
downloadhistorical-6c68299d4f649e5e1803943fa4708f0a46a58315.tar.gz
historical-6c68299d4f649e5e1803943fa4708f0a46a58315.tar.bz2
historical-6c68299d4f649e5e1803943fa4708f0a46a58315.zip
Initial commit for cs2009q1 eglibc-2.8 scratchbox toolchain
Package-Manager: portage-2.2_rc61/cvs/Linux x86_64
Diffstat (limited to 'dev-embedded/scratchbox-toolchain-cs2009q1-eglibc2_8/scratchbox-toolchain-cs2009q1-eglibc2_8-1.0.14.ebuild')
-rw-r--r--dev-embedded/scratchbox-toolchain-cs2009q1-eglibc2_8/scratchbox-toolchain-cs2009q1-eglibc2_8-1.0.14.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-embedded/scratchbox-toolchain-cs2009q1-eglibc2_8/scratchbox-toolchain-cs2009q1-eglibc2_8-1.0.14.ebuild b/dev-embedded/scratchbox-toolchain-cs2009q1-eglibc2_8/scratchbox-toolchain-cs2009q1-eglibc2_8-1.0.14.ebuild
new file mode 100644
index 000000000000..13b0846fdb3b
--- /dev/null
+++ b/dev-embedded/scratchbox-toolchain-cs2009q1-eglibc2_8/scratchbox-toolchain-cs2009q1-eglibc2_8-1.0.14.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/scratchbox-toolchain-cs2009q1-eglibc2_8/scratchbox-toolchain-cs2009q1-eglibc2_8-1.0.14.ebuild,v 1.1 2010/01/17 18:36:02 ayoy Exp $
+
+SBOX_GROUP="sbox"
+
+ARMV=${PV}-7
+I486V=${PV}-4
+
+DESCRIPTION="A cross-compilation toolkit designed to make embedded Linux application development easier."
+HOMEPAGE="http://www.scratchbox.org/"
+SRC_URI="http://scratchbox.org/download/files/sbox-releases/stable/tarball/${PN/_/.}-armv7-${ARMV}-i386.tar.gz
+ http://scratchbox.org/download/files/sbox-releases/stable/tarball/${PN/_/.}-i486-${I486V}-i386.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="=dev-embedded/scratchbox-1.0*"
+
+TARGET_DIR="/opt/scratchbox"
+
+S=${WORKDIR}/scratchbox
+
+src_install() {
+ dodir ${TARGET_DIR}
+ cp -pRP * "${D}/${TARGET_DIR}"
+}