summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-10-20 09:51:33 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-10-20 09:51:33 +0000
commit0d1078c25821c0d1b4c73adc386194fc627409f7 (patch)
tree9ea3541b2dc9d7ab50cb7798bfcd1c2373103a92 /dev-embedded/picptk/picptk-0.5a.ebuild
parentinitial commit, package is still broken, needs more tcl/gcc3.3 fixes (diff)
downloadhistorical-0d1078c25821c0d1b4c73adc386194fc627409f7.tar.gz
historical-0d1078c25821c0d1b4c73adc386194fc627409f7.tar.bz2
historical-0d1078c25821c0d1b4c73adc386194fc627409f7.zip
initial commit, package is still broken, needs more tcl/gcc3.3 fixes
Diffstat (limited to 'dev-embedded/picptk/picptk-0.5a.ebuild')
-rw-r--r--dev-embedded/picptk/picptk-0.5a.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-embedded/picptk/picptk-0.5a.ebuild b/dev-embedded/picptk/picptk-0.5a.ebuild
new file mode 100644
index 000000000000..9087937d479a
--- /dev/null
+++ b/dev-embedded/picptk/picptk-0.5a.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/picptk/picptk-0.5a.ebuild,v 1.1 2003/10/20 09:51:31 robbat2 Exp $
+
+#this is for autoconf
+inherit kde-functions
+
+DESCRIPTION="Picptk is a programmer supporting the whole PIC family including all memory types (EEPROM, EPROM, and OTP)"
+HOMEPAGE="http://huizen.dds.nl/~gnupic/programmers_mike_butler.html"
+# http://huizen.dds.nl/~gnupic/picptk-0.5a.tar.gz
+SRC_URI="http://huizen.dds.nl/~gnupic/picptk-0.5a.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="~x86"
+RDEPEND="dev-tcltk/itcl"
+DEPEND="${RDEPEND} sys-devel/gcc sys-devel/automake sys-devel/autoconf"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-headerfix.patch
+ cd ${S}
+ need-autoconf 2.1
+ automake
+ autoconf
+}
+
+src_compile() {
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ #dobin picprog
+ #dodoc README #jdm*.png adapter.jpg
+ #dohtml picprog.html *.jpg *.png
+ #doman picprog.1
+ einstall || die "einstall failed"
+ dodoc AUTHORS NEWS README TODO
+ newdoc .picprc sample.picprc
+}