summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2005-01-03 00:35:40 +0000
committerDaniel Black <dragonheart@gentoo.org>2005-01-03 00:35:40 +0000
commit6abf3f1dc1847c711ee8ca1f5e4da0f3d7c3c571 (patch)
treebe1623a7be515b7160a57021825ca3a65e47bed2 /dev-embedded/gpsim-lcd/gpsim-lcd-0.2.1.ebuild
parentTesting new gpgkey (diff)
downloadhistorical-6abf3f1dc1847c711ee8ca1f5e4da0f3d7c3c571.tar.gz
historical-6abf3f1dc1847c711ee8ca1f5e4da0f3d7c3c571.tar.bz2
historical-6abf3f1dc1847c711ee8ca1f5e4da0f3d7c3c571.zip
updated gnuconfig to solve bug #74998.
Diffstat (limited to 'dev-embedded/gpsim-lcd/gpsim-lcd-0.2.1.ebuild')
-rw-r--r--dev-embedded/gpsim-lcd/gpsim-lcd-0.2.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-embedded/gpsim-lcd/gpsim-lcd-0.2.1.ebuild b/dev-embedded/gpsim-lcd/gpsim-lcd-0.2.1.ebuild
new file mode 100644
index 000000000000..c31450024a9d
--- /dev/null
+++ b/dev-embedded/gpsim-lcd/gpsim-lcd-0.2.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/gpsim-lcd/gpsim-lcd-0.2.1.ebuild,v 1.1 2005/01/03 00:35:39 dragonheart Exp $
+
+inherit eutils gnuconfig
+
+MY_PN="${PN/gpsim-}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="2x20 LCD display module for GPSIM"
+HOMEPAGE="http://www.dattalo.com/gnupic/gpsim.html#modules http://www.dattalo.com/gnupic/lcd.html"
+SRC_URI="http://www.dattalo.com/gnupic/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=dev-embedded/gpsim-0.21"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ gnuconfig_update
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog INSTALL NEWS README
+ cp -ra ${S}/examples ${D}/usr/share/doc/${PF}
+ find ${D}/usr/share/doc/${PF} -name 'Makefile*' -exec rm -f \{} \;
+}