summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Martins <rafaelmartins@gentoo.org>2013-12-15 19:51:31 +0000
committerRafael Martins <rafaelmartins@gentoo.org>2013-12-15 19:51:31 +0000
commitb180a4cc907798de4c92ac7b734f065509d6018e (patch)
tree703c066074c0370dc1ce97c6675e71935a76e53c /dev-embedded/cpik/cpik-0.7.2_p4.ebuild
parentInitial commit. (diff)
downloadhistorical-b180a4cc907798de4c92ac7b734f065509d6018e.tar.gz
historical-b180a4cc907798de4c92ac7b734f065509d6018e.tar.bz2
historical-b180a4cc907798de4c92ac7b734f065509d6018e.zip
Initial commit.
Package-Manager: portage-2.2.7/cvs/Linux x86_64
Diffstat (limited to 'dev-embedded/cpik/cpik-0.7.2_p4.ebuild')
-rw-r--r--dev-embedded/cpik/cpik-0.7.2_p4.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-embedded/cpik/cpik-0.7.2_p4.ebuild b/dev-embedded/cpik/cpik-0.7.2_p4.ebuild
new file mode 100644
index 000000000000..79730b4c2786
--- /dev/null
+++ b/dev-embedded/cpik/cpik-0.7.2_p4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/cpik/cpik-0.7.2_p4.ebuild,v 1.1 2013/12/15 19:51:19 rafaelmartins Exp $
+
+EAPI=5
+
+inherit qt4-r2
+
+MY_PV="${PV/_p/-}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="C compiler for PIC18 devices"
+HOMEPAGE="http://pikdev.free.fr/"
+SRC_URI="http://pikdev.free.fr/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-qt/qtcore"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="${MY_PV/-*/}/doc/*.pdf"
+HTML_DOCS="${MY_PV/-*/}/doc/html/."
+
+src_prepare() {
+ # does not install docs in wrong path
+ sed -i -e '/INSTALLS += docs/d' "${PN}"*.pro || die 'sed failed.'
+
+ qt4-r2_src_prepare
+}
+
+src_install() {
+ qt4-r2_src_install
+
+ dosym "${PN}-${MY_PV/-*/}" "/usr/bin/${PN}"
+}