summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2004-03-15 02:18:57 +0000
committerSeemant Kulleen <seemant@gentoo.org>2004-03-15 02:18:57 +0000
commitd51bbdfad5011655e138afe211d10e767511e058 (patch)
treea07d2436e274ac50fe84120386acc5cf6e207948 /dev-embedded/avr-binutils
parentfix for (gcc-3 related?) build problem (diff)
downloadhistorical-d51bbdfad5011655e138afe211d10e767511e058.tar.gz
historical-d51bbdfad5011655e138afe211d10e767511e058.tar.bz2
historical-d51bbdfad5011655e138afe211d10e767511e058.zip
some SERIOUS f'ing cleanup on this ebuild
Diffstat (limited to 'dev-embedded/avr-binutils')
-rw-r--r--dev-embedded/avr-binutils/ChangeLog5
-rw-r--r--dev-embedded/avr-binutils/avr-binutils-2.14.ebuild51
2 files changed, 14 insertions, 42 deletions
diff --git a/dev-embedded/avr-binutils/ChangeLog b/dev-embedded/avr-binutils/ChangeLog
index 000c3089ef9d..c90a517119d9 100644
--- a/dev-embedded/avr-binutils/ChangeLog
+++ b/dev-embedded/avr-binutils/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-embedded/avr-binutils
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/avr-binutils/ChangeLog,v 1.3 2004/03/09 13:03:25 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/avr-binutils/ChangeLog,v 1.4 2004/03/15 02:11:47 seemant Exp $
+
+ 14 Mar 2004; Seemant Kulleen <seemant@gentoo.org> avr-binutils-2.14.ebuild:
+ some SERIOUS f'ing cleanup on this ebuild
*avr-binutils-2.14 (07 Mar 2004)
diff --git a/dev-embedded/avr-binutils/avr-binutils-2.14.ebuild b/dev-embedded/avr-binutils/avr-binutils-2.14.ebuild
index 092a36ee27f2..0641262a31f7 100644
--- a/dev-embedded/avr-binutils/avr-binutils-2.14.ebuild
+++ b/dev-embedded/avr-binutils/avr-binutils-2.14.ebuild
@@ -1,58 +1,27 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/avr-binutils/avr-binutils-2.14.ebuild,v 1.1 2004/03/07 19:23:27 pappy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/avr-binutils/avr-binutils-2.14.ebuild,v 1.2 2004/03/15 02:11:47 seemant Exp $
-DESCRIPTION="The GNU binutils for the AVR microcontroller architecture"
-
-# Homepage, not used by Portage directly but handy for developer reference
+IUSE="nls"
+MY_P=${P/avr-/}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="The GNU binutils for the AVR microcontroller architecture"
HOMEPAGE="http://sources.redhat.com/binutils"
-
-
-S="${WORKDIR}/binutils-2.14"
-
-A="binutils-2.14.tar.bz2"
-
-SRC_URI="http://ftp.gnu.org/gnu/binutils/${A}"
-
-LICENSE="GPL-2"
+SRC_URI="http://ftp.gnu.org/gnu/binutils/${MY_P}.tar.bz2"
SLOT="0"
-
+LICENSE="GPL-2"
KEYWORDS="x86"
-IUSE=""
-INSTALLDIR=/usr/
-MANDIR=/usr/share/man
-INFODIR=/usr/share/info
-
-# Build-time dependencies, such as
-# ssl? ( >=openssl-0.9.6b )
-# >=perl-5.6.1-r1
-# It is advisable to use the >= syntax show above, to reflect what you
-# had installed on your system when you tested the package. Then
-# other users hopefully won't be caught without the right version of
-# a dependency.
DEPEND="virtual/glibc"
-# Run-time dependencies, same as DEPEND if RDEPEND isn't defined:
-#RDEPEND=""
-
src_compile() {
- pwd
- ./configure \
- --host=${CHOST} \
- --target=avr \
- --prefix=${INSTALLDIR} \
- --infodir=${INFODIR} \
- --mandir=${MANDIR} || die "./configure failed"
-
+ econf \
+ `use_enable nls` || die
emake || die
}
src_install() {
- make prefix=${D}${INSTALLDIR} \
- mandir=${D}${MANDIR} \
- infodir=${D}${INFODIR} \
- install || die
+ einstall || die
}