summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2012-02-21 08:55:34 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2012-02-21 08:55:34 +0000
commitee0046990b7dd1e3faac98822dd7e6b93fa025de (patch)
tree1bf8c517a1e789ef8754c3fc178388534cd4a28e /dev-db
parentVersion bump. (diff)
downloadhistorical-ee0046990b7dd1e3faac98822dd7e6b93fa025de.tar.gz
historical-ee0046990b7dd1e3faac98822dd7e6b93fa025de.tar.bz2
historical-ee0046990b7dd1e3faac98822dd7e6b93fa025de.zip
Version bump.
Package-Manager: portage-2.2.0_alpha87/cvs/Linux x86_64
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/libdbi/ChangeLog10
-rw-r--r--dev-db/libdbi/files/libdbi-0.8.4-doc-build-fix.patch22
-rw-r--r--dev-db/libdbi/libdbi-0.8.4.ebuild54
-rw-r--r--dev-db/mysql/ChangeLog7
-rw-r--r--dev-db/mysql/mysql-5.5.21.ebuild129
5 files changed, 219 insertions, 3 deletions
diff --git a/dev-db/libdbi/ChangeLog b/dev-db/libdbi/ChangeLog
index 3998ad8f2173..eb10d5848b0b 100644
--- a/dev-db/libdbi/ChangeLog
+++ b/dev-db/libdbi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/libdbi
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/libdbi/ChangeLog,v 1.40 2009/09/23 16:33:36 patrick Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libdbi/ChangeLog,v 1.41 2012/02/21 08:55:32 robbat2 Exp $
+
+*libdbi-0.8.4 (21 Feb 2012)
+
+ 21 Feb 2012; Robin H. Johnson <robbat2@gentoo.org>
+ +files/libdbi-0.8.4-doc-build-fix.patch, +libdbi-0.8.4.ebuild:
+ Version bump.
23 Sep 2009; Patrick Lauer <patrick@gentoo.org> libdbi-0.8.1.ebuild,
libdbi-0.8.3.ebuild:
diff --git a/dev-db/libdbi/files/libdbi-0.8.4-doc-build-fix.patch b/dev-db/libdbi/files/libdbi-0.8.4-doc-build-fix.patch
new file mode 100644
index 000000000000..2891a7839002
--- /dev/null
+++ b/dev-db/libdbi/files/libdbi-0.8.4-doc-build-fix.patch
@@ -0,0 +1,22 @@
+diff -Nuar libdbi-0.8.4.orig/configure.in libdbi-0.8.4/configure.in
+--- libdbi-0.8.4.orig/configure.in 2012-02-21 08:36:15.560231962 +0000
++++ libdbi-0.8.4/configure.in 2012-02-21 08:39:07.910615238 +0000
+@@ -147,14 +147,13 @@
+ dnl See whether to build the docs
+ dnl ==============================
+
+-ac_docs="YES"
++ac_docs="yes"
+ AC_ARG_ENABLE(docs,
+ [ --disable-docs do not build and install the documentation.],
+- [ if test "$enable_docs" = "no"; then
+- ac_docs="NO"
+- fi ])
++ [ ac_docs="$enableval" ],
++ [ ac_docs="no" ])
+
+-if test "$ac_docs" = "YES"; then
++if test "$ac_docs" = "yes"; then
+ dnl AC_PATH_PROGS(myjade, openjade jade)
+ dnl if test "x$myjade" != "x"; then
+ docs_subdirs="doc"
diff --git a/dev-db/libdbi/libdbi-0.8.4.ebuild b/dev-db/libdbi/libdbi-0.8.4.ebuild
new file mode 100644
index 000000000000..07e57c0f42ed
--- /dev/null
+++ b/dev-db/libdbi/libdbi-0.8.4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libdbi/libdbi-0.8.4.ebuild,v 1.1 2012/02/21 08:55:32 robbat2 Exp $
+
+EAPI=4
+
+inherit eutils autotools multilib
+
+DESCRIPTION="libdbi implements a database-independent abstraction layer in C, similar to the DBI/DBD layer in Perl."
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://libdbi.sourceforge.net/"
+LICENSE="LGPL-2.1"
+RDEPEND=""
+DEPEND=">=sys-apps/sed-4
+ dev-util/pkgconfig
+ doc? ( app-text/openjade )
+ ${RDEPEND}"
+PDEPEND=">=dev-db/libdbi-drivers-0.8.3" # On purpose, libdbi-drivers 0.8.4 does not exist
+IUSE="doc"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+SLOT=0
+
+src_unpack() {
+ unpack ${A}
+ chown -R portage:portage "${S}"
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/libdbi-0.8.1-pkg-config.patch
+ cp -f "${FILESDIR}"/dbi.pc.in "${S}"/dbi.pc.in
+ epatch "${FILESDIR}"/libdbi-0.8.4-doc-build-fix.patch
+
+ # configure.in has been changed
+ eautoreconf || die "eautoreconf failed"
+ # should append CFLAGS, not replace them
+ sed -i.orig -e 's/^CFLAGS = /CFLAGS += /g' src/Makefile.in
+}
+
+src_configure() {
+ econf $(use_enable doc docs) || die "econf failed"
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install () {
+ emake install DESTDIR="${ED}" || die "make install failed"
+ dodoc AUTHORS ChangeLog README README.osx TODO
+
+ # syslog-ng requires dbi.pc
+ insinto /usr/$(get_libdir)/pkgconfig/
+ doins dbi.pc
+}
diff --git a/dev-db/mysql/ChangeLog b/dev-db/mysql/ChangeLog
index cc4928321ccb..5d5cdb4f291b 100644
--- a/dev-db/mysql/ChangeLog
+++ b/dev-db/mysql/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/mysql
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.604 2012/02/15 02:07:21 jmbsvicetto Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.605 2012/02/21 08:55:34 robbat2 Exp $
+
+*mysql-5.5.21 (21 Feb 2012)
+
+ 21 Feb 2012; Robin H. Johnson <robbat2@gentoo.org> +mysql-5.5.21.ebuild:
+ Version bump.
15 Feb 2012; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
files/my.cnf-5.1:
diff --git a/dev-db/mysql/mysql-5.5.21.ebuild b/dev-db/mysql/mysql-5.5.21.ebuild
new file mode 100644
index 000000000000..89f04579bc5b
--- /dev/null
+++ b/dev-db/mysql/mysql-5.5.21.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.5.21.ebuild,v 1.1 2012/02/21 08:55:34 robbat2 Exp $
+
+EAPI="4"
+
+MY_EXTRAS_VER="20111118-2347Z"
+MY_PV="${PV//_alpha_pre/-m}"
+MY_PV="${MY_PV//_/-}"
+
+# Build type
+BUILD="cmake"
+
+inherit toolchain-funcs mysql-v2
+# only to make repoman happy. it is really set in the eclass
+IUSE="$IUSE"
+
+# Define the mysql-extras source
+EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/mysql-extras.git"
+
+# REMEMBER: also update eclass/mysql*.eclass before committing!
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+
+# When MY_EXTRAS is bumped, the index should be revised to exclude these.
+EPATCH_EXCLUDE=''
+
+DEPEND="|| ( >=sys-devel/gcc-3.4.6 >=sys-devel/gcc-apple-4.0 )"
+RDEPEND="${RDEPEND}"
+
+# Please do not add a naive src_unpack to this ebuild
+# If you want to add a single patch, copy the ebuild to an overlay
+# and create your own mysql-extras tarball, looking at 000_index.txt
+
+# Official test instructions:
+# USE='berkdb -cluster embedded extraengine perl ssl community' \
+# FEATURES='test userpriv -usersandbox' \
+# ebuild mysql-X.X.XX.ebuild \
+# digest clean package
+src_test() {
+
+ local TESTDIR="${CMAKE_BUILD_DIR}/mysql-test"
+ local retstatus_unit
+ local retstatus_tests
+
+ # Bug #213475 - MySQL _will_ object strenously if your machine is named
+ # localhost. Also causes weird failures.
+ [[ "${HOSTNAME}" == "localhost" ]] && die "Your machine must NOT be named localhost"
+
+ if ! use "minimal" ; then
+
+ if [[ $UID -eq 0 ]]; then
+ die "Testing with FEATURES=-userpriv is no longer supported by upstream. Tests MUST be run as non-root."
+ fi
+ has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox"
+
+ einfo ">>> Test phase [test]: ${CATEGORY}/${PF}"
+ addpredict /this-dir-does-not-exist/t9.MYI
+
+ # Run CTest (test-units)
+ cmake-utils_src_test
+ retstatus_unit=$?
+ [[ $retstatus_unit -eq 0 ]] || eerror "test-unit failed"
+
+ # Ensure that parallel runs don't die
+ export MTR_BUILD_THREAD="$((${RANDOM} % 100))"
+
+ # create directories because mysqladmin might right out of order
+ mkdir -p "${S}"/mysql-test/var-{tests}{,/log}
+
+ # These are failing in MySQL 5.5 for now and are believed to be
+ # false positives:
+ #
+ # main.information_schema, binlog.binlog_statement_insert_delayed,
+ # main.mysqld--help-notwin
+ # fails due to USE=-latin1 / utf8 default
+ #
+ # main.mysql_client_test:
+ # segfaults at random under Portage only, suspect resource limits.
+ #
+ # sys_vars.plugin_dir_basic
+ # fails because PLUGIN_DIR is set to MYSQL_LIBDIR64/plugin
+ # instead of MYSQL_LIBDIR/plugin
+ #
+ # main.flush_read_lock_kill
+ # fails because of unknown system variable 'DEBUG_SYNC'
+ #
+ # main.openssl_1
+ # error message changing
+ # -mysqltest: Could not open connection 'default': 2026 SSL connection
+ # error: ASN: bad other signature confirmation
+ # +mysqltest: Could not open connection 'default': 2026 SSL connection
+ # error: error:00000001:lib(0):func(0):reason(1)
+ #
+
+ for t in main.mysql_client_test \
+ binlog.binlog_statement_insert_delayed main.information_schema \
+ main.mysqld--help-notwin main.flush_read_lock_kill \
+ sys_vars.plugin_dir_basic main.openssl_1 ; do
+ mysql-v2_disable_test "$t" "False positives in Gentoo"
+ done
+
+ # Run mysql tests
+ pushd "${TESTDIR}"
+
+ # run mysql-test tests
+ perl mysql-test-run.pl --force --vardir="${S}/mysql-test/var-tests"
+ retstatus_tests=$?
+ [[ $retstatus_tests -eq 0 ]] || eerror "tests failed"
+ has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox"
+
+ popd
+
+ # Cleanup is important for these testcases.
+ pkill -9 -f "${S}/ndb" 2>/dev/null
+ pkill -9 -f "${S}/sql" 2>/dev/null
+
+ failures=""
+ [[ $retstatus_unit -eq 0 ]] || failures="${failures} test-unit"
+ [[ $retstatus_tests -eq 0 ]] || failures="${failures} tests"
+ has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox"
+
+ [[ -z "$failures" ]] || die "Test failures: $failures"
+ einfo "Tests successfully completed"
+
+ else
+
+ einfo "Skipping server tests due to minimal build."
+ fi
+}