summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorKarol Wojtaszek <sekretarz@gentoo.org>2004-09-14 16:08:11 +0000
committerKarol Wojtaszek <sekretarz@gentoo.org>2004-09-14 16:08:11 +0000
commitb22706e7b5a7be698f2d60811e30a2a1a375da56 (patch)
tree47c08c9d4a776f3cb8c3d704638d34f70e3a70d7 /dev-db
parentStable on hppa. (diff)
downloadhistorical-b22706e7b5a7be698f2d60811e30a2a1a375da56.tar.gz
historical-b22706e7b5a7be698f2d60811e30a2a1a375da56.tar.bz2
historical-b22706e7b5a7be698f2d60811e30a2a1a375da56.zip
Fixing patch for gcc-3.4, now it works with gcc-3.3 :)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/firebird/ChangeLog6
-rw-r--r--dev-db/firebird/Manifest4
-rw-r--r--dev-db/firebird/files/firebird-1.5.1-gcc34.patch20
3 files changed, 19 insertions, 11 deletions
diff --git a/dev-db/firebird/ChangeLog b/dev-db/firebird/ChangeLog
index 414f122b53d3..94542af566de 100644
--- a/dev-db/firebird/ChangeLog
+++ b/dev-db/firebird/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-db/firebird
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/firebird/ChangeLog,v 1.24 2004/09/13 19:08:17 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/firebird/ChangeLog,v 1.25 2004/09/14 16:08:11 sekretarz Exp $
+
+ 14 Sep 2004; Karol Wojtaszek <sekretarz@gentoo.org>
+ files/firebird-1.5.1-gcc34.patch:
+ Fixing patch for gcc-3.4, now it works with gcc-3.3 :)
13 Sep 2004; Carsten Lohrke <carlo@gentoo.org>
-files/firebird-1.0-gentoo.patch, -files/firebird-1.0.3-gentoo.patch,
diff --git a/dev-db/firebird/Manifest b/dev-db/firebird/Manifest
index c3d29249ba89..40d6bc31d9a6 100644
--- a/dev-db/firebird/Manifest
+++ b/dev-db/firebird/Manifest
@@ -1,10 +1,10 @@
MD5 a937e33e83997615b610b3624c9ffce2 firebird-1.5.1.ebuild 6380
-MD5 399f2bdef67c27381deb0dd8692ebe40 ChangeLog 3683
+MD5 e755b4669ee93d289a2554d654a3ba7f ChangeLog 3835
MD5 c5f5e6bae2cae891269931331e69f1ca files/firebird.conf.d 80
MD5 19238be258dea758cf3f082df5ae813a files/firebird.init.d 697
MD5 d3278f869be37481ddde143f5ee98c4a files/70firebird-1.5.0 50
MD5 b0d6de21d0e14d41983d440d5675e9d5 files/firebird.xinetd 206
MD5 5b28cc81eff2c59fbee652dc2c6ed483 files/firebird-1.5.0.xinetd 425
-MD5 228f9ea2d6f609009a96bc5592142e19 files/firebird-1.5.1-gcc34.patch 5735
+MD5 5bc644b4558c11069e2a946e029d70bb files/firebird-1.5.1-gcc34.patch 5906
MD5 a71afe7683db444d9647fc136eaeb1c1 files/70firebird 77
MD5 606e690fe61535cc02d7314616e263fb files/digest-firebird-1.5.1 73
diff --git a/dev-db/firebird/files/firebird-1.5.1-gcc34.patch b/dev-db/firebird/files/firebird-1.5.1-gcc34.patch
index f5ddb4bac4bd..e5df4841b3d2 100644
--- a/dev-db/firebird/files/firebird-1.5.1-gcc34.patch
+++ b/dev-db/firebird/files/firebird-1.5.1-gcc34.patch
@@ -1,27 +1,30 @@
diff -uNr firebird-1.5.1.4481-orig/src/common/classes/alloc.h firebird-1.5.1.4481/src/common/classes/alloc.h
--- firebird-1.5.1.4481-orig/src/common/classes/alloc.h 2003-10-30 22:25:52.000000000 +0000
-+++ firebird-1.5.1.4481/src/common/classes/alloc.h 2004-09-12 11:26:47.351584232 +0000
-@@ -237,12 +237,14 @@
++++ firebird-1.5.1.4481/src/common/classes/alloc.h 2004-09-14 04:12:37.967099632 +0000
+@@ -237,12 +237,17 @@
// loaded by host application using STL
// This is to prevent inclusion of <new> header
-#ifdef __NEW__
-+#ifdef _NEW
++#if defined( _NEW ) || defined ( __NEW__ )
#error "alloc.h must be included before <new>"
#endif
--#define __NEW__
+#define _NEW
+ #define __NEW__
namespace std {
class bad_alloc : public exception {};
++#if ( __GNUC__ > 3) || ((__GNUC__==3) && __GNUC_MINOR__ >=4)
+ struct nothrow_t { };
+ extern const nothrow_t nothrow;
++#endif
}
// Define operators as static inline to prevent replacement of STL versions
static inline void* operator new(size_t s) {
-@@ -258,6 +260,19 @@
+@@ -258,6 +263,21 @@
);
}
++#if ( __GNUC__ > 3) || ((__GNUC__==3) && __GNUC_MINOR__ >=4)
+static inline void* operator new(size_t s, const std::nothrow_t&) {
+#if defined(DEV_BUILD)
+// Do not complain here. It causes client tools to crash on Red Hat 8.0
@@ -34,13 +37,14 @@ diff -uNr firebird-1.5.1.4481-orig/src/common/classes/alloc.h firebird-1.5.1.448
+#endif
+ );
+}
++#endif
+
static inline void* operator new[](size_t s) {
#if defined(DEV_BUILD)
// Do not complain here. It causes client tools to crash on Red Hat 8.0
diff -uNr firebird-1.5.1.4481-orig/src/common/classes/array.h firebird-1.5.1.4481/src/common/classes/array.h
--- firebird-1.5.1.4481-orig/src/common/classes/array.h 2004-03-29 07:40:23.000000000 +0000
-+++ firebird-1.5.1.4481/src/common/classes/array.h 2004-09-12 11:31:34.555922536 +0000
++++ firebird-1.5.1.4481/src/common/classes/array.h 2004-09-14 04:10:26.267121072 +0000
@@ -60,15 +60,15 @@
class Array : private Storage {
public:
@@ -93,7 +97,7 @@ diff -uNr firebird-1.5.1.4481-orig/src/common/classes/array.h firebird-1.5.1.448
int pos;
diff -uNr firebird-1.5.1.4481-orig/src/common/classes/tree.h firebird-1.5.1.4481/src/common/classes/tree.h
--- firebird-1.5.1.4481-orig/src/common/classes/tree.h 2003-10-30 22:25:52.000000000 +0000
-+++ firebird-1.5.1.4481/src/common/classes/tree.h 2004-09-12 11:22:54.754944296 +0000
++++ firebird-1.5.1.4481/src/common/classes/tree.h 2004-09-14 04:10:26.268120920 +0000
@@ -215,7 +215,7 @@
}
Value& current() const { return (*curr)[curPos]; }
@@ -114,7 +118,7 @@ diff -uNr firebird-1.5.1.4481-orig/src/common/classes/tree.h firebird-1.5.1.4481
if (level) {
diff -uNr firebird-1.5.1.4481-orig/src/common/classes/vector.h firebird-1.5.1.4481/src/common/classes/vector.h
--- firebird-1.5.1.4481-orig/src/common/classes/vector.h 2002-12-14 21:43:18.000000000 +0000
-+++ firebird-1.5.1.4481/src/common/classes/vector.h 2004-09-12 11:23:25.422282152 +0000
++++ firebird-1.5.1.4481/src/common/classes/vector.h 2004-09-14 04:10:26.268120920 +0000
@@ -100,17 +100,17 @@
public:
SortedVector() : Vector<Value, Capacity>() {}