summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorPieter van den Abeele <pvdabeel@gentoo.org>2002-08-13 19:49:30 +0000
committerPieter van den Abeele <pvdabeel@gentoo.org>2002-08-13 19:49:30 +0000
commitae4bcc8a5ada21926b6fd3d0e7b490c229259a5d (patch)
treefd7f0609b465b6e4cf265042198ab229ff58c960 /dev-db
parentAdded ppc keyword (diff)
downloadhistorical-ae4bcc8a5ada21926b6fd3d0e7b490c229259a5d.tar.gz
historical-ae4bcc8a5ada21926b6fd3d0e7b490c229259a5d.tar.bz2
historical-ae4bcc8a5ada21926b6fd3d0e7b490c229259a5d.zip
lintoolize
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/postgresql/postgresql-7.0.3-r3.ebuild11
-rw-r--r--dev-db/postgresql/postgresql-7.1-r1.ebuild12
-rw-r--r--dev-db/postgresql/postgresql-7.2.1-r1.ebuild3
3 files changed, 13 insertions, 13 deletions
diff --git a/dev-db/postgresql/postgresql-7.0.3-r3.ebuild b/dev-db/postgresql/postgresql-7.0.3-r3.ebuild
index 758905265a17..ba6f67f7d70c 100644
--- a/dev-db/postgresql/postgresql-7.0.3-r3.ebuild
+++ b/dev-db/postgresql/postgresql-7.0.3-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.0.3-r3.ebuild,v 1.5 2002/08/01 11:58:59 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.0.3-r3.ebuild,v 1.6 2002/08/13 19:49:30 pvdabeel Exp $
S=${WORKDIR}/${P}/src
DESCRIPTION="PostgreSQL is a sophisticated Object-Relational DBMS"
@@ -9,6 +9,7 @@ HOMEPAGE="http://postgresql.readysetnet.com/"
LICENSE="POSTGRESQL"
SLOT="0"
DEPEND=">=dev-lang/tk-8"
+RDEPEND=""
KEYWORDS="x86"
src_unpack() {
@@ -21,14 +22,14 @@ src_unpack() {
src_compile() {
cd ${S}
- try ./configure --prefix=/usr --host=${CHOST} \
- --enable-locale --with-tcl --enable-syslog
+ ./configure --prefix=/usr --host=${CHOST} \
+ --enable-locale --with-tcl --enable-syslog || die
cp Makefile.global Makefile.orig
sed -e "s:^TEMPLATEDIR=.*:TEMPLATEDIR=\$(POSTGRESDIR)/lib/pgsql:" \
-e "s:^HEADERDIR=.*:HEADERDIR=\$(POSTGRESDIR)/include/pgsql:" \
-e "s:-O2:${CFLAGS}:" \
Makefile.orig > Makefile.global
- try make
+ make || die
}
@@ -36,7 +37,7 @@ src_install () {
cd ${S}
dodir /usr/include/pgsql
- try make POSTGRESDIR=${D}/usr install
+ make POSTGRESDIR=${D}/usr install || die
dosed "s:/usr/pgaccess:/usr/lib/pgaccess:" /usr/bin/pgaccess
cd ${D}/usr
mv pgaccess lib
diff --git a/dev-db/postgresql/postgresql-7.1-r1.ebuild b/dev-db/postgresql/postgresql-7.1-r1.ebuild
index 3f5a7ba55f51..fc4c10c23c88 100644
--- a/dev-db/postgresql/postgresql-7.1-r1.ebuild
+++ b/dev-db/postgresql/postgresql-7.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.1-r1.ebuild,v 1.7 2002/08/13 19:43:43 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.1-r1.ebuild,v 1.8 2002/08/13 19:49:30 pvdabeel Exp $
S=${WORKDIR}/${P}
DESCRIPTION="PostgreSQL is a sophisticated Object-Relational DBMS"
@@ -76,17 +76,17 @@ src_compile() {
then
myconf="$myconf --enable-locale"
fi
- try autoconf
+ autoconf || die
unset ROOT
- try ./configure --prefix=/usr --mandir=/usr/share/man --host=${CHOST} \
- --enable-syslog $myconf
- try make
+ ./configure --prefix=/usr --mandir=/usr/share/man --host=${CHOST} \
+ --enable-syslog $myconf || die
+ make || die
}
src_install () {
- try make DESTDIR=${D} install
+ make DESTDIR=${D} install || die
dodoc COPYRIGHT HISTORY README register.txt
cd ${S}/doc
dodoc FAQ* KNOWN_BUGS MISSING_FEATURES README*
diff --git a/dev-db/postgresql/postgresql-7.2.1-r1.ebuild b/dev-db/postgresql/postgresql-7.2.1-r1.ebuild
index 38faa73ab10d..cdf0e0d61bd9 100644
--- a/dev-db/postgresql/postgresql-7.2.1-r1.ebuild
+++ b/dev-db/postgresql/postgresql-7.2.1-r1.ebuild
@@ -1,7 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Geert Bevin <gbevin@theleaf.be>
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.2.1-r1.ebuild,v 1.12 2002/07/23 02:57:16 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.2.1-r1.ebuild,v 1.13 2002/08/13 19:49:30 pvdabeel Exp $
S=${WORKDIR}/${P}
DESCRIPTION="PostgreSQL is a sophisticated Object-Relational DBMS"