summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorFrancesco Riosa <vivo@gentoo.org>2005-09-12 16:05:45 +0000
committerFrancesco Riosa <vivo@gentoo.org>2005-09-12 16:05:45 +0000
commit04056a4776d08cc3e1245127387e6067af93f18c (patch)
tree6c9cf0738cd61fd369625d4f7b5f86710473a17b /dev-db
parentMark 1.8.4 stable on alpha (diff)
downloadhistorical-04056a4776d08cc3e1245127387e6067af93f18c.tar.gz
historical-04056a4776d08cc3e1245127387e6067af93f18c.tar.bz2
historical-04056a4776d08cc3e1245127387e6067af93f18c.zip
Temporary bug fix for bug #105534, disabling some test of the suite
Package-Manager: portage-2.0.52-r1
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/mysql/ChangeLog6
-rw-r--r--dev-db/mysql/Manifest8
-rw-r--r--dev-db/mysql/mysql-4.1.13-r1.ebuild24
-rw-r--r--dev-db/mysql/mysql-4.1.14.ebuild26
-rw-r--r--dev-db/mysql/mysql-5.0.12_beta.ebuild24
5 files changed, 79 insertions, 9 deletions
diff --git a/dev-db/mysql/ChangeLog b/dev-db/mysql/ChangeLog
index 7b7061f2d60b..a7701431d375 100644
--- a/dev-db/mysql/ChangeLog
+++ b/dev-db/mysql/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-db/mysql
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.235 2005/09/12 14:58:15 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.236 2005/09/12 16:05:45 vivo Exp $
+
+ 12 Sep 2005; Francesco Riosa <vivo@gentoo.org> mysql-4.1.13-r1.ebuild,
+ mysql-4.1.14.ebuild, mysql-5.0.12_beta.ebuild:
+ Temporary bug fix for bug #105534, disabling some test of the suite
12 Sep 2005; Francesco Riosa <vivo@gentoo.org> mysql-4.0.22-r2.ebuild,
mysql-4.0.24.ebuild, mysql-4.0.25-r2.ebuild, mysql-4.0.26.ebuild,
diff --git a/dev-db/mysql/Manifest b/dev-db/mysql/Manifest
index d1a19464adc3..919c893c1fab 100644
--- a/dev-db/mysql/Manifest
+++ b/dev-db/mysql/Manifest
@@ -1,12 +1,12 @@
-MD5 2b2f161e014867ce5e15262ffec581a7 mysql-5.0.12_beta.ebuild 16892
-MD5 a9831baf4774009031fd6bc2477ddb01 mysql-4.1.14.ebuild 16757
+MD5 6a087609d66875c7e2aed46c49f6008d mysql-5.0.12_beta.ebuild 17757
+MD5 481f8911da885c2af83e7811634dae1e mysql-4.1.14.ebuild 17632
MD5 6f9d7b6c5292d432e859729eecd426a0 mysql-4.0.26.ebuild 13674
-MD5 80029ae771cba88c096426b7e4a34438 mysql-4.1.13-r1.ebuild 16349
+MD5 0e7b64bdf9b103a1133ee6f82de04252 mysql-4.1.13-r1.ebuild 17214
MD5 d168c71df57729ea0eeadab3c6a59f43 mysql-4.0.22.ebuild 8768
MD5 92fc2eaf2ef09d494ee45b25e57c6087 mysql-4.0.22-r2.ebuild 9569
MD5 0cfd7831f2d57b93e252c0f3d9c25276 mysql-3.23.58-r1.ebuild 7063
MD5 de9bc44b9100cfff7b5ee2296d727910 mysql-4.0.24.ebuild 9840
-MD5 a17bbab3a3e2ed28bb06138e13020229 ChangeLog 41138
+MD5 9532ce055a8bc3c9dd46efdc32da15ff ChangeLog 41331
MD5 a2a9fdc7d010a7c04c96cb3b7c05f06b metadata.xml 158
MD5 06056877b1940a0df66415d32bbe782c mysql-4.0.25-r2.ebuild 13805
MD5 a755fb5a3ed724046a4f83fafd819c77 files/mysql-test-myisam-geometry.patch 1217
diff --git a/dev-db/mysql/mysql-4.1.13-r1.ebuild b/dev-db/mysql/mysql-4.1.13-r1.ebuild
index 08aefc06abd4..f2abfdb59c7c 100644
--- a/dev-db/mysql/mysql-4.1.13-r1.ebuild
+++ b/dev-db/mysql/mysql-4.1.13-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-4.1.13-r1.ebuild,v 1.7 2005/09/12 14:58:15 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-4.1.13-r1.ebuild,v 1.8 2005/09/12 16:05:45 vivo Exp $
inherit eutils gnuconfig flag-o-matic versionator
@@ -161,6 +161,28 @@ src_unpack() {
# -e "s/\<clear_bit\>/my__clear_bit/g" \
# ${S}/client/mysqltest.c || die "Failed to fix bitops"
+ # Temporary workaround for bug in test suite, a correct solution
+ # should work inside the include files to enable/disable the tests
+ # for the current configuration
+
+ if ! useq extraengine ; then
+ einfo "disabling unneded extraengine tests"
+ local disable_test="archive bdb blackhole federated view"
+ for i in $disable_test ; do
+ mv "${S}/mysql-test/t/${i}.test" "${S}/mysql-test/t/${i}.disabled" \
+ &> /dev/null
+ done
+ fi
+
+
+ if ! useq berkdb ; then
+ einfo "disabling unneded berkdb tests"
+ local disable_test="auto_increment bdb-alter-table-1 bdb-alter-table-2 bdb-crash bdb-deadlock bdb bdb_cache binlog ctype_sjis ctype_utf8 heap_auto_increment index_merge_bdb multi_update mysqldump ps_1general ps_6bdb rowid_order_bdb"
+ for i in $disable_test ; do
+ mv "${S}/mysql-test/t/${i}.test" "${S}/mysql-test/t/${i}.disabled" \
+ &> /dev/null
+ done
+ fi
}
src_compile() {
diff --git a/dev-db/mysql/mysql-4.1.14.ebuild b/dev-db/mysql/mysql-4.1.14.ebuild
index 72560c17c047..728defc3ba21 100644
--- a/dev-db/mysql/mysql-4.1.14.ebuild
+++ b/dev-db/mysql/mysql-4.1.14.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-4.1.14.ebuild,v 1.4 2005/09/12 14:58:15 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-4.1.14.ebuild,v 1.5 2005/09/12 16:05:45 vivo Exp $
-inherit eutils flag-o-matic versionator
+inherit eutils gnuconfig flag-o-matic versionator
SVER=${PV%.*}
NEWP="${PN}-${PV}"
@@ -159,6 +159,28 @@ src_unpack() {
gnuconfig_update
done
+ # Temporary workaround for bug in test suite, a correct solution
+ # should work inside the include files to enable/disable the tests
+ # for the current configuration
+
+ if ! useq extraengine ; then
+ einfo "disabling unneded extraengine tests"
+ local disable_test="archive bdb blackhole federated view"
+ for i in $disable_test ; do
+ mv "${S}/mysql-test/t/${i}.test" "${S}/mysql-test/t/${i}.disabled" \
+ &> /dev/null
+ done
+ fi
+
+
+ if ! useq berkdb ; then
+ einfo "disabling unneded berkdb tests"
+ local disable_test="auto_increment bdb-alter-table-1 bdb-alter-table-2 bdb-crash bdb-deadlock bdb bdb_cache binlog ctype_sjis ctype_utf8 heap_auto_increment index_merge_bdb multi_update mysqldump ps_1general ps_6bdb rowid_order_bdb"
+ for i in $disable_test ; do
+ mv "${S}/mysql-test/t/${i}.test" "${S}/mysql-test/t/${i}.disabled" \
+ &> /dev/null
+ done
+ fi
}
src_compile() {
diff --git a/dev-db/mysql/mysql-5.0.12_beta.ebuild b/dev-db/mysql/mysql-5.0.12_beta.ebuild
index 8fbb9264dc0b..812f3830690c 100644
--- a/dev-db/mysql/mysql-5.0.12_beta.ebuild
+++ b/dev-db/mysql/mysql-5.0.12_beta.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.12_beta.ebuild,v 1.5 2005/09/12 14:58:15 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.12_beta.ebuild,v 1.6 2005/09/12 16:05:45 vivo Exp $
inherit eutils flag-o-matic versionator
@@ -115,6 +115,28 @@ pkg_setup() {
enewuser mysql 60 -1 /dev/null mysql \
|| die "problem adding user mysql"
+ # Temporary workaround for bug in test suite, a correct solution
+ # should work inside the include files to enable/disable the tests
+ # for the current configuration
+
+ if ! useq extraengine ; then
+ einfo "disabling unneded extraengine tests"
+ local disable_test="archive bdb blackhole federated view"
+ for i in $disable_test ; do
+ mv "${S}/mysql-test/t/${i}.test" "${S}/mysql-test/t/${i}.disabled" \
+ &> /dev/null
+ done
+ fi
+
+
+ if ! useq berkdb ; then
+ einfo "disabling unneded berkdb tests"
+ local disable_test="auto_increment bdb-alter-table-1 bdb-alter-table-2 bdb-crash bdb-deadlock bdb bdb_cache binlog ctype_sjis ctype_utf8 heap_auto_increment index_merge_bdb multi_update mysqldump ps_1general ps_6bdb rowid_order_bdb"
+ for i in $disable_test ; do
+ mv "${S}/mysql-test/t/${i}.test" "${S}/mysql-test/t/${i}.disabled" \
+ &> /dev/null
+ done
+ fi
}
src_unpack() {