summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2008-12-27 12:36:03 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2008-12-27 12:36:03 +0000
commite82fa963edcdea4a2dd6c41f73db34d18389408c (patch)
tree1d73efeb17fcd003b34a89a1f4cb7bb74d60e56d /dev-db/oracle-instantclient-sqlplus
parentforcing env-update and added elog to ask user to source /etc/profile (#244314) (diff)
downloadhistorical-e82fa963edcdea4a2dd6c41f73db34d18389408c.tar.gz
historical-e82fa963edcdea4a2dd6c41f73db34d18389408c.tar.bz2
historical-e82fa963edcdea4a2dd6c41f73db34d18389408c.zip
Version bump, #228803
Package-Manager: portage-2.2_rc19/cvs/Linux 2.6.28-gentoo i686
Diffstat (limited to 'dev-db/oracle-instantclient-sqlplus')
-rw-r--r--dev-db/oracle-instantclient-sqlplus/ChangeLog8
-rw-r--r--dev-db/oracle-instantclient-sqlplus/oracle-instantclient-sqlplus-11.1.0.7.0.ebuild66
2 files changed, 73 insertions, 1 deletions
diff --git a/dev-db/oracle-instantclient-sqlplus/ChangeLog b/dev-db/oracle-instantclient-sqlplus/ChangeLog
index 2560042e4d2e..87ee5541c644 100644
--- a/dev-db/oracle-instantclient-sqlplus/ChangeLog
+++ b/dev-db/oracle-instantclient-sqlplus/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/oracle-instantclient-sqlplus
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/oracle-instantclient-sqlplus/ChangeLog,v 1.23 2008/06/18 22:35:36 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/oracle-instantclient-sqlplus/ChangeLog,v 1.24 2008/12/27 12:36:03 dertobi123 Exp $
+
+*oracle-instantclient-sqlplus-11.1.0.7.0 (27 Dec 2008)
+
+ 27 Dec 2008; Tobias Scherbaum <dertobi123@gentoo.org>
+ +oracle-instantclient-sqlplus-11.1.0.7.0.ebuild:
+ Version bump, #228803
18 Jun 2008; Chris Gianelloni <wolf31o2@gentoo.org>
oracle-instantclient-sqlplus-10.2.0.3.ebuild:
diff --git a/dev-db/oracle-instantclient-sqlplus/oracle-instantclient-sqlplus-11.1.0.7.0.ebuild b/dev-db/oracle-instantclient-sqlplus/oracle-instantclient-sqlplus-11.1.0.7.0.ebuild
new file mode 100644
index 000000000000..ac72170375c8
--- /dev/null
+++ b/dev-db/oracle-instantclient-sqlplus/oracle-instantclient-sqlplus-11.1.0.7.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/oracle-instantclient-sqlplus/oracle-instantclient-sqlplus-11.1.0.7.0.ebuild,v 1.1 2008/12/27 12:36:03 dertobi123 Exp $
+
+inherit eutils
+
+MY_P_x86="${PN/oracle-/}-linux32-${PV/7.0/7}"
+MY_P_amd64="${PN/oracle-instantclient-/}-${PV}-linux-x86_64"
+
+S="${WORKDIR}"
+DESCRIPTION="Oracle 10g client installation for Linux: SQL*Plus"
+HOMEPAGE="http://www.oracle.com/technology/tech/oci/instantclient/index.html"
+SRC_URI="amd64? ( ${MY_P_amd64}.zip )
+ x86? ( ${MY_P_x86}.zip )"
+
+LICENSE="OTN"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="fetch"
+IUSE=""
+
+RDEPEND=">=dev-db/oracle-instantclient-basic-${PV}"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+pkg_setup() {
+ MY_P=MY_P_${ARCH}
+ export MY_P=${!MY_P}
+}
+
+pkg_nofetch() {
+ eerror "Please go to:"
+ eerror " ${HOMEPAGE}"
+ eerror "select your platform and download the"
+ eerror "SQL*Plus package. Put it in:"
+ eerror " ${DISTDIR}"
+ eerror "after downloading it."
+}
+
+src_unpack() {
+ unzip "${DISTDIR}"/${MY_P}.zip
+}
+
+src_install() {
+ dodir /usr/$(get_libdir)/oracle/${PV}/client/lib
+ cd "${S}"/instantclient_11_1
+ insinto /usr/$(get_libdir)/oracle/${PV}/client/lib
+ doins glogin.sql libsqlplus.so libsqlplusic.so
+
+ dodir /usr/$(get_libdir)/oracle/${PV}/client/bin
+ cd "${S}"/instantclient_11_1
+ exeinto /usr/$(get_libdir)/oracle/${PV}/client/bin
+ doexe sqlplus
+
+ dodir /usr/bin
+ dosym "${D}"/usr/$(get_libdir)/oracle/${PV}/client/bin/sqlplus /usr/bin/sqlplus
+}
+
+pkg_postinst() {
+ elog "The SQL*Plus package for Oracle 10g has been installed."
+ elog "You may wish to install the oracle-instantclient-jdbc (for"
+ elog "the supplemental JDBC functionality) package as well."
+ elog
+ elog "If you have any questions, be sure to read the README:"
+ elog "http://otn.oracle.com/docs/tech/sql_plus/10102/readme_ic.htm"
+}