summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2004-05-25 01:45:56 +0000
committerJoshua Kinard <kumba@gentoo.org>2004-05-25 01:45:56 +0000
commit72a979ec41db888dfa6c9d9b379c2b9b6d89938c (patch)
treee61b52d899d4a17149aee37d36b518ce3e268337 /dev-db/mysql/mysql-4.0.18-r1.ebuild
parentarm KEYWORDS (diff)
downloadhistorical-72a979ec41db888dfa6c9d9b379c2b9b6d89938c.tar.gz
historical-72a979ec41db888dfa6c9d9b379c2b9b6d89938c.tar.bz2
historical-72a979ec41db888dfa6c9d9b379c2b9b6d89938c.zip
Marked 4.0.18-r2 stable on mips, removed berkdb check on mips from pkg_setup, and added mips to list of arches that need to build w/o berkdb.
Diffstat (limited to 'dev-db/mysql/mysql-4.0.18-r1.ebuild')
-rw-r--r--dev-db/mysql/mysql-4.0.18-r1.ebuild14
1 files changed, 2 insertions, 12 deletions
diff --git a/dev-db/mysql/mysql-4.0.18-r1.ebuild b/dev-db/mysql/mysql-4.0.18-r1.ebuild
index 0e190a2890d1..89a0dce894d4 100644
--- a/dev-db/mysql/mysql-4.0.18-r1.ebuild
+++ b/dev-db/mysql/mysql-4.0.18-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-4.0.18-r1.ebuild,v 1.7 2004/05/23 13:36:43 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-4.0.18-r1.ebuild,v 1.8 2004/05/25 01:45:56 kumba Exp $
inherit eutils
#to accomodate -laadeedah releases
@@ -45,16 +45,6 @@ warning() {
pkg_setup() {
warning
-
- # MySQL on mips cannot link to berkdb due to issues.
- if [ "`use mips`" ]; then
- if [ "`use berkdb`" ]; then
- echo -e ""
- eerror "You cannot link MySQL into berkeley db on mips. Please remove the \"berkdb\""
- eerror "flag from your USE settings and try again."
- echo -e ""
- fi
- fi
}
src_unpack() {
@@ -106,7 +96,7 @@ src_compile() {
#The following fix is due to a bug with bdb on sparc's. See:
#http://www.geocrawler.com/mail/msg.php3?msg_id=4754814&list=8
- if use sparc || use sparc64 || use alpha || use hppa
+ if use sparc || use sparc64 || use alpha || use hppa || use mips
then
myconf="${myconf} --without-berkeley-db"
else