summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDawid Węgliński <cla@gentoo.org>2008-10-09 18:23:50 +0000
committerDawid Węgliński <cla@gentoo.org>2008-10-09 18:23:50 +0000
commit14c58ec580b6246a998ef17a88ef464861a44d1f (patch)
tree76e273a0cd2132ae13e3ff8a138c44c301826b49 /app-text/wklej/wklej-0.1.5.ebuild
parentVersion bump. (diff)
downloadhistorical-14c58ec580b6246a998ef17a88ef464861a44d1f.tar.gz
historical-14c58ec580b6246a998ef17a88ef464861a44d1f.tar.bz2
historical-14c58ec580b6246a998ef17a88ef464861a44d1f.zip
Version bump, thanks to thanks to Antoni <awaria at chopin.edu.pl> and Paweł <pkilian at wklej.org> for working on ebuild
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'app-text/wklej/wklej-0.1.5.ebuild')
-rw-r--r--app-text/wklej/wklej-0.1.5.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-text/wklej/wklej-0.1.5.ebuild b/app-text/wklej/wklej-0.1.5.ebuild
new file mode 100644
index 000000000000..ca8bd7945313
--- /dev/null
+++ b/app-text/wklej/wklej-0.1.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/wklej/wklej-0.1.5.ebuild,v 1.1 2008/10/09 18:23:50 cla Exp $
+
+EAPI=1
+
+inherit eutils
+
+DESCRIPTION="A wklej.org submitter"
+HOMEPAGE="http://wklej.org"
+SRC_URI="http://wklej.org/m/apps/wklej-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="+vim"
+
+DEPEND="${RDEPEND}"
+RDEPEND="dev-lang/python
+ vim? ( app-editors/vim )"
+
+pkg_setup() {
+ if use vim && ! built_with_use app-editors/vim python; then
+ eerror "app-editors/vim must be compiled with USE=python"
+ die "app-editors/vim must be compiled with USE=python"
+ fi
+}
+
+src_install() {
+ if use vim; then
+ insinto /usr/share/vim/vimfiles/plugin
+ doins "${WORKDIR}"/${PN}.vim
+ fi
+
+ dobin "${WORKDIR}"/${PN}
+}