summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-05 15:56:04 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-05 15:56:04 +0000
commit3bdae3e659b00f31edbd3ad360257407f8a13acf (patch)
tree9afc70f12a3d6cfa56040bb92d03b2dbf8d52762 /app-text/recode
parentneed eutils for epatch (diff)
downloadhistorical-3bdae3e659b00f31edbd3ad360257407f8a13acf.tar.gz
historical-3bdae3e659b00f31edbd3ad360257407f8a13acf.tar.bz2
historical-3bdae3e659b00f31edbd3ad360257407f8a13acf.zip
need eutils for epatch
Diffstat (limited to 'app-text/recode')
-rw-r--r--app-text/recode/recode-3.5.ebuild32
-rw-r--r--app-text/recode/recode-3.6-r1.ebuild27
-rw-r--r--app-text/recode/recode-3.6.ebuild27
3 files changed, 33 insertions, 53 deletions
diff --git a/app-text/recode/recode-3.5.ebuild b/app-text/recode/recode-3.5.ebuild
index 901a22015429..db45acbd13ed 100644
--- a/app-text/recode/recode-3.5.ebuild
+++ b/app-text/recode/recode-3.5.ebuild
@@ -1,43 +1,37 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/recode/recode-3.5.ebuild,v 1.11 2003/06/28 16:00:37 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/recode/recode-3.5.ebuild,v 1.12 2003/08/05 15:56:04 vapier Exp $
-IUSE="nls"
-
-S=${WORKDIR}/${P}
DESCRIPTION="Convert files between various character sets."
SRC_URI="ftp://ftp.gnu.org/pub/gnu/${PN}/${P}.tar.gz"
HOMEPAGE="http://www.gnu.org/software/recode/"
-KEYWORDS="x86 sparc "
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 sparc"
+IUSE="nls"
DEPEND="virtual/glibc
nls? ( sys-devel/gettext )"
-SLOT="0"
-LICENSE="GPL-2"
-
src_compile() {
-
local myconf
use nls || myconf="--disable-nls"
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
$myconf || die
-
emake || die
}
src_install() {
-
- make prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
install || die
dodoc AUTHORS BACKLOG COPYING* ChangeLog INSTALL
dodoc NEWS README THANKS TODO
}
-
diff --git a/app-text/recode/recode-3.6-r1.ebuild b/app-text/recode/recode-3.6-r1.ebuild
index 834c8b9dcd78..b83bf365d4ef 100644
--- a/app-text/recode/recode-3.6-r1.ebuild
+++ b/app-text/recode/recode-3.6-r1.ebuild
@@ -1,27 +1,23 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/recode/recode-3.6-r1.ebuild,v 1.1 2003/06/28 23:32:13 pylon Exp $
-
-IUSE="nls"
-
-inherit flag-o-matic base
+# $Header: /var/cvsroot/gentoo-x86/app-text/recode/recode-3.6-r1.ebuild,v 1.2 2003/08/05 15:56:04 vapier Exp $
+inherit flag-o-matic base eutils gcc
replace-flags "-march=pentium4" "-march=pentium3"
-S=${WORKDIR}/${P}
DESCRIPTION="Convert files between various character sets."
+HOMEPAGE="http://www.gnu.org/software/recode/"
SRC_URI="ftp://ftp.gnu.org/pub/gnu/${PN}/${P}.tar.gz
mirror://gentoo/${P}-debian.diff.bz2"
-HOMEPAGE="http://www.gnu.org/software/recode/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ppc"
+IUSE="nls"
DEPEND="virtual/glibc
nls? ( sys-devel/gettext )"
-
-KEYWORDS="~x86 ~sparc ppc"
-SLOT="0"
-LICENSE="GPL-2"
-
src_unpack() {
unpack ${A}
cd ${S}
@@ -29,13 +25,12 @@ src_unpack() {
}
src_compile() {
-
local myconf=""
use nls || myconf="--disable-nls"
# gcc-3.2 crashes if we don't remove any -O?
- if [ ! -z "`gcc --version | grep 3.2`" ] && [ ${ARCH} == "x86" ] ; then
- CFLAGS=${CFLAGS/-O?/}
+ if [ ! -z "`gcc-version`" == "3.2" ] && [ ${ARCH} == "x86" ] ; then
+ filter-flags -O?
fi
./configure --host=${CHOST} \
--prefix=/usr \
@@ -47,7 +42,6 @@ src_compile() {
}
src_install() {
-
make prefix=${D}/usr \
mandir=${D}/usr/share/man \
infodir=${D}/usr/share/info \
@@ -56,4 +50,3 @@ src_install() {
dodoc AUTHORS BACKLOG COPYING* ChangeLog INSTALL
dodoc NEWS README THANKS TODO
}
-
diff --git a/app-text/recode/recode-3.6.ebuild b/app-text/recode/recode-3.6.ebuild
index 782742c12a6a..dfa75792172f 100644
--- a/app-text/recode/recode-3.6.ebuild
+++ b/app-text/recode/recode-3.6.ebuild
@@ -1,34 +1,29 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/recode/recode-3.6.ebuild,v 1.15 2003/06/28 16:00:37 mholzer Exp $
-
-IUSE="nls"
-
-inherit flag-o-matic
+# $Header: /var/cvsroot/gentoo-x86/app-text/recode/recode-3.6.ebuild,v 1.16 2003/08/05 15:56:04 vapier Exp $
+inherit flag-o-matic gcc
replace-flags "-march=pentium4" "-march=pentium3"
-S=${WORKDIR}/${P}
DESCRIPTION="Convert files between various character sets."
-SRC_URI="ftp://ftp.gnu.org/pub/gnu/${PN}/${P}.tar.gz"
HOMEPAGE="http://www.gnu.org/software/recode/"
+SRC_URI="ftp://ftp.gnu.org/pub/gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 sparc ~ppc"
+IUSE="nls"
DEPEND="virtual/glibc
nls? ( sys-devel/gettext )"
-
-KEYWORDS="x86 sparc ~ppc"
-SLOT="0"
-LICENSE="GPL-2"
-
src_compile() {
-
local myconf=""
use nls || myconf="--disable-nls"
# gcc-3.2 crashes if we don't remove any -O?
- if [ ! -z "`gcc --version | grep 3.2`" ] && [ ${ARCH} == "x86" ] ; then
- CFLAGS=${CFLAGS/-O?/}
+ if [ ! -z "`gcc-version`" == "3.2" ] && [ ${ARCH} == "x86" ] ; then
+ filter-flags -O?
fi
./configure --host=${CHOST} \
--prefix=/usr \
@@ -40,7 +35,6 @@ src_compile() {
}
src_install() {
-
make prefix=${D}/usr \
mandir=${D}/usr/share/man \
infodir=${D}/usr/share/info \
@@ -49,4 +43,3 @@ src_install() {
dodoc AUTHORS BACKLOG COPYING* ChangeLog INSTALL
dodoc NEWS README THANKS TODO
}
-