summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Turk <satai@gentoo.org>2002-12-31 04:36:56 +0000
committerMatthew Turk <satai@gentoo.org>2002-12-31 04:36:56 +0000
commit7990b28cad9969f099585d10517762f84aca16b1 (patch)
treeb998eb4a90edb6ff330ed17d890a8b9df865ece4 /app-text/docbook-dsssl-stylesheets/docbook-dsssl-stylesheets-1.77-r1.ebuild
parentNew SGML catalog eclass, hopefully will fix things. (diff)
downloadhistorical-7990b28cad9969f099585d10517762f84aca16b1.tar.gz
historical-7990b28cad9969f099585d10517762f84aca16b1.tar.bz2
historical-7990b28cad9969f099585d10517762f84aca16b1.zip
Oy. Tons of changes... Fixed all of these ebuilds to inherit from
sgml-catalog.eclass, and then set them all up to have proper dependencies on the newest items, as well as use the new, more robust installation and removal system. This will probably have some growing pains over the next few days, but the long range will be worth it. All problem hints will be found at http://www.gentoo.org/~satai/
Diffstat (limited to 'app-text/docbook-dsssl-stylesheets/docbook-dsssl-stylesheets-1.77-r1.ebuild')
-rw-r--r--app-text/docbook-dsssl-stylesheets/docbook-dsssl-stylesheets-1.77-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-text/docbook-dsssl-stylesheets/docbook-dsssl-stylesheets-1.77-r1.ebuild b/app-text/docbook-dsssl-stylesheets/docbook-dsssl-stylesheets-1.77-r1.ebuild
new file mode 100644
index 000000000000..928f618f99be
--- /dev/null
+++ b/app-text/docbook-dsssl-stylesheets/docbook-dsssl-stylesheets-1.77-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/docbook-dsssl-stylesheets/docbook-dsssl-stylesheets-1.77-r1.ebuild,v 1.1 2002/12/31 04:36:55 satai Exp $
+
+inherit sgml-catalog
+
+MY_P=${P/-stylesheets/}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="DSSSL Stylesheets for DocBook."
+SRC_URI="mirror://sourceforge/docbook/${MY_P}.tar.gz"
+HOMEPAGE="http://www.sourceforge.net/docbook/"
+
+RDEPEND="app-text/sgml-common"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="x86 ppc sparc alpha"
+
+sgml-catalog_cat_include "/etc/sgml/dsssl-docbook-stylesheets.cat" \
+ "/usr/share/sgml/docbook/dsssl-stylesheets-${PV}/catalog"
+sgml-catalog_cat_include "/etc/sgml/sgml-docbook.cat" \
+ "/etc/sgml/dsssl-docbook-stylesheets.cat"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cp ${FILESDIR}/${P}.Makefile Makefile
+}
+
+src_compile() {
+ dummy="dummy"
+}
+
+src_install () {
+
+ make \
+ BINDIR="${D}/usr/bin" \
+ DESTDIR="${D}/usr/share/sgml/docbook/dsssl-stylesheets-${PV}" \
+ install || die
+
+}
+