summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2003-06-12 20:34:40 +0000
committerTavis Ormandy <taviso@gentoo.org>2003-06-12 20:34:40 +0000
commitd8c002d05bb058946588da63952bd2c100e2066d (patch)
tree5ef10c2f4f93b55852ec70b7311f7b0e54fa8620 /app-shells
parentfix Header (diff)
downloadhistorical-d8c002d05bb058946588da63952bd2c100e2066d.tar.gz
historical-d8c002d05bb058946588da63952bd2c100e2066d.tar.bz2
historical-d8c002d05bb058946588da63952bd2c100e2066d.zip
no longer use cvs, other minor updates and fixes.
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/csh/ChangeLog14
-rw-r--r--app-shells/csh/Manifest4
-rw-r--r--app-shells/csh/csh-1.29-r1.ebuild116
-rw-r--r--app-shells/csh/files/digest-csh-1.29-r11
4 files changed, 133 insertions, 2 deletions
diff --git a/app-shells/csh/ChangeLog b/app-shells/csh/ChangeLog
index 3d8fefca05ca..4bba3fe1e93c 100644
--- a/app-shells/csh/ChangeLog
+++ b/app-shells/csh/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for app-shells/csh
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/csh/ChangeLog,v 1.3 2003/06/04 22:58:27 taviso Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/csh/ChangeLog,v 1.4 2003/06/12 20:34:31 taviso Exp $
+
+*csh-1.29-r1 (12 Jun 2003)
+
+ 12 Jun 2003; Tavis Ormandy <taviso@gentoo.org> csh-1.29-r1.ebuild:
+ no longer uses cvs.eclass to fetch sources (#22678).
+
+ no longer dual license, generate list of signal names from `kill -l` output.
+
+ informational messages tweak.
+
+ produced binary will have better `kill` builtin (no more SIGJUNK fillers),
+ so version bump.
04 Jun 2003; Tavis Ormandy <taviso@gentoo.org> csh-1.29.ebuild:
inherit eclasses _after_ my own dependencies, or they get clobbered.
diff --git a/app-shells/csh/Manifest b/app-shells/csh/Manifest
index 1e45d833d012..85761224f1a3 100644
--- a/app-shells/csh/Manifest
+++ b/app-shells/csh/Manifest
@@ -1,5 +1,7 @@
MD5 40d1ad4d9431c17c016fb5e5e65210b0 csh-1.29.ebuild 3809
-MD5 784b7f59851ee09a4bc38cf47c3046ae ChangeLog 645
+MD5 3a6ccddcb458fdada6521556dc37798e csh-1.29-r1.ebuild 3252
+MD5 b0afe87086fdea8a1e86acde22774fb8 ChangeLog 1014
MD5 49c0a95e6881eb7e2932d149f62f0de2 files/mksignames.c 10722
MD5 49ee962115384f8a0acedfcf225fd27a files/digest-csh-1.29 148
MD5 213922a7d6fdee0a89e9a349653be22d files/linux-vs-bsd.diff 7483
+MD5 8eb726131df145785642164034fb5a74 files/digest-csh-1.29-r1 60
diff --git a/app-shells/csh/csh-1.29-r1.ebuild b/app-shells/csh/csh-1.29-r1.ebuild
new file mode 100644
index 000000000000..b61a0d07cae9
--- /dev/null
+++ b/app-shells/csh/csh-1.29-r1.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/csh/csh-1.29-r1.ebuild,v 1.1 2003/06/12 20:34:31 taviso Exp $
+
+DESCRIPTION="Classic UNIX shell with C like syntax"
+HOMEPAGE="http://www.netbsd.org/"
+
+SRC_URI="http://cvs.gentoo.org/~taviso/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~alpha"
+IUSE="static doc"
+
+DEPEND="virtual/glibc
+ sys-devel/pmake
+ >=sys-apps/sed-4
+ doc? ( sys-apps/groff )
+ sys-apps/util-linux"
+RDEPEND="virtual/glibc"
+
+inherit flag-o-matic eutils ccc
+
+S="${WORKDIR}/src/bin/csh"
+
+src_compile() {
+ # hide some BSDisms, mostly my work, got some hints from the
+ # debian project (they use an older OpenBSD csh, though).
+ cd ${S}; epatch ${FILESDIR}/linux-vs-bsd.diff || die "patching failed."
+
+ # copy some required files over, from NetBSD
+
+ cd ${S}; cp ${WORKDIR}/printf.c \
+ ${WORKDIR}/vis.h \
+ ${WORKDIR}/vis.c \
+ ${S}
+
+ # this parses the output of the bash builtin `kill`
+ # and creates an array of signal names for csh.
+
+ einfo "Making a list of signal names..."
+
+ local cnt=0
+
+ printf "/* automatically generated during %s build */\n\n" ${P} > ${S}/signames.h
+ printf "const char *const sys_signame[NSIG + 3] = {\n" >> ${S}/signames.h
+ printf "\t\"EXIT\",\t\n" $((cnt++)) >> ${S}/signames.h
+
+ for i in `kill -l`
+ do
+ let $((cnt++))%2 && continue
+ einfo " Adding ${i}..."
+ printf "\t\"%s\",\n" ${i} >> ${S}/signames.h
+ done
+
+ printf "\t\"DEBUG\",\n\t\"ERR\",\n\t(char *)0x0\n};\n\n" >> ${S}/signames.h
+
+ einfo "Adding flags required for succesful compilation..."
+ # this should be easier than maintaining a patch.
+ for i in {-Dlint,-w,-D__dead="",-D__LIBC12_SOURCE__,-DNODEV="-1",-DTTYHOG=1024,-DMAXPATHLEN=4096,-D_GNU_SOURCE,-D_DIAGASSERT="assert"}
+ do
+ append-flags ${i}
+ done
+
+ einfo "Making some final tweaks..."
+ sed -i 's#sys/tty.h#linux/tty.h#g' ${S}/file.c
+ sed -i 's!\(#include "proc.h"\)!\1\n#include "signames.h"\n!g' ${S}/proc.c
+ sed -i 's#\(strpct.c time.c\)#\1 vis.c#g' ${S}/Makefile
+ sed -i 's!#include "namespace.h"!!g' ${S}/vis.c
+
+ # maybe they dont warn on BSD, but _damn_.
+ export NOGCCERROR=1
+
+ # if csh is a users preferred shell, they may want
+ # a static binary to help on the event of fs emergency.
+ use static && append-ldflags -static
+
+ # pmake is a portage binary as well, so specify full path.
+ # if yours isnt in /usr/bin, you can set PMAKE_PATH.
+ einfo "Starting build..."
+ ${PMAKE_PATH:-/usr/bin/}pmake || die "compile failed."
+
+ echo
+ size csh
+ echo
+
+ # make the c shell guide
+ use doc && {
+ einfo "Making documentation..."
+ cd ${S}/USD.doc
+ ${PMAKE_PATH:-/usr/bin/}pmake
+ }
+ cd ${S}
+}
+
+src_install() {
+ exeinto /bin
+ doexe csh
+ doman csh.1
+ use doc && dodoc USD.doc/paper.ps
+}
+
+pkg_postinst() {
+ echo
+ use doc >/dev/null && {
+ einfo "An Introduction to the C shell by William Joy, a "
+ einfo "postscript document included with this shell has"
+ einfo "been installed in /usr/share/docs/${P}, if you are new"
+ einfo "to the C shell, you may find it interesting."
+ } || {
+ einfo "You didnt have the \`doc\` use flag set, the"
+ einfo "postscript document \"An Introduction to the C"
+ einfo "shell by William Joy\" was not installed."
+ }
+ echo
+}
diff --git a/app-shells/csh/files/digest-csh-1.29-r1 b/app-shells/csh/files/digest-csh-1.29-r1
new file mode 100644
index 000000000000..ebc0d877f98b
--- /dev/null
+++ b/app-shells/csh/files/digest-csh-1.29-r1
@@ -0,0 +1 @@
+MD5 9637b9572e66e992305dfed9909098e2 csh-1.29.tar.gz 179592