summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-27 08:24:24 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-27 08:24:24 +0000
commit4d419388acc43e71df3b2a9ae7e288266261ab29 (patch)
treedd8ea922f6a828c6d5d8d8bbe8984616366f20f3 /app-sci
parentdont access $CC (diff)
downloadhistorical-4d419388acc43e71df3b2a9ae7e288266261ab29.tar.gz
historical-4d419388acc43e71df3b2a9ae7e288266261ab29.tar.bz2
historical-4d419388acc43e71df3b2a9ae7e288266261ab29.zip
dont access $CC
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/rasmol/rasmol-2.7.1.1.ebuild4
-rw-r--r--app-sci/rasmol/rasmol-2.7.2.1.1.ebuild8
2 files changed, 6 insertions, 6 deletions
diff --git a/app-sci/rasmol/rasmol-2.7.1.1.ebuild b/app-sci/rasmol/rasmol-2.7.1.1.ebuild
index 260cb64d0b93..a8aff7d2ae81 100644
--- a/app-sci/rasmol/rasmol-2.7.1.1.ebuild
+++ b/app-sci/rasmol/rasmol-2.7.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/rasmol/rasmol-2.7.1.1.ebuild,v 1.4 2004/04/27 08:23:44 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/rasmol/rasmol-2.7.1.1.ebuild,v 1.5 2004/04/27 08:24:24 vapier Exp $
inherit gcc
@@ -32,7 +32,7 @@ src_unpack() {
src_compile() {
cd src
xmkmf || die "xmkmf failed"
- make DEPTHDEF=-DEIGHTBIT CC=${CC} \
+ make DEPTHDEF=-DEIGHTBIT CC="$(gcc-getCC)" \
CDEBUGFLAGS="${CFLAGS}" \
|| die "8-bit make failed"
mv rasmol rasmol.8
diff --git a/app-sci/rasmol/rasmol-2.7.2.1.1.ebuild b/app-sci/rasmol/rasmol-2.7.2.1.1.ebuild
index 67f89a4dc2ad..310f24b51a0e 100644
--- a/app-sci/rasmol/rasmol-2.7.2.1.1.ebuild
+++ b/app-sci/rasmol/rasmol-2.7.2.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/rasmol/rasmol-2.7.2.1.1.ebuild,v 1.3 2004/04/27 08:23:44 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/rasmol/rasmol-2.7.2.1.1.ebuild,v 1.4 2004/04/27 08:24:24 vapier Exp $
inherit gcc
@@ -31,17 +31,17 @@ src_unpack() {
src_compile() {
cd src
xmkmf || die "xmkmf failed"
- make DEPTHDEF=-DEIGHTBIT CC=${CC} \
+ make DEPTHDEF=-DEIGHTBIT CC="$(gcc-getCC)" \
CDEBUGFLAGS="${CFLAGS}" \
|| die "8-bit make failed"
mv rasmol rasmol.8
make clean
- make DEPTHDEF=-DSIXTEENBIT CC=${CC} \
+ make DEPTHDEF=-DSIXTEENBIT CC="$(gcc-getCC)" \
CDEBUGFLAGS="${CFLAGS}" \
|| die "16-bit make failed"
mv rasmol rasmol.16
make clean
- make DEPTHDEF=-DTHIRTYTWOBIT CC=${CC} \
+ make DEPTHDEF=-DTHIRTYTWOBIT CC="$(gcc-getCC)" \
CDEBUGFLAGS="${CFLAGS}" \
|| die "32-bit make failed"
mv rasmol rasmol.32