summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-04-23 14:56:11 +0000
committerMike Frysinger <vapier@gentoo.org>2003-04-23 14:56:11 +0000
commit2a58a768242afcd41e645b45b63ae2dfdcd6d833 (patch)
tree34cd9ea9d2281bc7bcae4350ec325869fb72dbbf /app-sci
parentbumpage (diff)
downloadhistorical-2a58a768242afcd41e645b45b63ae2dfdcd6d833.tar.gz
historical-2a58a768242afcd41e645b45b63ae2dfdcd6d833.tar.bz2
historical-2a58a768242afcd41e645b45b63ae2dfdcd6d833.zip
touchups
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/scilab/scilab-2.6.ebuild129
1 files changed, 62 insertions, 67 deletions
diff --git a/app-sci/scilab/scilab-2.6.ebuild b/app-sci/scilab/scilab-2.6.ebuild
index 9b79617a600b..a420e59b8947 100644
--- a/app-sci/scilab/scilab-2.6.ebuild
+++ b/app-sci/scilab/scilab-2.6.ebuild
@@ -1,21 +1,18 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/scilab/scilab-2.6.ebuild,v 1.7 2003/02/13 09:25:33 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/scilab/scilab-2.6.ebuild,v 1.8 2003/04/23 14:56:11 vapier Exp $
-IUSE="tcltk"
-
-S=${WORKDIR}/${P}
-
-DESCRIPTION="Scilab is a scientific software package for numerical computations "
+DESCRIPTION="scientific software package for numerical computations"
SRC_URI="ftp://ftp.inria.fr/INRIA/Projects/Meta2/Scilab/distributions/${P}.src.tar.gz"
HOMEPAGE="http://www-rocq.inria.fr/scilab/"
LICENSE="scilab"
SLOT="0"
KEYWORDS="x86"
+IUSE="tcltk"
DEPEND="virtual/x11
- tcltk? ( dev-lang/tk )"
+ tcltk? ( dev-lang/tk )"
src_compile() {
local myopts
@@ -30,74 +27,72 @@ src_compile() {
--sysconfdir=/etc \
--localstatedir=/var \
${myopts} || die "./configure failed"
- # HOME must be set to prevent writing to /root directory
- export HOME=/var/tmp/portage/${P}/work
- make all || die
+ env HOME=${S} make all || die
}
-src_install () {
+src_install() {
BINDISTFILES="\
${P}/.binary \
${P}/.pvmd.conf \
${P}/ACKNOWLEDGEMENTS \
- ${P}/CHANGES \
- ${P}/Makefile \
- ${P}/Makefile.OBJ \
- ${P}/Makefile.incl \
- ${P}/Makemex \
- ${P}/Path.incl \
- ${P}/README \
- ${P}/Version.incl \
- ${P}/configure \
- ${P}/libtool \
- ${P}/license.txt \
- ${P}/licence.txt \
- ${P}/scilab.quit \
- ${P}/scilab.star \
- ${P}/X11_defaults \
- ${P}/bin \
- ${P}/config \
- ${P}/contrib \
- ${P}/demos \
- ${P}/examples \
- ${P}/imp/NperiPos.ps \
- ${P}/imp/giffonts \
- ${P}/macros \
- ${P}/man \
- ${P}/maple \
- ${P}/pvm3/lib/pvm \
- ${P}/pvm3/lib/pvmd \
- ${P}/pvm3/lib/pvmtmparch \
- ${P}/pvm3/lib/pvmgetarch \
- ${P}/pvm3/lib/LINUX/pvmd3 \
- ${P}/pvm3/lib/LINUX/pvmgs \
- ${P}/routines/*.h \
- ${P}/routines/Make.lib \
- ${P}/routines/default/FCreate \
- ${P}/routines/default/Flist \
- ${P}/routines/default/README \
- ${P}/routines/default/fundef \
- ${P}/routines/default/*.c \
- ${P}/routines/default/*.f \
- ${P}/routines/graphics/Math.h \
- ${P}/routines/graphics/Graphics.h \
- ${P}/routines/interf/*.h \
- ${P}/routines/intersci/sparse.h \
- ${P}/routines/menusX/*.h \
- ${P}/routines/scicos/scicos.h \
- ${P}/routines/sun/*.h \
- ${P}/routines/xsci/*.h \
- ${P}/scripts \
- ${P}/tcl \
- ${P}/tests \
- ${P}/util"
+ ${P}/CHANGES \
+ ${P}/Makefile \
+ ${P}/Makefile.OBJ \
+ ${P}/Makefile.incl \
+ ${P}/Makemex \
+ ${P}/Path.incl \
+ ${P}/README \
+ ${P}/Version.incl \
+ ${P}/configure \
+ ${P}/libtool \
+ ${P}/license.txt \
+ ${P}/licence.txt \
+ ${P}/scilab.quit \
+ ${P}/scilab.star \
+ ${P}/X11_defaults \
+ ${P}/bin \
+ ${P}/config \
+ ${P}/contrib \
+ ${P}/demos \
+ ${P}/examples \
+ ${P}/imp/NperiPos.ps \
+ ${P}/imp/giffonts \
+ ${P}/macros \
+ ${P}/man \
+ ${P}/maple \
+ ${P}/pvm3/lib/pvm \
+ ${P}/pvm3/lib/pvmd \
+ ${P}/pvm3/lib/pvmtmparch \
+ ${P}/pvm3/lib/pvmgetarch \
+ ${P}/pvm3/lib/LINUX/pvmd3 \
+ ${P}/pvm3/lib/LINUX/pvmgs \
+ ${P}/routines/*.h \
+ ${P}/routines/Make.lib \
+ ${P}/routines/default/FCreate \
+ ${P}/routines/default/Flist \
+ ${P}/routines/default/README \
+ ${P}/routines/default/fundef \
+ ${P}/routines/default/*.c \
+ ${P}/routines/default/*.f \
+ ${P}/routines/graphics/Math.h \
+ ${P}/routines/graphics/Graphics.h \
+ ${P}/routines/interf/*.h \
+ ${P}/routines/intersci/sparse.h \
+ ${P}/routines/menusX/*.h \
+ ${P}/routines/scicos/scicos.h \
+ ${P}/routines/sun/*.h \
+ ${P}/routines/xsci/*.h \
+ ${P}/scripts \
+ ${P}/tcl \
+ ${P}/tests \
+ ${P}/util"
touch .binary
strip bin/scilex
- (cd tests; make distclean)
- (cd examples; make distclean)
+ cd tests && make distclean
+ cd examples && make distclean
dodir /usr/lib
- (cd ..; tar cf - ${BINDISTFILES} | (cd ${D}usr/lib; tar xf -))
+ (cd ..; tar cf - ${BINDISTFILES} | (cd ${D}/usr/lib; tar xf -))
rm .binary
dodir /usr/bin
@@ -108,12 +103,12 @@ src_install () {
# the following is needed in order to create the startup scripts with
# the right paths
-pkg_postinst () {
+pkg_postinst() {
(cd /usr/lib/${P}; make)
}
# but of course then, unmerge won't remove everything without the following
-pkg_postrm () {
+pkg_postrm() {
rm /usr/lib/${P}/Path.incl
rm -r /usr/lib/${P}/bin
rm -r /usr/lib/${P}/util