summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2003-10-05 01:24:24 +0000
committerGeorge Shapovalov <george@gentoo.org>2003-10-05 01:24:24 +0000
commit0d54e08147b49cb4fd5b463c6409cc8741247b61 (patch)
treeaf9d8be2c87fe685dc0c1a1b1d7e876af1363223 /app-sci
parentadd ~amd64 flag (diff)
downloadhistorical-0d54e08147b49cb4fd5b463c6409cc8741247b61.tar.gz
historical-0d54e08147b49cb4fd5b463c6409cc8741247b61.tar.bz2
historical-0d54e08147b49cb4fd5b463c6409cc8741247b61.zip
fix to postremove issues, added gtk USE flag
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/scilab/ChangeLog9
-rw-r--r--app-sci/scilab/Manifest4
-rw-r--r--app-sci/scilab/files/digest-scilab-2.7-r22
-rw-r--r--app-sci/scilab/scilab-2.7-r2.ebuild121
4 files changed, 134 insertions, 2 deletions
diff --git a/app-sci/scilab/ChangeLog b/app-sci/scilab/ChangeLog
index 6e013146907f..26a2432c72ad 100644
--- a/app-sci/scilab/ChangeLog
+++ b/app-sci/scilab/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-sci/scilab
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/scilab/ChangeLog,v 1.5 2003/09/16 21:27:01 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/scilab/ChangeLog,v 1.6 2003/10/05 01:24:16 george Exp $
+
+*scilab-2.7-r2 (04 Oct 2003)
+
+ 04 Oct 2003; George Shapovalov <geore@gentoo.org> scilab-2.7-r2.ebuild :
+ fixes ##28245 and 30219, thanks to the guys from the -r1 update :) and
+ to Toby Smith <thlsmith@iprimus.com.au> for the gtk hint
+ now ebuild comes without postinst/remove functions
*scilab-2.7-r1 (16 Sep 2003)
diff --git a/app-sci/scilab/Manifest b/app-sci/scilab/Manifest
index ca9a333d3b4d..69932f8f46b9 100644
--- a/app-sci/scilab/Manifest
+++ b/app-sci/scilab/Manifest
@@ -1,8 +1,10 @@
MD5 dad730249717cbeff055be53d6473d07 scilab-2.6.ebuild 2840
-MD5 39ed8d6f16b9cb7f3d7729c6cde0d017 ChangeLog 1134
+MD5 700dfedcb51f90e956d9b99812c14a19 scilab-2.7-r2.ebuild 3125
+MD5 692bffc50ce6fad5339533aa7c3d13ee ChangeLog 1426
MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
MD5 c586179fbaa8ea3b375fa6e1bb02e6cd scilab-2.7-r1.ebuild 3505
MD5 85f60272dc7d8e3afbff77d8694d98e8 scilab-2.7.ebuild 3038
MD5 1d6cf95b60df9aed59392d68189bb25d files/digest-scilab-2.6 67
MD5 08e3affe50b12d19408b7e389b08a964 files/digest-scilab-2.7 67
MD5 f8e77491ef5140fe63fbe21ca1964377 files/digest-scilab-2.7-r1 135
+MD5 f8e77491ef5140fe63fbe21ca1964377 files/digest-scilab-2.7-r2 135
diff --git a/app-sci/scilab/files/digest-scilab-2.7-r2 b/app-sci/scilab/files/digest-scilab-2.7-r2
new file mode 100644
index 000000000000..c742d1e38c77
--- /dev/null
+++ b/app-sci/scilab/files/digest-scilab-2.7-r2
@@ -0,0 +1,2 @@
+MD5 e8aa1ede5efa20eeced284963d08bebb scilab-2.7.src.tar.gz 9510676
+MD5 712df122ba9d3dabf17e6016f33efcc4 patch_browsehelp.tar.gz 622246
diff --git a/app-sci/scilab/scilab-2.7-r2.ebuild b/app-sci/scilab/scilab-2.7-r2.ebuild
new file mode 100644
index 000000000000..178b643bfabb
--- /dev/null
+++ b/app-sci/scilab/scilab-2.7-r2.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/scilab/scilab-2.7-r2.ebuild,v 1.1 2003/10/05 01:24:16 george Exp $
+
+DESCRIPTION="Scientific software package for numerical computations, Matlab lookalike"
+SRC_URI="ftp://ftp.inria.fr/INRIA/Projects/Meta2/Scilab/distributions/${P}.src.tar.gz
+ http://www-rocq.inria.fr/scilab/bugfix/patch_browsehelp.tar.gz"
+HOMEPAGE="http://www.scilab.org/"
+
+LICENSE="scilab"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="tcltk"
+
+DEPEND="virtual/x11
+ x11-libs/Xaw3d
+ tcltk? ( dev-lang/tk )
+ gtk? ( =x11-libs/gtk+-1.2* )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S} && unpack ${DISTFILES}/patch_browsehelp.tar.gz
+}
+
+src_compile() {
+ local myopts
+
+ use tcltk || myopts="${myopts} --without-tk"
+ use gtk && myopts="${myopts} --with-gtk" || myopts="${myopts} --without-gtk"
+
+ econf ${myopts} || die "./configure failed"
+ env HOME=${S} make all || die
+}
+
+src_install() {
+ PVMBINDISTFILES="\
+ ${P}/pvm3/Readme \
+ ${P}/pvm3/lib/pvm \
+ ${P}/pvm3/lib/pvmd \
+ ${P}/pvm3/lib/pvmtmparch \
+ ${P}/pvm3/lib/pvmgetarch \
+ ${P}/pvm3/lib/LINUX/pvmd3 \
+ ${P}/pvm3/lib/LINUX/pvmgs \
+ ${P}/pvm3/lib/LINUX/pvm \
+ ${P}/pvm3/bin/LINUX/*"
+
+ BINDISTFILES="\
+ ${P}/.binary \
+ ${P}/.pvmd.conf \
+ ${P}/ACKNOWLEDGEMENTS \
+ ${P}/CHANGES \
+ ${P}/Makefile \
+ ${P}/Makefile.OBJ \
+ ${P}/Makefile.incl \
+ ${P}/Makemex \
+ ${P}/Path.incl \
+ ${P}/README_Unix \
+ ${P}/Version.incl \
+ ${P}/configure \
+ ${P}/libtool \
+ ${P}/license.txt \
+ ${P}/licence.txt \
+ ${P}/scilab.quit \
+ ${P}/scilab.star \
+ ${P}/X11_defaults \
+ ${P}/bin \
+ ${P}/config \
+ ${P}/contrib \
+ ${P}/demos \
+ ${P}/examples \
+ ${P}/imp/NperiPos.ps \
+ ${P}/imp/giffonts \
+ ${P}/macros \
+ ${P}/man/eng/*.htm \
+ ${P}/man/eng/*/*.htm \
+ ${P}/man/fr/*/*.htm \
+ ${P}/man/fr/*.htm \
+ ${P}/man/*.dtd \
+ ${P}/man/*/*.xsl \
+ ${P}/maple \
+ ${P}/routines/*.h \
+ ${P}/routines/Make.lib \
+ ${P}/routines/default/FCreate \
+ ${P}/routines/default/Flist \
+ ${P}/routines/default/README \
+ ${P}/routines/default/fundef \
+ ${P}/routines/default/*.c \
+ ${P}/routines/default/*.f \
+ ${P}/routines/default/*.h \
+ ${P}/routines/graphics/Math.h \
+ ${P}/routines/graphics/Graphics.h \
+ ${P}/routines/graphics/Entities.h \
+ ${P}/routines/interf/*.h \
+ ${P}/routines/intersci/sparse.h \
+ ${P}/routines/menusX/*.h \
+ ${P}/routines/scicos/scicos.h \
+ ${P}/routines/sun/*.h \
+ ${P}/routines/xsci/*.h \
+ ${P}/scripts \
+ ${P}/tcl \
+ ${P}/tests \
+ ${P}/util"
+
+ touch .binary
+ strip bin/scilex
+ cd ${S}/tests && make distclean
+ cd ${S}/examples && make distclean
+ dodir /usr/lib
+ (cd ${S}/..; tar cf - ${BINDISTFILES} ${PVMBINDISTFILES} | (cd ${D}/usr/lib; tar xf -))
+ rm .binary
+
+ dodir /usr/bin
+ dosym /usr/lib/${P}/bin/scilab /usr/bin/scilab
+ dosym /usr/lib/${P}/bin/intersci /usr/bin/intersci
+ dosym /usr/lib/${P}/bin/intersci-n /usr/bin/intersci-n
+
+ #now scilab wants to create some wrappers, and we will need to adjust the paths
+ cd ${D}/usr/lib/${P}
+ make || die "wrapper creation failed"
+ grep -rle "${D}" * | xargs sed -i -e "s:${D}:/:g"
+}