summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-04-25 22:57:28 +0000
committerAron Griffis <agriffis@gentoo.org>2004-04-25 22:57:28 +0000
commit015ebdf3ac894530c72a1d7c00f1f6329229c05a (patch)
tree00892c3924d26ea25428b310a72a2b3eb76ee873 /app-sci/singular
parentUpdate so gcc-3.4 is respected (#48933). (diff)
downloadhistorical-015ebdf3ac894530c72a1d7c00f1f6329229c05a.tar.gz
historical-015ebdf3ac894530c72a1d7c00f1f6329229c05a.tar.bz2
historical-015ebdf3ac894530c72a1d7c00f1f6329229c05a.zip
Add die following econf for bug 48950
Diffstat (limited to 'app-sci/singular')
-rw-r--r--app-sci/singular/ChangeLog5
-rw-r--r--app-sci/singular/singular-2.0.4-r1.ebuild4
2 files changed, 6 insertions, 3 deletions
diff --git a/app-sci/singular/ChangeLog b/app-sci/singular/ChangeLog
index 113c7ffcf0ed..07b91427c917 100644
--- a/app-sci/singular/ChangeLog
+++ b/app-sci/singular/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-sci/singular
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/singular/ChangeLog,v 1.11 2004/04/01 08:47:22 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/singular/ChangeLog,v 1.12 2004/04/25 22:53:49 agriffis Exp $
+
+ 25 Apr 2004; Aron Griffis <agriffis@gentoo.org> singular-2.0.4-r1.ebuild:
+ Add die following econf for bug 48950
01 Apr 2004; Patrick Kursawe <phosphan@gentoo.org> singular-2.0.4-r1.ebuild:
Inheriting eutils, removed S=...
diff --git a/app-sci/singular/singular-2.0.4-r1.ebuild b/app-sci/singular/singular-2.0.4-r1.ebuild
index bbc5a6a12b28..138ae060d04f 100644
--- a/app-sci/singular/singular-2.0.4-r1.ebuild
+++ b/app-sci/singular/singular-2.0.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/singular/singular-2.0.4-r1.ebuild,v 1.4 2004/04/01 08:47:22 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/singular/singular-2.0.4-r1.ebuild,v 1.5 2004/04/25 22:53:49 agriffis Exp $
inherit eutils
@@ -46,7 +46,7 @@ src_unpack () {
src_compile() {
local myconf="${myconf} --with-NTL --prefix=${D}/usr"
- econf ${myconf}
+ econf ${myconf} || die "econf failed"
make CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" || die "make failed"
}