summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2002-10-25 23:19:39 +0000
committerGeorge Shapovalov <george@gentoo.org>2002-10-25 23:19:39 +0000
commita1ddc5af95ed7c59bb86c3824243ae20786d55b6 (patch)
tree8d7f8ca4f652870585d31fd1bb8448e6dcfc5e27 /app-sci/octave
parentnew version (diff)
downloadhistorical-a1ddc5af95ed7c59bb86c3824243ae20786d55b6.tar.gz
historical-a1ddc5af95ed7c59bb86c3824243ae20786d55b6.tar.bz2
historical-a1ddc5af95ed7c59bb86c3824243ae20786d55b6.zip
sandbox violation fix
Diffstat (limited to 'app-sci/octave')
-rw-r--r--app-sci/octave/ChangeLog7
-rw-r--r--app-sci/octave/files/digest-octave-2.0.17-r11
-rw-r--r--app-sci/octave/octave-2.0.17-r1.ebuild47
3 files changed, 54 insertions, 1 deletions
diff --git a/app-sci/octave/ChangeLog b/app-sci/octave/ChangeLog
index aba897451bce..d15f7ca73e09 100644
--- a/app-sci/octave/ChangeLog
+++ b/app-sci/octave/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for <CATEGORY>/<PACKAGE_NAME>
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-sci/octave/ChangeLog,v 1.6 2002/10/01 20:46:26 satai Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/octave/ChangeLog,v 1.7 2002/10/25 23:19:39 george Exp $
+
+*octave-2.0.17-r1 (13 Jul 2002)
+
+ 25 Oct 2002 George Shapovalov <george@gentoo.org> octave-2.0.17-r1.ebuild, files/digest-octave-2.0.17-r1 ;
+ fix for sandbox violation
*octave-2.1.36-r1 (01 Oct 02)
diff --git a/app-sci/octave/files/digest-octave-2.0.17-r1 b/app-sci/octave/files/digest-octave-2.0.17-r1
new file mode 100644
index 000000000000..e1aa710b0e51
--- /dev/null
+++ b/app-sci/octave/files/digest-octave-2.0.17-r1
@@ -0,0 +1 @@
+MD5 04e97dd7067424463f1501bc33d0e84b octave-2.0.17.tar.bz2 3064093
diff --git a/app-sci/octave/octave-2.0.17-r1.ebuild b/app-sci/octave/octave-2.0.17-r1.ebuild
new file mode 100644
index 000000000000..75dd380bf43a
--- /dev/null
+++ b/app-sci/octave/octave-2.0.17-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/octave/octave-2.0.17-r1.ebuild,v 1.1 2002/10/25 23:19:39 george Exp $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="A high-level language (MatLab compatible) intended for numerical computations."
+SRC_URI="ftp://ftp.octave.org/pub/octave/${P}.tar.bz2"
+HOMEPAGE="http://www.octave.org/"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2-r3
+ >=media-gfx/gnuplot-3.7.1-r3"
+PROVIDE="dev-lang/octave"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+SLOT="0"
+
+src_compile() {
+ # NOTE: This version only works with gcc-2.x not gcc-3.x
+ econf \
+ --enable-dl \
+ --enable-shared \
+ --enable-rpath \
+ --enable-lite-kernel \
+ ${myconf} || die "configure failed"
+
+ make || die "make failed"
+
+}
+
+src_install () {
+
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ datadir=${D}/usr/share \
+ install || die "make install failed"
+
+# DESTDIR=${D} make install || die
+
+ dodoc BUGS COPYING ChangeLog* INSTALL* NEWS* PROJECTS README* ROADMAP \
+ SENDING-PATCHES THANKS
+
+}