summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Portnoy <avenj@gentoo.org>2003-04-25 23:27:57 +0000
committerJon Portnoy <avenj@gentoo.org>2003-04-25 23:27:57 +0000
commit60b1f139999ceef5cfdd2763346e67d38cbbab58 (patch)
tree8b98ebfb0f16bd73c7e0f8803e0f15c9eab9b55d /app-sci/bioperl
parentVersion bump, fixes #13826 (diff)
downloadhistorical-60b1f139999ceef5cfdd2763346e67d38cbbab58.tar.gz
historical-60b1f139999ceef5cfdd2763346e67d38cbbab58.tar.bz2
historical-60b1f139999ceef5cfdd2763346e67d38cbbab58.zip
Version bump, fixes #13826
Diffstat (limited to 'app-sci/bioperl')
-rw-r--r--app-sci/bioperl/Manifest7
-rw-r--r--app-sci/bioperl/bioperl-1.0.2.ebuild2
-rw-r--r--app-sci/bioperl/bioperl-1.2.ebuild67
-rw-r--r--app-sci/bioperl/files/bioperl-1.2-manpage.diff28
-rw-r--r--app-sci/bioperl/files/digest-bioperl-1.21
5 files changed, 101 insertions, 4 deletions
diff --git a/app-sci/bioperl/Manifest b/app-sci/bioperl/Manifest
index 5abde296229a..64d7902ff601 100644
--- a/app-sci/bioperl/Manifest
+++ b/app-sci/bioperl/Manifest
@@ -1,5 +1,6 @@
-MD5 b9ee31171fa91fd624168e28d3ab75f2 ChangeLog 410
-MD5 5f0c1de27bcf99d292581fe446a08137 bioperl-1.0.2.ebuild 1452
-MD5 ba4e2fcbf61f83721a014c5ac9e09af0 bioperl-1.2.ebuild 1526
+MD5 b3dfb0c5ae5c8a1bfb4f99e6bf8c4cb1 ChangeLog 594
+MD5 9a4bfbf012a3a048201edb2014d771d2 bioperl-1.2.ebuild 1603
+MD5 baad623047a6890e3fab7ae888233850 bioperl-1.0.2.ebuild 1551
MD5 dfdb9921cbef92f60e9746a9531d8de7 files/digest-bioperl-1.0.2 66
MD5 14b9e16331895fe40e231065f7dda942 files/digest-bioperl-1.2 64
+MD5 1828ff2ba6225e17a98d27bfbad5c7c9 files/bioperl-1.2-manpage.diff 712
diff --git a/app-sci/bioperl/bioperl-1.0.2.ebuild b/app-sci/bioperl/bioperl-1.0.2.ebuild
index e43ac2669e9e..74ea2a5830a7 100644
--- a/app-sci/bioperl/bioperl-1.0.2.ebuild
+++ b/app-sci/bioperl/bioperl-1.0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/bioperl/bioperl-1.0.2.ebuild,v 1.3 2003/04/25 23:27:45 avenj Exp $
IUSE="mysql gd"
diff --git a/app-sci/bioperl/bioperl-1.2.ebuild b/app-sci/bioperl/bioperl-1.2.ebuild
new file mode 100644
index 000000000000..bfcd123b18c3
--- /dev/null
+++ b/app-sci/bioperl/bioperl-1.2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/bioperl/bioperl-1.2.ebuild,v 1.1 2003/04/25 23:27:45 avenj Exp $
+
+inherit perl-module debug
+
+S="${WORKDIR}/bioperl-${PV}"
+IUSE="mysql gd"
+
+DESCRIPTION="The Bioperl Project is a collection of tools for bioinformatics, genomics and life science research."
+
+HOMEPAGE="http://www.bioperl.org"
+SRC_URI="http://bioperl.org/ftp/DIST/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+LICENSE="Artistic GPL-2"
+
+DEPEND="${DEPEND}
+ dev-perl/File-Temp
+ dev-perl/Graph
+ dev-perl/HTML-Parser
+ dev-perl/IO-String
+ dev-perl/IO-stringy
+ dev-perl/Parse-RecDescent
+ dev-perl/SOAP-Lite
+ dev-perl/Storable
+ dev-perl/XML-DOM
+ dev-perl/XML-Parser
+ dev-perl/XML-Writer
+ dev-perl/XML-Twig
+ dev-perl/libxml-perl
+ dev-perl/libwww-perl
+ dev-perl/Text-Shellwords
+ gd? ( >=dev-perl/GD-1.32-r1 )
+ mysql? ( >=dev-perl/DBD-mysql-2.1004-r3 )"
+
+RDEPEND=${DEPEND}
+
+# uncomment this if you'd like to access bioperl docs via man in addition to
+# perldoc.
+#src_unpack() {
+# unpack ${A}
+# cd ${S}
+# echo
+# einfo " Patching to build manified pods..."
+# echo
+# patch < ${FILESDIR}/${P}-manpage.diff
+#}
+
+src_compile() {
+ # note: these echo's give the default values for testing.
+ use mysql && (
+ echo y
+ echo test
+ echo localhost
+ echo undef
+ echo undef
+ ) | perl-module_src_compile || perl-module_src_compile || die "compile failed"
+
+ # This dies at RootIO.t:
+ # perl-module_src_test || die "test failed"
+}
+src_install() {
+ mydoc="AUTHORS BUGS FAQ"
+ perl-module_src_install
+}
diff --git a/app-sci/bioperl/files/bioperl-1.2-manpage.diff b/app-sci/bioperl/files/bioperl-1.2-manpage.diff
new file mode 100644
index 000000000000..54ba46aa680e
--- /dev/null
+++ b/app-sci/bioperl/files/bioperl-1.2-manpage.diff
@@ -0,0 +1,28 @@
+--- Makefile.PL.orig 2003-01-09 19:22:26.000000000 -0700
++++ Makefile.PL 2003-01-09 19:23:06.000000000 -0700
+@@ -270,16 +270,16 @@
+ },
+ );
+
+-
+-sub MY::manifypods {
+- my $self = shift;
+- #print STDERR "In manifypods moment\n";
+- if( 1 ) {
+- return "\nmanifypods : pure_all\n\t$self->{NOECHO}\$(NOOP)\n"
+- }
+- else {
+- return $self->SUPER::manifypods(@_);
+- }
+- }
++# build pods by commenting out
++#sub MY::manifypods {
++# my $self = shift;
++# #print STDERR "In manifypods moment\n";
++# if( 1 ) {
++# return "\nmanifypods : pure_all\n\t$self->{NOECHO}\$(NOOP)\n"
++# }
++# else {
++# return $self->SUPER::manifypods(@_);
++# }
++# }
diff --git a/app-sci/bioperl/files/digest-bioperl-1.2 b/app-sci/bioperl/files/digest-bioperl-1.2
new file mode 100644
index 000000000000..183c203289e2
--- /dev/null
+++ b/app-sci/bioperl/files/digest-bioperl-1.2
@@ -0,0 +1 @@
+MD5 23c0de12d08c394b336331caf33d3e94 bioperl-1.2.tar.gz 3425575