summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2006-07-09 05:16:21 +0000
committerSteve Arnold <nerdboy@gentoo.org>2006-07-09 05:16:21 +0000
commit8db7c96b7cacac146837803d5a779b5e029a67f0 (patch)
tree7ba25d3c3859e350f6e64b43ade51365efc1d35e /app-pda/qtopia-desktop-bin/qtopia-desktop-bin-2.2.0.ebuild
parentadded qtopia-desktop-bin since new version has multilib (diff)
downloadhistorical-8db7c96b7cacac146837803d5a779b5e029a67f0.tar.gz
historical-8db7c96b7cacac146837803d5a779b5e029a67f0.tar.bz2
historical-8db7c96b7cacac146837803d5a779b5e029a67f0.zip
added new upstream version with multilib support and updated to modular X
Package-Manager: portage-2.1.1_pre2-r2
Diffstat (limited to 'app-pda/qtopia-desktop-bin/qtopia-desktop-bin-2.2.0.ebuild')
-rw-r--r--app-pda/qtopia-desktop-bin/qtopia-desktop-bin-2.2.0.ebuild78
1 files changed, 78 insertions, 0 deletions
diff --git a/app-pda/qtopia-desktop-bin/qtopia-desktop-bin-2.2.0.ebuild b/app-pda/qtopia-desktop-bin/qtopia-desktop-bin-2.2.0.ebuild
new file mode 100644
index 000000000000..97a6400343d1
--- /dev/null
+++ b/app-pda/qtopia-desktop-bin/qtopia-desktop-bin-2.2.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/qtopia-desktop-bin/qtopia-desktop-bin-2.2.0.ebuild,v 1.1 2006/07/09 05:16:21 nerdboy Exp $
+
+inherit eutils rpm multilib
+
+REV="1"
+QD="/opt/QtopiaDesktop"
+S="${WORKDIR}"
+
+DESCRIPTION="Qtopia Deskyop sync application for Zaurus PDA's"
+SRC_URI="ftp://ftp.trolltech.com/qtopia/desktop/RedHat9.0/qtopia-desktop-${PV}-${REV}-redhat9.i386.rpm"
+HOMEPAGE="http://www.trolltech.com/developer/downloads/qtopia/desktopdownloads"
+
+LICENSE="trolltech_PUL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+DEPEND=""
+RDEPEND="virtual/libc
+ || ( x11-libs/libX11 virtual/x11 )
+ amd64? ( app-emulation/emul-linux-x86-xlibs )"
+
+RESTRICT="nomirror nostrip"
+
+pkg_setup() {
+ # This is a binary x86 package => ABI=x86
+ has_multilib_profile && ABI="x86"
+}
+
+pkg_unpack() {
+ rpm_src_unpack
+}
+
+src_compile() { :; }
+
+src_install() {
+ dodir ${QD}
+ # Too many subdirs and files for individual ebuild commands
+ # Isn't there a better way?
+ cp -a ${S}/${QD}/qtopiadesktop ${D}${QD}
+ local libdir="lib32"
+ if has_multilib_profile ; then
+ libdir=$(get_abi_LIBDIR x86)
+ fi
+ into ${QD}
+ dolib.so ${S}/${QD}/lib/lib*
+ rm -f ${S}/${QD}/lib/*.prl
+ exeinto ${QD}/bin
+ doexe ${S}/${QD}/bin/*
+ docinto /usr/share/doc/${P}
+ dodoc ${S}/${QD}/LICENSE.US
+ dodoc ${S}/${QD}/README.html
+ dodoc ${FILESDIR}/usb0.conf
+ rm -f ${S}/${QD}/LICENSE*
+ echo "PATH=${QD}/bin" > 37qtopia-desktop-bin
+ echo "LDPATH=${QD}/${libdir}" >> 37qtopia-desktop-bin
+ doenvd 37qtopia-desktop-bin
+}
+
+pkg_postinst() {
+
+ einfo " Finished installing Qtopia Desktop ${PV}-${REV} into ${QD}"
+ einfo
+ einfo " To start Qtopia Desktop, run:"
+ einfo
+ einfo " $ qtopiadesktop"
+ einfo
+ einfo "See the usb0.conf file for a static network configuration for the"
+ einfo "Zaurus cradle interface (it works with an SL-5x00). Note the old"
+ einfo "way of adding a config script to /etc/hotplug/usb also works, but"
+ einfo "depends on the desktop kernel version and module name, since the"
+ einfo "latest 2.6.16 module is cdc_ether for older models of the Zaurus"
+ einfo "(such as above) running OZ with kernel 2.4.x."
+ einfo
+}