summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-04-28 12:48:27 +0000
committerAchim Gottinger <achim@gentoo.org>2001-04-28 12:48:27 +0000
commitf46ed65c6c44ef92623517f118f109f3db7e6485 (patch)
treef0babe0b1348740ddbb7faa7882f42c195a78521 /app-office
parent*** empty log message *** (diff)
downloadhistorical-f46ed65c6c44ef92623517f118f109f3db7e6485.tar.gz
historical-f46ed65c6c44ef92623517f118f109f3db7e6485.tar.bz2
historical-f46ed65c6c44ef92623517f118f109f3db7e6485.zip
*** empty log message ***
Diffstat (limited to 'app-office')
-rw-r--r--app-office/koffice/koffice-1.1_beta1.ebuild32
1 files changed, 19 insertions, 13 deletions
diff --git a/app-office/koffice/koffice-1.1_beta1.ebuild b/app-office/koffice/koffice-1.1_beta1.ebuild
index 650c7bf07f52..e0d3a66582d2 100644
--- a/app-office/koffice/koffice-1.1_beta1.ebuild
+++ b/app-office/koffice/koffice-1.1_beta1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/koffice-1.1_beta1.ebuild,v 1.1 2001/04/28 08:49:09 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/koffice-1.1_beta1.ebuild,v 1.2 2001/04/28 12:48:27 achim Exp $
P=${PN}-1.1-beta1
A=${P}.tar.bz2
@@ -14,7 +14,7 @@ SRC_URI="ftp://ftp.kde.org/pub/$SRC_PATH
HOMEPAGE="http://www.kde.org/"
DEPEND=">=kde-base/kdelibs-2.1.1
- virtual/python"
+ >=dev-lang/python-2.0-r2"
RDEPEND=$DEPEND
@@ -23,18 +23,24 @@ src_compile() {
try ./configure --prefix=$KDEDIR --host=${CHOST} \
--with-qt-dir=$QTBASE
- if [ "`use readline`" ]
- then
- # I use sed to patch a makefile to compile with python
- for i in connector text zoom selector
- do
- cd ${S}/kivio/plugins/kivio${i}tool
- cp Makefile Makefile.org
- sed -e "s:^LDFLAGS =.*:LDFLAGS = -lreadline -lncurses:" Makefile.orig > Makefile
- done
- fi
+# if [ "`use readline`" ]
+# then
+# # I use sed to patch a makefile to compile with python
+# for i in connector text zoom selector
+# do
+# cd ${S}/kivio/plugins/kivio${i}tool
+# cp Makefile Makefile.org
+# sed -e "s:^LDFLAGS =.*:LDFLAGS = -lreadline -lncurses:" Makefile.orig > Makefile
+# done
+# fi
cd ${S}
- try make
+ if [ "`use readline`" ]
+ then
+ try make LIBPYTHON=\"-lpython2.0 -lm -lutil -ldl -lz -lreadline -lncurses\"
+ else
+ try make
+ fi
+
}
src_install() {