summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2001-09-15 11:43:33 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2001-09-15 11:43:33 +0000
commit9c91eb64577474f4f1c776d320cde439e3d2562c (patch)
treee929f25a562373c1ea360d5a3157b346cd91e56e /app-office
parentmoved perl down in the build order to hopefully solve a mystery dep (diff)
downloadhistorical-9c91eb64577474f4f1c776d320cde439e3d2562c.tar.gz
historical-9c91eb64577474f4f1c776d320cde439e3d2562c.tar.bz2
historical-9c91eb64577474f4f1c776d320cde439e3d2562c.zip
Initial import of abiword 0.9.3
Diffstat (limited to 'app-office')
-rw-r--r--app-office/abiword/abiword-0.9.3.ebuild58
-rw-r--r--app-office/abiword/files/digest-abiword-0.9.31
2 files changed, 59 insertions, 0 deletions
diff --git a/app-office/abiword/abiword-0.9.3.ebuild b/app-office/abiword/abiword-0.9.3.ebuild
new file mode 100644
index 000000000000..31e85da63129
--- /dev/null
+++ b/app-office/abiword/abiword-0.9.3.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Karl Trygve Kalleberg <karltk@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-0.9.3.ebuild,v 1.1 2001/09/15 11:43:33 karltk Exp $
+
+S=${WORKDIR}/${P}/abi
+DESCRIPTION="Text processor"
+SRC_URI="http://prdownloads.sourceforge.net/abiword/abiword-0.9.3.tar.gz"
+
+HOMEPAGE="http://www.abisource.com"
+
+DEPEND="virtual/glibc
+ >=sys-devel/gcc-2.95.2
+ =media-libs/freetype-1.3.1-r2
+ >=media-libs/libpng-1.0.7
+ >=x11-libs/gtk+-1.2.8
+ gnome? ( >=gnome-base/gnome-libs-1.2.10 >=gnome-base/libunicode-0.4
+ >=gnome-base/bonobo-1.0.4 >=gnome-base/gal-0.8 )
+ spell? ( app-text/pspell-0.11.2 )
+ virtual/x11"
+
+
+ if [ "`use gnome`" ] ; then
+ myconf="ABI_OPT_GNOME=1 ABI_OPT_BONOBO=1 "
+ fi
+ if [ "`use spell`" ] ; then
+ myconf="$myconf ABI_OPT_PSPELL=1"
+ fi
+
+src_compile() {
+
+ if [ "`use spell`" ] ; then
+ cd ${S}/src/config
+ cp abi_defs.mk abi_defs.orig
+ sed -e "s:-lltdl::" abi_defs.orig > abi_defs.mk
+ fi
+ cd ${S}
+
+ # Doesn't work with -j 4 (hallski)
+ try make prefix=/opt/gnome/ UNIX_CAN_BUILD_STATIC=0 $myconf OPTIMIZER="$CFLAGS"
+
+}
+
+src_install() {
+ #do you really need the OPTIMIZER var below? -- DR
+ try make prefix=${D}/opt/gnome UNIX_CAN_BUILD_STATIC=0 $myconf OPTIMIZER="$CFLAGS" install
+ cp ${D}/opt/gnome/AbiSuite/bin/AbiWord AbiWord.orig
+ sed -e "s:${D}::" AbiWord.orig > ${D}/opt/gnome/AbiSuite/bin/AbiWord
+ cd ${D}/opt/gnome/bin
+ rm -f abiword
+ rm -f AbiWord
+ ln -s ../AbiSuite/bin/AbiWord AbiWord
+ ln -s ../AbiSuite/bin/AbiWord abiword
+}
+
+
+
+
diff --git a/app-office/abiword/files/digest-abiword-0.9.3 b/app-office/abiword/files/digest-abiword-0.9.3
new file mode 100644
index 000000000000..6bd0ee14e392
--- /dev/null
+++ b/app-office/abiword/files/digest-abiword-0.9.3
@@ -0,0 +1 @@
+MD5 20a9a7a8a2e8f15219eb6db0a3ec8727 abiword-0.9.3.tar.gz