summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-04-28 08:04:32 +0000
committerAchim Gottinger <achim@gentoo.org>2001-04-28 08:04:32 +0000
commit28242756ead2cdd2b265e63292c4e7f3203ff508 (patch)
tree19e45ebfe23fbcceea631eb74882135bf96862a8 /app-office
parentprefix fix (diff)
downloadhistorical-28242756ead2cdd2b265e63292c4e7f3203ff508.tar.gz
historical-28242756ead2cdd2b265e63292c4e7f3203ff508.tar.bz2
historical-28242756ead2cdd2b265e63292c4e7f3203ff508.zip
Added USE guile,python,mysql
Diffstat (limited to 'app-office')
-rw-r--r--app-office/siag/siag-3.4.7.ebuild33
1 files changed, 30 insertions, 3 deletions
diff --git a/app-office/siag/siag-3.4.7.ebuild b/app-office/siag/siag-3.4.7.ebuild
index c2586facb584..d3d5402433c7 100644
--- a/app-office/siag/siag-3.4.7.ebuild
+++ b/app-office/siag/siag-3.4.7.ebuild
@@ -1,19 +1,46 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-office/siag/siag-3.4.7.ebuild,v 1.1 2001/04/28 06:27:32 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/siag/siag-3.4.7.ebuild,v 1.2 2001/04/28 08:04:32 achim Exp $
S=${WORKDIR}/${P}
DESCRIPTION="A free Office package for Linux"
SRC_URI="ftp://siag.nu/pub/siag/${P}.tar.gz"
HOMEPAGE="http://siag.nu/"
+DEPEND="virtual/x11
+ >=dev-libs/gmp-3.1.1
+ >=media-libs/t1lib-1.0.1
+ mysql? ( dev-db/mysql )
+ guile? ( dev-util/guile )"
+
+RDEPEND="virtual/x11
+ >=media-libs/t1lib-1.0.1"
src_compile() {
+ local myconf
+ if [ "`use mysql`" ]
+ then
+ myconf="--with-mysql"
+ else
+ myconf="--without-mysql"
+ fi
+ if [ "`use guile`" ]
+ then
+ myconf="$myconf --with-guile"
+ else
+ myconf="$myconf --without-guile"
+ fi
+# siag only supports python1.5
+# if [ "`use python`" ]
+# then
+# myconf="$myconf --with-python"
+# else
+# myconf="$myconf --without-python"
+# fi
try ./configure --prefix=/opt/siag --mandir=/opt/siag/share/man --host=${CHOST} \
- --with-guile --with-gmp \
- --with-mysql --with-t1lib
+ --with-gmp --with-t1lib $myconf
try make
}