summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Verwilst <verwilst@gentoo.org>2002-06-28 21:55:33 +0000
committerBart Verwilst <verwilst@gentoo.org>2002-06-28 21:55:33 +0000
commitf524b152b1d1c74e22413cf957ed28d38eae64e6 (patch)
treee3bdf1e7546611f2e472164a2f6c45619d9b5e71 /app-office/koffice
parentUnmasking cups-1.1.15. New ghostscript should fix the problem. (diff)
downloadhistorical-f524b152b1d1c74e22413cf957ed28d38eae64e6.tar.gz
historical-f524b152b1d1c74e22413cf957ed28d38eae64e6.tar.bz2
historical-f524b152b1d1c74e22413cf957ed28d38eae64e6.zip
flag fixor
Diffstat (limited to 'app-office/koffice')
-rw-r--r--app-office/koffice/koffice-1.2_beta2.ebuild25
1 files changed, 24 insertions, 1 deletions
diff --git a/app-office/koffice/koffice-1.2_beta2.ebuild b/app-office/koffice/koffice-1.2_beta2.ebuild
index 5f5df3118baa..06f4903f4ebe 100644
--- a/app-office/koffice/koffice-1.2_beta2.ebuild
+++ b/app-office/koffice/koffice-1.2_beta2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/koffice-1.2_beta2.ebuild,v 1.1 2002/06/27 15:37:51 verwilst Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/koffice-1.2_beta2.ebuild,v 1.2 2002/06/28 21:55:33 verwilst Exp $
inherit kde-base || die
@@ -24,4 +24,27 @@ need-automake 1.5
need-autoconf 2.5
+src_compile() {
+
+ myconf="$myconf --enable-all"
+ kde_src_compile myconf
+
+ #the dir kchar/kdchart cannot be compiled with the -fomit-frame-pointer flag present
+ CXXFLAGS2="$CXXFLAGS"
+ CFLAGS2="$CFLAGS"
+
+ CFLAGS=${CFLAGS/-fomit-frame-pointer}
+ CXXFLAGS=${CXXFLAGS/-fomit-frame-pointer}
+ cd ${S}
+ kde_src_compile configure
+ cd ${S}/kchart/kdchart
+ make
+
+ CFLAGS="$CFLAGS2"
+ CXXFLAGS="$CXXFLAGS2"
+ cd ${S}
+ kde_src_compile configure
+ make
+
+}