summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2007-05-29 18:37:24 +0000
committerCédric Krier <cedk@gentoo.org>2007-05-29 18:37:24 +0000
commita435e5711f2bd2d3db7cb80862e036713c037c03 (patch)
tree12b3671e2806eb235b829fd274c7ec63f31443cc /app-office/calcurse/calcurse-1.8.ebuild
parentalpha stable wrt #175560 (diff)
downloadhistorical-a435e5711f2bd2d3db7cb80862e036713c037c03.tar.gz
historical-a435e5711f2bd2d3db7cb80862e036713c037c03.tar.bz2
historical-a435e5711f2bd2d3db7cb80862e036713c037c03.zip
app-office/calcurse: Version bump
Package-Manager: portage-2.1.2.7
Diffstat (limited to 'app-office/calcurse/calcurse-1.8.ebuild')
-rw-r--r--app-office/calcurse/calcurse-1.8.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-office/calcurse/calcurse-1.8.ebuild b/app-office/calcurse/calcurse-1.8.ebuild
new file mode 100644
index 000000000000..df5cfe7c8c76
--- /dev/null
+++ b/app-office/calcurse/calcurse-1.8.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/calcurse/calcurse-1.8.ebuild,v 1.1 2007/05/29 18:37:24 cedk Exp $
+
+DESCRIPTION="a text-based personal organizer"
+HOMEPAGE="http://culot.org/calcurse/index.html"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="linguas_en linguas_fr linguas_de linguas_es"
+
+DEPEND="sys-libs/ncurses"
+RDEPEND=${DEPEND}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ rm po/LINGUAS
+}
+
+src_compile() {
+ local ALL_LINGUAS=""
+
+ use linguas_en && ALL_LINGUAS="${ALL_LINGUAS} en"
+ use linguas_fr && ALL_LINGUAS="${ALL_LINGUAS} fr"
+ use linguas_de && ALL_LINGUAS="${ALL_LINGUAS} de"
+ use linguas_es && ALL_LINGUAS="${ALL_LINGUAS} es"
+
+ ALL_LINGUAS="${ALL_LINGUAS}" econf || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+ dohtml doc/*.html
+}