summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-10-30 03:53:10 +0000
committerAron Griffis <agriffis@gentoo.org>2004-10-30 03:53:10 +0000
commit3290d9b19075255b64113bee8d2e481e43822704 (patch)
tree722789ef570345992f3b87caa4948d3bd7ba65e7 /app-misc/nut/nut-10.7.ebuild
parentFixed permissions issue per bug #64558 for ferringb. (diff)
downloadhistorical-3290d9b19075255b64113bee8d2e481e43822704.tar.gz
historical-3290d9b19075255b64113bee8d2e481e43822704.tar.bz2
historical-3290d9b19075255b64113bee8d2e481e43822704.zip
Add ebuild for Jim Jozwiak's nutrition program. Thanks to Chris Houser (Chouser) for the ebuild
Diffstat (limited to 'app-misc/nut/nut-10.7.ebuild')
-rw-r--r--app-misc/nut/nut-10.7.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-misc/nut/nut-10.7.ebuild b/app-misc/nut/nut-10.7.ebuild
new file mode 100644
index 000000000000..5921b2beaebb
--- /dev/null
+++ b/app-misc/nut/nut-10.7.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/nut/nut-10.7.ebuild,v 1.1 2004/10/30 03:53:10 agriffis Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="record what you eat and analyze your nutrient levels"
+HOMEPAGE="http://www.lafn.org/~av832/"
+SRC_URI="http://www.lafn.org/~av832/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=""
+
+src_compile() {
+ append-flags '-DNUTDIR=\".nutdb\" -DFOODDIR=\"/usr/share/nut\"'
+ emake CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dodir /usr/share/nut
+ cp -a raw.data/* ${D}/usr/share/nut/
+ dobin nut
+ doman nut.1
+}