summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2009-06-04 16:22:21 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2009-06-04 16:22:21 +0000
commit0ed31e086491d07946d60670e4f1b83116dd464e (patch)
tree753feba0412c2c9808dc8ea24d02c86f4f9d0a2b /app-i18n
parentAdded update module for GTK+-2.16. (diff)
downloadhistorical-0ed31e086491d07946d60670e4f1b83116dd464e.tar.gz
historical-0ed31e086491d07946d60670e4f1b83116dd464e.tar.bz2
historical-0ed31e086491d07946d60670e4f1b83116dd464e.zip
Version bumped.
Package-Manager: portage-2.1.6.13/cvs/Linux x86_64
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-anthy/ChangeLog8
-rw-r--r--app-i18n/ibus-anthy/ibus-anthy-1.1.0.20090603.ebuild55
-rw-r--r--app-i18n/ibus-table-translit/ChangeLog8
-rw-r--r--app-i18n/ibus-table-translit/ibus-table-translit-1.1.0.20090603.ebuild31
-rw-r--r--app-i18n/ibus-table/ChangeLog9
-rw-r--r--app-i18n/ibus-table/ibus-table-1.1.0.20090505.ebuild47
-rw-r--r--app-i18n/ibus-table/ibus-table-1.1.0.20090527.ebuild47
-rw-r--r--app-i18n/ibus-table/ibus-table-1.1.0.20090603.ebuild (renamed from app-i18n/ibus-table/ibus-table-1.1.0.20090306.ebuild)2
8 files changed, 109 insertions, 98 deletions
diff --git a/app-i18n/ibus-anthy/ChangeLog b/app-i18n/ibus-anthy/ChangeLog
index 976081ae4958..05203f6048db 100644
--- a/app-i18n/ibus-anthy/ChangeLog
+++ b/app-i18n/ibus-anthy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/ibus-anthy
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-anthy/ChangeLog,v 1.8 2009/04/02 16:04:05 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-anthy/ChangeLog,v 1.9 2009/06/04 16:22:21 matsuu Exp $
+
+*ibus-anthy-1.1.0.20090603 (04 Jun 2009)
+
+ 04 Jun 2009; MATSUU Takuto <matsuu@gentoo.org>
+ +ibus-anthy-1.1.0.20090603.ebuild:
+ Version bumped.
*ibus-anthy-1.1.0.20090402 (02 Apr 2009)
diff --git a/app-i18n/ibus-anthy/ibus-anthy-1.1.0.20090603.ebuild b/app-i18n/ibus-anthy/ibus-anthy-1.1.0.20090603.ebuild
new file mode 100644
index 000000000000..ab3b1e835af2
--- /dev/null
+++ b/app-i18n/ibus-anthy/ibus-anthy-1.1.0.20090603.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-anthy/ibus-anthy-1.1.0.20090603.ebuild,v 1.1 2009/06/04 16:22:21 matsuu Exp $
+
+inherit eutils python
+
+DESCRIPTION="Japanese input method Anthy IMEngine for IBus Framework"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND=">=app-i18n/ibus-1.1.0
+ app-i18n/anthy
+ >=dev-lang/python-2.5
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-lang/swig
+ dev-util/pkgconfig
+ nls? ( >=sys-devel/gettext-0.16.1 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ mv py-compile py-compile.orig || die
+ ln -s "$(type -P true)" py-compile || die
+}
+
+src_compile() {
+ econf $(use_enable nls) || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ ewarn "This package is very experimental, please report your bugs to"
+ ewarn "http://ibus.googlecode.com/issues/list"
+ elog
+ elog "You should run ibus-setup and enable IM Engines you want to use!"
+ elog
+
+ python_mod_optimize /usr/share/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}
+}
diff --git a/app-i18n/ibus-table-translit/ChangeLog b/app-i18n/ibus-table-translit/ChangeLog
index 721468867b31..2f76ef9b25a9 100644
--- a/app-i18n/ibus-table-translit/ChangeLog
+++ b/app-i18n/ibus-table-translit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/ibus-table-translit
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-table-translit/ChangeLog,v 1.1 2009/06/01 15:19:21 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-table-translit/ChangeLog,v 1.2 2009/06/04 16:15:38 matsuu Exp $
+
+*ibus-table-translit-1.1.0.20090603 (04 Jun 2009)
+
+ 04 Jun 2009; MATSUU Takuto <matsuu@gentoo.org>
+ +ibus-table-translit-1.1.0.20090603.ebuild:
+ Version bumped.
*ibus-table-translit-1.1.0.20090601 (01 Jun 2009)
diff --git a/app-i18n/ibus-table-translit/ibus-table-translit-1.1.0.20090603.ebuild b/app-i18n/ibus-table-translit/ibus-table-translit-1.1.0.20090603.ebuild
new file mode 100644
index 000000000000..05a45efb3225
--- /dev/null
+++ b/app-i18n/ibus-table-translit/ibus-table-translit-1.1.0.20090603.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-table-translit/ibus-table-translit-1.1.0.20090603.ebuild,v 1.1 2009/06/04 16:15:38 matsuu Exp $
+
+DESCRIPTION="The Translit input method on IBus Table"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-i18n/ibus-table-1.1
+ >=dev-lang/python-2.5"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ ewarn "This package is very experimental, please report your bugs to"
+ ewarn "http://ibus.googlecode.com/issues/list"
+ elog
+ elog "You should run ibus-setup and enable IM Engines you want to use!"
+ elog
+}
diff --git a/app-i18n/ibus-table/ChangeLog b/app-i18n/ibus-table/ChangeLog
index 4a44c1f485ec..ea20da2874a2 100644
--- a/app-i18n/ibus-table/ChangeLog
+++ b/app-i18n/ibus-table/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-i18n/ibus-table
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-table/ChangeLog,v 1.12 2009/06/01 15:11:47 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-table/ChangeLog,v 1.13 2009/06/04 16:18:27 matsuu Exp $
+
+*ibus-table-1.1.0.20090603 (04 Jun 2009)
+
+ 04 Jun 2009; MATSUU Takuto <matsuu@gentoo.org>
+ -ibus-table-1.1.0.20090306.ebuild, -ibus-table-1.1.0.20090505.ebuild,
+ -ibus-table-1.1.0.20090527.ebuild, +ibus-table-1.1.0.20090603.ebuild:
+ Version bumped. Removed old versions.
*ibus-table-1.1.0.20090601 (01 Jun 2009)
diff --git a/app-i18n/ibus-table/ibus-table-1.1.0.20090505.ebuild b/app-i18n/ibus-table/ibus-table-1.1.0.20090505.ebuild
deleted file mode 100644
index d98490262129..000000000000
--- a/app-i18n/ibus-table/ibus-table-1.1.0.20090505.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-table/ibus-table-1.1.0.20090505.ebuild,v 1.1 2009/05/07 23:47:54 matsuu Exp $
-
-EAPI="2"
-inherit eutils python
-
-DESCRIPTION="The Table Engine for IBus Framework"
-HOMEPAGE="http://code.google.com/p/ibus/"
-SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="minimal nls"
-
-RDEPEND=">=app-i18n/ibus-1.1
- >=dev-lang/python-2.5[sqlite]
- nls? ( virtual/libintl )"
-DEPEND="${RDEPEND}
- nls? ( >=sys-devel/gettext-0.16.1 )
- dev-util/pkgconfig"
-
-src_prepare() {
- mv py-compile py-compile.orig || die
- ln -s "$(type -P true)" py-compile || die
-}
-
-src_configure() {
- econf \
- $(use_enable !minimal additional) \
- $(use_enable nls) || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-
- dodoc AUTHORS ChangeLog NEWS README
-}
-
-pkg_postinst() {
- python_mod_optimize /usr/share/${PN}/engine
-}
-
-pkg_postrm() {
- python_mod_cleanup /usr/share/${PN}/engine
-}
diff --git a/app-i18n/ibus-table/ibus-table-1.1.0.20090527.ebuild b/app-i18n/ibus-table/ibus-table-1.1.0.20090527.ebuild
deleted file mode 100644
index 73403ce1fbee..000000000000
--- a/app-i18n/ibus-table/ibus-table-1.1.0.20090527.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-table/ibus-table-1.1.0.20090527.ebuild,v 1.1 2009/05/31 13:24:17 matsuu Exp $
-
-EAPI="2"
-inherit eutils python
-
-DESCRIPTION="The Table Engine for IBus Framework"
-HOMEPAGE="http://code.google.com/p/ibus/"
-SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="minimal nls"
-
-RDEPEND=">=app-i18n/ibus-1.1
- >=dev-lang/python-2.5[sqlite]
- nls? ( virtual/libintl )"
-DEPEND="${RDEPEND}
- nls? ( >=sys-devel/gettext-0.16.1 )
- dev-util/pkgconfig"
-
-src_prepare() {
- mv py-compile py-compile.orig || die
- ln -s "$(type -P true)" py-compile || die
-}
-
-src_configure() {
- econf \
- $(use_enable !minimal additional) \
- $(use_enable nls) || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-
- dodoc AUTHORS ChangeLog NEWS README
-}
-
-pkg_postinst() {
- python_mod_optimize /usr/share/${PN}/engine
-}
-
-pkg_postrm() {
- python_mod_cleanup /usr/share/${PN}/engine
-}
diff --git a/app-i18n/ibus-table/ibus-table-1.1.0.20090306.ebuild b/app-i18n/ibus-table/ibus-table-1.1.0.20090603.ebuild
index 8df3df6adeea..9b0eccfa7e6e 100644
--- a/app-i18n/ibus-table/ibus-table-1.1.0.20090306.ebuild
+++ b/app-i18n/ibus-table/ibus-table-1.1.0.20090603.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-table/ibus-table-1.1.0.20090306.ebuild,v 1.1 2009/03/07 15:29:32 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-table/ibus-table-1.1.0.20090603.ebuild,v 1.1 2009/06/04 16:18:27 matsuu Exp $
EAPI="2"
inherit eutils python