summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2004-07-25 10:17:30 +0000
committerAkinori Hattori <hattya@gentoo.org>2004-07-25 10:17:30 +0000
commiteb8fae2aec7db449d151046a58322d5983d24e4e (patch)
tree170e4fe76e67fd76414a0c2854a5c57f68d5031d /app-i18n/anthy-ss
parentMarked -hppa. It b0rks glibc and co. (diff)
downloadhistorical-eb8fae2aec7db449d151046a58322d5983d24e4e.tar.gz
historical-eb8fae2aec7db449d151046a58322d5983d24e4e.tar.bz2
historical-eb8fae2aec7db449d151046a58322d5983d24e4e.zip
version bump.
Diffstat (limited to 'app-i18n/anthy-ss')
-rw-r--r--app-i18n/anthy-ss/ChangeLog7
-rw-r--r--app-i18n/anthy-ss/Manifest4
-rw-r--r--app-i18n/anthy-ss/anthy-ss-5524.ebuild69
-rw-r--r--app-i18n/anthy-ss/files/digest-anthy-ss-55241
4 files changed, 79 insertions, 2 deletions
diff --git a/app-i18n/anthy-ss/ChangeLog b/app-i18n/anthy-ss/ChangeLog
index 3b2ff079fca6..1702217c6b2f 100644
--- a/app-i18n/anthy-ss/ChangeLog
+++ b/app-i18n/anthy-ss/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/anthy-ss
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy-ss/ChangeLog,v 1.38 2004/07/25 07:24:57 hattya Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy-ss/ChangeLog,v 1.39 2004/07/25 10:17:30 hattya Exp $
+
+*anthy-ss-5524 (25 Jul 2004)
+
+ 25 Jul 2004; Akinori Hattori <hattya@gentoo.org> +anthy-ss-5524.ebuild:
+ version bump.
*anthy-ss-5516 (25 Jul 2004)
diff --git a/app-i18n/anthy-ss/Manifest b/app-i18n/anthy-ss/Manifest
index 940df7267c59..81c08533f2a5 100644
--- a/app-i18n/anthy-ss/Manifest
+++ b/app-i18n/anthy-ss/Manifest
@@ -1,11 +1,13 @@
-MD5 67185f0753eab7d5a724e49b2913104e ChangeLog 5351
+MD5 51cdbe3799d0ebe59870923bb307bad9 ChangeLog 5472
MD5 d50cf115437d38d8e44a8a1bcafcc8e4 anthy-ss-5406.ebuild 1640
MD5 d4c1e868e1e861d1b26de003d3fccb46 anthy-ss-5414.ebuild 1640
MD5 eea045facfc6344d35dd497c2457d91e anthy-ss-5516.ebuild 1641
MD5 134e67bcaecac79d949afa5eb9672eac anthy-ss-5523.ebuild 1516
+MD5 6a4d089f12ccee7c064e9f51d9674058 anthy-ss-5524.ebuild 1516
MD5 bae17b53f1633ca708e67b8762933954 metadata.xml 616
MD5 d91fcb424ec63b588900d2d88a8bcee2 files/50anthy-gentoo.el 99
MD5 5cf47066ec69dd7bf5cb5608655b26ed files/digest-anthy-ss-5406 63
MD5 7b897d744e2bdb8daebdcbe4ff258cff files/digest-anthy-ss-5414 63
MD5 ae0b002102ce35af49630eaab916579b files/digest-anthy-ss-5516 63
MD5 c9253a102c9b0a8603aa76db6739bc44 files/digest-anthy-ss-5523 63
+MD5 b5662c0f7e3322dd5faafd4c93369a41 files/digest-anthy-ss-5524 63
diff --git a/app-i18n/anthy-ss/anthy-ss-5524.ebuild b/app-i18n/anthy-ss/anthy-ss-5524.ebuild
new file mode 100644
index 000000000000..85b8a719f537
--- /dev/null
+++ b/app-i18n/anthy-ss/anthy-ss-5524.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy-ss/anthy-ss-5524.ebuild,v 1.1 2004/07/25 10:17:30 hattya Exp $
+
+inherit elisp-common
+
+IUSE="emacs ucs4"
+
+MY_P="${P/-ss/}"
+
+DESCRIPTION="Anthy -- free and secure Japanese input system"
+HOMEPAGE="http://anthy.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/anthy/10485/${MY_P}.tar.gz"
+
+RESTRICT="nomirror"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+SLOT="0"
+S="${WORKDIR}/${MY_P}"
+
+DEPEND="emacs? ( virtual/emacs )
+ !app-i18n/anthy"
+
+src_compile() {
+
+ local myconf
+ local cannadicdir=/var/lib/canna/dic/canna
+
+ use emacs || myconf="EMACS=no"
+ use ucs4 && myconf="${myconf} --enable-ucs4"
+
+ if has_version 'app-dicts/canna-zipcode'; then
+ einfo "Adding zipcode.t and jigyosyo.t to anthy.dic."
+ cp ${cannadicdir}/{zipcode,jigyosyo}.t mkanthydic
+ sed -i -e "/^EXTRA_DICS/s|$| zipcode.t jigyosyo.t|" mkanthydic/Makefile.in
+ fi
+
+ if has_version 'app-dicts/canna-2ch'; then
+ einfo "Adding nichan.ctd to anthy.dic."
+ cp ${cannadicdir}/nichan.ctd mkanthydic/2ch.t
+ sed -i -e "/^EXTRA_DICS/s|$| 2ch.t|" mkanthydic/Makefile.in
+ fi
+
+ econf ${myconf} || die
+ emake || die
+
+}
+
+src_install() {
+
+ einstall || die
+
+ use emacs && elisp-site-file-install ${FILESDIR}/50anthy-gentoo.el
+
+ dodoc [A-Z][A-Z]* ChangeLog doc/[A-Z0-9][A-Z0-9]* doc/protocol.txt
+
+}
+
+pkg_postinst() {
+
+ use emacs && elisp-site-regen
+
+}
+
+pkg_postrm() {
+
+ has_version virtual/emacs && elisp-site-regen
+
+}
diff --git a/app-i18n/anthy-ss/files/digest-anthy-ss-5524 b/app-i18n/anthy-ss/files/digest-anthy-ss-5524
new file mode 100644
index 000000000000..a1a38279683b
--- /dev/null
+++ b/app-i18n/anthy-ss/files/digest-anthy-ss-5524
@@ -0,0 +1 @@
+MD5 c7ae6242db6f10507f04ad824d1b1bc6 anthy-5524.tar.gz 1546770