summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2004-09-18 21:02:05 +0000
committerAaron Walker <ka0ttic@gentoo.org>2004-09-18 21:02:05 +0000
commit6b0c552bab71de0f37e8ed262adf0baa21213fb2 (patch)
tree2227e335ed65836e7f6f2e8b1e747f45bff8b5dc /app-forensics/chkrootkit
parentFixed ChangeLog header. (diff)
downloadhistorical-6b0c552bab71de0f37e8ed262adf0baa21213fb2.tar.gz
historical-6b0c552bab71de0f37e8ed262adf0baa21213fb2.tar.bz2
historical-6b0c552bab71de0f37e8ed262adf0baa21213fb2.zip
Version bump and clean up.
Diffstat (limited to 'app-forensics/chkrootkit')
-rw-r--r--app-forensics/chkrootkit/ChangeLog11
-rw-r--r--app-forensics/chkrootkit/chkrootkit-0.37.ebuild31
-rw-r--r--app-forensics/chkrootkit/chkrootkit-0.44.ebuild45
-rw-r--r--app-forensics/chkrootkit/files/chkrootkit-0.37-gentoo.diff152
-rw-r--r--app-forensics/chkrootkit/files/digest-chkrootkit-0.371
-rw-r--r--app-forensics/chkrootkit/files/digest-chkrootkit-0.442
6 files changed, 56 insertions, 186 deletions
diff --git a/app-forensics/chkrootkit/ChangeLog b/app-forensics/chkrootkit/ChangeLog
index f432d2d792e0..d8960e4e1618 100644
--- a/app-forensics/chkrootkit/ChangeLog
+++ b/app-forensics/chkrootkit/ChangeLog
@@ -1,6 +1,13 @@
-# ChangeLog for app-admin/chkrootkit
+# ChangeLog for app-forensics/chkrootkit
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/chkrootkit/ChangeLog,v 1.7 2004/09/18 18:16:28 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/chkrootkit/ChangeLog,v 1.8 2004/09/18 21:02:05 ka0ttic Exp $
+
+*chkrootkit-0.44 (18 Sep 2004)
+
+ 18 Sep 2004; Aaron Walker <ka0ttic@gentoo.org>
+ -files/chkrootkit-0.37-gentoo.diff, -chkrootkit-0.37.ebuild,
+ +chkrootkit-0.44.ebuild:
+ Version bump and clean up.
18 Sep 2004; Travis Tilley <lv@gentoo.org> chkrootkit-0.43-r3.ebuild:
stable on amd64
diff --git a/app-forensics/chkrootkit/chkrootkit-0.37.ebuild b/app-forensics/chkrootkit/chkrootkit-0.37.ebuild
deleted file mode 100644
index bd2199c4a388..000000000000
--- a/app-forensics/chkrootkit/chkrootkit-0.37.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/chkrootkit/chkrootkit-0.37.ebuild,v 1.1 2004/09/12 06:58:28 dragonheart Exp $
-
-inherit eutils
-
-DESCRIPTION="a tool to locally check for signs of a rootkit"
-HOMEPAGE="http://www.chkrootkit.org/"
-SRC_URI="ftp://ftp.pangeia.com.br/pub/seg/pac/${P}.tar.gz"
-
-LICENSE="AMS"
-SLOT="0"
-KEYWORDS="x86 ppc sparc alpha"
-IUSE=""
-
-DEPEND="virtual/libc"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PF}-gentoo.diff
-}
-
-src_compile() {
- make sense || die
-}
-
-src_install() {
- dosbin check_wtmpx chklastlog chkproc chkrootkit chkwtmp ifpromisc || die
- dodoc README README.chklastlog README.chkwtmp
-}
diff --git a/app-forensics/chkrootkit/chkrootkit-0.44.ebuild b/app-forensics/chkrootkit/chkrootkit-0.44.ebuild
new file mode 100644
index 000000000000..cb1d7056a764
--- /dev/null
+++ b/app-forensics/chkrootkit/chkrootkit-0.44.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/chkrootkit/chkrootkit-0.44.ebuild,v 1.1 2004/09/18 21:02:05 ka0ttic Exp $
+
+inherit eutils
+
+DESCRIPTION="a tool to locally check for signs of a rootkit"
+HOMEPAGE="http://www.chkrootkit.org/"
+SRC_URI="ftp://ftp.pangeia.com.br/pub/seg/pac/${P}.tar.gz
+ mirror://gentoo/${P}-gentoo.diff.gz"
+
+LICENSE="AMS"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~ia64 ~amd64"
+IUSE=""
+
+DEPEND="virtual/libc
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${WORKDIR}/${P}-gentoo.diff
+ sed -i 's:${head} -:${head} -n :' chkrootkit || die "sed chkrootkit failed"
+ sed -i 's:/var/adm:/var/log:g' chklastlog.c || die "sed chklastlog.c failed"
+}
+
+src_compile() {
+ make sense || die
+}
+
+src_install() {
+ dosbin chkdirs chklastlog chkproc chkrootkit chkwtmp ifpromisc \
+ strings-static || die
+ dodoc README README.chklastlog README.chkwtmp
+
+ exeinto /etc/cron.weekly
+ newexe ${FILESDIR}/${PN}.cron ${PN} || die
+}
+
+pkg_postinst() {
+ echo
+ einfo "Edit /etc/cron.weekly/chkrootkit to activate chkrootkit!"
+ echo
+}
diff --git a/app-forensics/chkrootkit/files/chkrootkit-0.37-gentoo.diff b/app-forensics/chkrootkit/files/chkrootkit-0.37-gentoo.diff
deleted file mode 100644
index 71212baa9fb6..000000000000
--- a/app-forensics/chkrootkit/files/chkrootkit-0.37-gentoo.diff
+++ /dev/null
@@ -1,152 +0,0 @@
---- chkrootkit-0.37/chkrootkit 2002-09-16 18:03:11.000000000 -0500
-+++ chkrootkit 2002-11-24 15:08:33.000000000 -0500
-@@ -10,6 +10,15 @@
- # (C)1997-2002 Nelson Murilo, Pangeia Informatica, AMS Foundation and others.
- # All rights reserved
-
-+# Gentoo specific : Could use `type <command> | cut -f 3 -d " "`
-+IFPROMISC="/usr/sbin/ifpromisc"
-+CHKLASTLOG="/usr/sbin/chklastlog"
-+CHKPROC="/usr/sbin/chkproc"
-+CHKWTMP="/usr/sbin/chkwtmp"
-+CHECK_WTMPX="/usr/sbin/check_wtmpx"
-+# ebuild doesn't install chkrootkit's strings; use gnus.
-+STRINGS="/usr/bin/strings"
-+
- ### workaround for some Bourne shell implementations
- unalias login > /dev/null 2>&1
- unalias ls > /dev/null 2>&1
-@@ -125,22 +134,22 @@
- return ${NOT_TESTED}
- fi
-
-- if [ ! -x ./ifpromisc ]; then
-- echo "not tested: can't exec ./ifpromisc"
-+ if [ ! -x $IFPROMISC ]; then
-+ echo "not tested: can't exec $IFPROMISC"
- return ${NOT_TESTED}
- fi
-
- if [ "${EXPERT}" = "t" ]; then
-- expertmode_output "./ifpromisc"
-+ expertmode_output "$IFPROMISC"
- return 5
- fi
- echo
-- ./ifpromisc
-+ $IFPROMISC
- }
-
- z2 () {
-- if [ ! -x ./chklastlog ]; then
-- echo "not tested: can't exec ./chklastlog"
-+ if [ ! -x $CHKLASTLOG ]; then
-+ echo "not tested: can't exec $CHKLASTLOG"
- return ${NOT_TESTED}
- fi
-
-@@ -148,31 +157,31 @@
- LASTLOG=`loc lastlog lastlog "${ROOTDIR}var/log ${ROOTDIR}var/adm"`
-
- if [ "${EXPERT}" = "t" ]; then
-- expertmode_output "./chklastlog -f ${WTMP} -l ${LASTLOG}"
-+ expertmode_output "$CHKLASTLOG -f ${WTMP} -l ${LASTLOG}"
- return 5
- fi
-
-- if ./chklastlog -f ${WTMP} -l ${LASTLOG}
-+ if $CHKLASTLOG -f ${WTMP} -l ${LASTLOG}
- then
- if [ "${QUIET}" != "t" ]; then echo "nothing deleted"; fi
- fi
- }
-
- wted () {
-- if [ ! -x ./chkwtmp ]; then
-- echo "not tested: can't exec ./chkwtmp"
-+ if [ ! -x $CHKWTMP ]; then
-+ echo "not tested: can't exec $CHKWTMP"
- return ${NOT_TESTED}
- fi
-
- if [ "$SYSTEM" = "SunOS" ]; then
-- if [ ! -x ./check_wtmpx ]; then
-- echo "not tested: can't exec ./check_wtmpx"
-+ if [ ! -x $CHECK_WTMPX ]; then
-+ echo "not tested: can't exec $CHECK_WTMPX"
- else
- if [ "${EXPERT}" = "t" ]; then
-- expertmode_output "./check_wtmpx"
-+ expertmode_output "$CHECK_WTMPX"
- return 5
- fi
-- if ./check_wtmpx
-+ if $CHECK_WTMPX
- then
- if [ "${QUIET}" != "t" ]; then \
- echo "nothing deleted in /var/adm/wtmpx"; fi
-@@ -183,11 +192,11 @@
- WTMP=`loc wtmp wtmp "${ROOTDIR}var/log ${ROOTDIR}var/adm"`
-
- if [ "${EXPERT}" = "t" ]; then
-- expertmode_output "./chkwtmp -f ${WTMP}"
-+ expertmode_output "$CHKWTMP -f ${WTMP}"
- return 5
- fi
-
-- if ./chkwtmp -f ${WTMP}
-+ if $CHKWTMP -f ${WTMP}
- then
- if [ "${QUIET}" != "t" ]; then echo "nothing deleted"; fi
- fi
-@@ -225,15 +234,15 @@
- {
- if [ \( "${SYSTEM}" = "Linux" -o \( "${SYSTEM}" = "FreeBSD" -a \
- ${V} -gt 43 \) \) -a "${ROOTDIR}" = "/" ]; then
-- if [ ! -x ./chkproc ]; then
-- echo "not tested: can't exec ./chkproc"
-+ if [ ! -x $CHKPROC ]; then
-+ echo "not tested: can't exec $CHKPROC"
- return ${NOT_TESTED}
- fi
-
- if [ "${EXPERT}" = "t" ]; then
- [ -r /proc/ksyms ] && ${egrep} -i adore < /proc/ksyms 2>/dev/null
- [ -d /proc/knark ] && ${ls} -la /proc/knark 2> /dev/null
-- expertmode_output "./chkproc -v"
-+ expertmode_output "$CHKPROC -v"
- return 5
- fi
-
-@@ -248,7 +257,7 @@
- echo "Warning: Knark LKM installed"
- fi
-
-- if ./chkproc
-+ if $CHKPROC
- then
- if [ "${QUIET}" != "t" ]; then echo "nothing detected"; fi
- else
-@@ -1293,18 +1302,18 @@
-
- if [ "${SYSTEM}" = "Linux" ]
- then
-- if [ ! -x ./strings ]; then
-- printn "can't exec ./strings-static, "
-+ if [ ! -x $STRINGS ]; then
-+ print "can't exec $STRINGS, "
- return ${NOT_TESTED}
- fi
-
- if [ "${EXPERT}" = "t" ]; then
-- expertmode_output "./strings -a ${CMD}"
-+ expertmode_output "$STRINGS -a ${CMD}"
- return 5
- fi
-
- ### strings must be a statically linked binary.
-- if ./strings-static -a ${CMD} > /dev/null 2>&1
-+ if $STRINGS -a ${CMD} > /dev/null 2>&1
- then
- STATUS=${INFECTED}
- fi
diff --git a/app-forensics/chkrootkit/files/digest-chkrootkit-0.37 b/app-forensics/chkrootkit/files/digest-chkrootkit-0.37
deleted file mode 100644
index c261bbd08184..000000000000
--- a/app-forensics/chkrootkit/files/digest-chkrootkit-0.37
+++ /dev/null
@@ -1 +0,0 @@
-MD5 b0feebea67655daa440da92099dd5187 chkrootkit-0.37.tar.gz 25312
diff --git a/app-forensics/chkrootkit/files/digest-chkrootkit-0.44 b/app-forensics/chkrootkit/files/digest-chkrootkit-0.44
new file mode 100644
index 000000000000..955ca947923f
--- /dev/null
+++ b/app-forensics/chkrootkit/files/digest-chkrootkit-0.44
@@ -0,0 +1,2 @@
+MD5 8f6dbb3204c24e9b71490142cb2953ee chkrootkit-0.44.tar.gz 34163
+MD5 5d94506f73748348d879d882bf791ca8 chkrootkit-0.44-gentoo.diff.gz 3931