summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2002-08-29 01:55:42 +0000
committerGeorge Shapovalov <george@gentoo.org>2002-08-29 01:55:42 +0000
commit89eb81d04f9d0bf4b2e02b460f8c9b0c1a88e237 (patch)
treed14a613f2ae36624bd04706996b6c4583800e8b3 /app-emulation
parentmasked pose-2.5-r1 for testing (diff)
downloadhistorical-89eb81d04f9d0bf4b2e02b460f8c9b0c1a88e237.tar.gz
historical-89eb81d04f9d0bf4b2e02b460f8c9b0c1a88e237.tar.bz2
historical-89eb81d04f9d0bf4b2e02b460f8c9b0c1a88e237.zip
fixes fltk issue
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/pose/ChangeLog16
-rw-r--r--app-emulation/pose/files/choose-gl.diff24
-rw-r--r--app-emulation/pose/files/detect-fluid.diff48
-rw-r--r--app-emulation/pose/files/digest-pose-3.5-r12
-rw-r--r--app-emulation/pose/files/init-clipwidget.diff18
-rw-r--r--app-emulation/pose/files/separate-builddir.diff62
-rw-r--r--app-emulation/pose/pose-3.5-r1.ebuild86
7 files changed, 254 insertions, 2 deletions
diff --git a/app-emulation/pose/ChangeLog b/app-emulation/pose/ChangeLog
index cc971eb6c9bb..b0ce71e98a72 100644
--- a/app-emulation/pose/ChangeLog
+++ b/app-emulation/pose/ChangeLog
@@ -1,7 +1,19 @@
# ChangeLog for app-text/hd2u
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
# Maintainer: George Shapovalov <georges@its.caltech.edu>
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/pose/ChangeLog,v 1.2 2002/07/22 18:51:47 owen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/pose/ChangeLog,v 1.3 2002/08/29 01:55:42 george Exp $
+
+*pose-3.5-r1, (28 Aug 2002)
+
+ 28 Aug 2002; George Shapovalov <george@gentoo.org> pose-3.5-r1.ebuild, files/{choose-gl.diff,detect-fluid.diff,init-clipwidget.diff,separate-builddir.diff} :
+
+ checked, did few cosmetic fixes and committed
+
+ 28 Aug 2002; David Mott <austmighty@yahoo.com> :
+ Changed whole ebuild structure. Now compiles statically.
+ A bit of a kludge but it works. Based on John Marshall's
+ rpm.spec file for POSE.
+
*pose-3.5, (10 May 2002)
@@ -9,6 +21,6 @@
Changed DEPEND to fltk-1.1.0_beta10 as fltk-1.1.0_rc4 breaks
POSE.
- 10 May 2002; G Shapovalov <george@gentoo.org> ChangeLog :
+ 10 May 2002; G Shapovalov <george@gentoo.org> pose-3.5.ebuild :
initial release
diff --git a/app-emulation/pose/files/choose-gl.diff b/app-emulation/pose/files/choose-gl.diff
new file mode 100644
index 000000000000..f174c0ab8f5f
--- /dev/null
+++ b/app-emulation/pose/files/choose-gl.diff
@@ -0,0 +1,24 @@
+--- Emulator_Src_3.4/BuildUnix/configure.in.orig Thu Feb 21 23:06:38 2002
++++ Emulator_Src_3.4/BuildUnix/configure.in Thu Feb 21 23:05:57 2002
+@@ -321,6 +321,13 @@
+
+ GLLIB=
+
++dnl When we go to FLTK 1.1 this will get easier: we will be able to ask
++dnl FLTK whether it needs GL via fltk-config
++
++AC_ARG_ENABLE(gl,
++ [ --disable-gl use OpenGL (default yes)])
++
++if test x$enable_gl != xno; then
+ AC_CHECK_HEADER(GL/gl.h,
+ AC_CHECK_LIB(GL, glXMakeCurrent, AC_DEFINE(HAVE_GL) GLLIB="-lGL", \
+ AC_CHECK_LIB(MesaGL, glXMakeCurrent, AC_DEFINE(HAVE_GL) GLLIB=" -lMesaGL",,\
+@@ -337,6 +344,7 @@
+ GLLIB="-lMesaGLU $GLLIB"
+ fi
+ )
++fi
+
+ AC_SUBST(GLLIB)
+
diff --git a/app-emulation/pose/files/detect-fluid.diff b/app-emulation/pose/files/detect-fluid.diff
new file mode 100644
index 000000000000..5d2795d2b039
--- /dev/null
+++ b/app-emulation/pose/files/detect-fluid.diff
@@ -0,0 +1,48 @@
+diff -urNp orig-Emulator_Src_3.4/BuildUnix/Makefile.am Emulator_Src_3.4/BuildUnix/Makefile.am
+--- orig-Emulator_Src_3.4/BuildUnix/Makefile.am Thu Jan 31 02:55:31 2002
++++ Emulator_Src_3.4/BuildUnix/Makefile.am Mon Feb 18 10:48:21 2002
+@@ -415,7 +415,7 @@ ResStrings.cpp: $(srcdir)/../SrcShared/S
+ perl -x $(srcdir)/../SrcShared/Strings.txt
+
+ EmDlgFltkFactory.h EmDlgFltkFactory.cpp : $(srcdir)/../SrcUnix/EmDlgFltkFactory.fl
+- fluid -c $(srcdir)/../SrcUnix/EmDlgFltkFactory.fl
++ $(FLUID) -c $(srcdir)/../SrcUnix/EmDlgFltkFactory.fl
+
+ EmDlgFltk.o : EmDlgFltkFactory.h
+
+diff -urNp orig-Emulator_Src_3.4/BuildUnix/configure.in Emulator_Src_3.4/BuildUnix/configure.in
+--- orig-Emulator_Src_3.4/BuildUnix/configure.in Thu Jan 31 02:55:25 2002
++++ Emulator_Src_3.4/BuildUnix/configure.in Mon Feb 18 10:48:21 2002
+@@ -34,6 +34,9 @@ AC_ARG_WITH(fltk,
+ [ --with-fltk=DIR use FLTK in DIR], [
+ CPPFLAGS="${CPPFLAGS} -I$withval/include"
+ LDFLAGS="${LDFLAGS} -L$withval/lib"
++ if test "${FLUID+set}" != set; then
++ test -r $withval/bin/fluid && FLUID=$withval/bin/fluid
++ fi
+ ])
+
+
+@@ -340,7 +343,8 @@ AC_SUBST(GLLIB)
+
+ dnl ========================================================
+ dnl Make sure FLTK is available. It must be installed on
+-dnl a standard path, or on $x_libraries.
++dnl a standard path, or on $x_libraries. Also check that
++dnl fluid is available (in PATH, or via --with-fltk).
+ dnl ========================================================
+
+ AC_CACHE_SAVE
+@@ -355,8 +359,11 @@ AC_CACHE_CHECK([for 'int fl_height (void
+ pose_cv_lib_fltk_found=yes, pose_cv_lib_fltk_found=no))
+
+ LIBS="$save_LIBS"
++
++dnl $FLUID may have already been set by --with-fltk, above
++AC_CHECK_PROG(FLUID, fluid, fluid, no)
+
+-if test $pose_cv_lib_fltk_found = yes; then
++if test $pose_cv_lib_fltk_found = yes && test $FLUID != no; then
+ AC_DEFINE(HAVE_LIBFLTK)
+ else
+ AC_MSG_ERROR(*** FLTK *must* be installed before running configure. ***)
diff --git a/app-emulation/pose/files/digest-pose-3.5-r1 b/app-emulation/pose/files/digest-pose-3.5-r1
new file mode 100644
index 000000000000..662101a539e1
--- /dev/null
+++ b/app-emulation/pose/files/digest-pose-3.5-r1
@@ -0,0 +1,2 @@
+MD5 c69b10798e524b999739bf1950125655 emulator_src_3.5.tar.gz 3162363
+MD5 e917767d012bcd8953a5d811e68134ff fltk-1.0.11-source.tar.bz2 999099
diff --git a/app-emulation/pose/files/init-clipwidget.diff b/app-emulation/pose/files/init-clipwidget.diff
new file mode 100644
index 000000000000..ef99aeafd7f6
--- /dev/null
+++ b/app-emulation/pose/files/init-clipwidget.diff
@@ -0,0 +1,18 @@
+--- SrcUnix/EmApplicationFltk.cpp.orig Tue Apr 16 12:51:13 2002
++++ SrcUnix/EmApplicationFltk.cpp Tue Apr 16 12:51:28 2002
+@@ -115,6 +115,7 @@
+
+ EmApplicationFltk::EmApplicationFltk (void) :
+ EmApplication (),
++ fClipboardWidget (NULL),
+ fAppWindow (NULL)
+ {
+ EmAssert (gHostApplication == NULL);
+@@ -138,6 +139,7 @@
+ EmApplicationFltk::~EmApplicationFltk (void)
+ {
+ delete fAppWindow;
++ delete fClipboardWidget;
+
+ EmAssert (gHostApplication == this);
+ gHostApplication = NULL;
diff --git a/app-emulation/pose/files/separate-builddir.diff b/app-emulation/pose/files/separate-builddir.diff
new file mode 100644
index 000000000000..aa8292b2da12
--- /dev/null
+++ b/app-emulation/pose/files/separate-builddir.diff
@@ -0,0 +1,62 @@
+diff -urNp orig-Emulator_Src_3.4/BuildUnix/Gzip/Makefile.am Emulator_Src_3.4/BuildUnix/Gzip/Makefile.am
+--- orig-Emulator_Src_3.4/BuildUnix/Gzip/Makefile.am Thu Jan 31 02:55:25 2002
++++ Emulator_Src_3.4/BuildUnix/Gzip/Makefile.am Mon Feb 18 10:55:27 2002
+@@ -8,7 +8,7 @@
+ ##
+ SUFFIXES = .cpp
+
+-VPATH = $(srcdir)/../../SrcShared/Gzip:
++VPATH = $(srcdir):$(srcdir)/../../SrcShared/Gzip:
+
+ ## no subdir specific flags needed -- just go with globals
+ LOCAL_CFLAGS =
+diff -urNp orig-Emulator_Src_3.4/BuildUnix/Makefile.am Emulator_Src_3.4/BuildUnix/Makefile.am
+--- orig-Emulator_Src_3.4/BuildUnix/Makefile.am Thu Jan 31 02:55:31 2002
++++ Emulator_Src_3.4/BuildUnix/Makefile.am Mon Feb 18 10:55:27 2002
+@@ -8,7 +8,8 @@ SUBDIRS = Gzip jpeg espws-2.0
+
+ SUFFIXES = .cpp
+
+-VPATH = $(srcdir)/../SrcUnix: \
++VPATH = $(srcdir): \
++ $(srcdir)/../SrcUnix: \
+ $(srcdir)/../SrcShared: \
+ $(srcdir)/../SrcShared/Hardware: \
+ $(srcdir)/../SrcShared/Hardware/TRG: \
+@@ -402,9 +403,9 @@ endif
+
+ bin_PROGRAMS = pose
+
+-pose_LDADD = $(srcdir)/Gzip/libposergzip.a
+-pose_LDADD += $(srcdir)/jpeg/libposerjpeg.a
+-pose_LDADD += $(srcdir)/espws-2.0/libposerespws.a
++pose_LDADD = Gzip/libposergzip.a
++pose_LDADD += jpeg/libposerjpeg.a
++pose_LDADD += espws-2.0/libposerespws.a
+ pose_LDADD += -lfltk
+ pose_LDADD += -L/usr/local/lib $(X_LIBS) -lXext -lX11 $(THREAD_LIBS) $(GLLIB) -lm
+
+diff -urNp orig-Emulator_Src_3.4/BuildUnix/espws-2.0/Makefile.am Emulator_Src_3.4/BuildUnix/espws-2.0/Makefile.am
+--- orig-Emulator_Src_3.4/BuildUnix/espws-2.0/Makefile.am Thu Jan 31 02:55:25 2002
++++ Emulator_Src_3.4/BuildUnix/espws-2.0/Makefile.am Mon Feb 18 10:55:27 2002
+@@ -9,7 +9,7 @@
+ ##
+ SUFFIXES = .cxx
+
+-VPATH = $(srcdir)/../../SrcUnix/espws-2.0:
++VPATH = $(srcdir):$(srcdir)/../../SrcUnix/espws-2.0:
+
+ CFLAGS = $(POSER_CFLAGS) $(LOCAL_CFLAGS) $(X_CFLAGS)
+ CXXFLAGS = $(POSER_CXXFLAGS) $(LOCAL_CFLAGS) $(X_CFLAGS)
+diff -urNp orig-Emulator_Src_3.4/BuildUnix/jpeg/Makefile.am Emulator_Src_3.4/BuildUnix/jpeg/Makefile.am
+--- orig-Emulator_Src_3.4/BuildUnix/jpeg/Makefile.am Thu Jan 31 02:55:25 2002
++++ Emulator_Src_3.4/BuildUnix/jpeg/Makefile.am Mon Feb 18 10:55:27 2002
+@@ -9,7 +9,7 @@
+ ##
+ SUFFIXES = .cpp
+
+-VPATH = $(srcdir)/../../SrcShared/jpeg:
++VPATH = $(srcdir):$(srcdir)/../../SrcShared/jpeg:
+
+ ## no subdir specific flags needed -- just go with globals
+ LOCAL_CFLAGS =
diff --git a/app-emulation/pose/pose-3.5-r1.ebuild b/app-emulation/pose/pose-3.5-r1.ebuild
new file mode 100644
index 000000000000..393fe13ffeab
--- /dev/null
+++ b/app-emulation/pose/pose-3.5-r1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/pose/pose-3.5-r1.ebuild,v 1.1 2002/08/29 01:55:42 george Exp $
+
+S=${WORKDIR}/Emulator_Src_3.5
+FLTK_PV=1.0.11
+FLTK_S=${WORKDIR}/fltk-${FLTK_PV}
+HOMEPAGE="http://www.palmos.com/dev/tools/emulator/"
+SRC_URI="http://www.palmos.com/dev/tools/emulator/sources/emulator_src_3.5.tar.gz
+ ftp://www.easysw.com/pub/fltk/${FLTK_PV}/fltk-${FLTK_PV}-source.tar.bz2"
+
+DESCRIPTION="Palm OS Emulator"
+
+DEPEND="virtual/glibc"
+RDEPEND="${DEPEND}"
+
+KEYWORDS="x86"
+LICENSE="GPL-2"
+SLOT="0"
+
+src_unpack() {
+ unpack emulator_src_3.5.tar.gz
+ unpack fltk-${FLTK_PV}-source.tar.bz2
+
+ cd ${S}
+ patch -p1 < ${FILESDIR}/detect-fluid.diff || die "Patching failed"
+ patch -p1 < ${FILESDIR}/separate-builddir.diff || die "Patching failed"
+ patch -p1 < ${FILESDIR}/choose-gl.diff || die "Patching failed"
+ patch -p0 < ${FILESDIR}/init-clipwidget.diff || die "Patching failed"
+ cd ${S}/BuildUnix
+ aclocal
+ automake --foreign
+ autoconf
+
+ cd ${S}
+ mkdir install-fltk
+ mkdir static-libs
+ mkdir build-normal
+ mkdir build-profile
+
+ cd ${S}/static-libs
+ ln -sf `g++ -print-file-name=libstdc++.a` libstdc++.a
+}
+
+src_compile() {
+ cd ${FLTK_S}
+ ./configure --prefix=${S}/install-fltk --disable-gl --disable-shared || die
+ make || die
+ make install || die
+
+ cd ${S}/build-normal
+ LDFLAGS=-L${S}/static-libs ../BuildUnix/configure --prefix=/usr \
+ --with-fltk=${S}/install-fltk \
+ --disable-gl || die
+
+ make || die
+
+ cd ${S}/build-profile
+ LDFLAGS=-L${S}/static-libs ../BuildUnix/configure --prefix=/usr \
+ --with-fltk=${S}/install-fltk \
+ --disable-gl --enable-palm-profile || die
+
+ make || die
+}
+
+src_install() {
+ cd ${S}/build-normal
+ dobin pose
+
+ cd ${S}/build-profile
+ newbin pose pose-profile
+
+ cd ${S}/Docs
+ dodoc *.txt *.rtf
+ dohtml *.html
+ insinto /usr/share/doc/${PF}
+ doins *.pdf
+
+ mkdir -p ${D}/usr/share/pose/downloads
+ mkdir -p ${D}/usr/share/pose/roms
+
+ cd ${S}/ROMTransfer/Source
+ insinto /usr/share/pose/downloads
+ doins *.prc
+}
+