summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-02-20 22:07:23 +0000
committerMike Frysinger <vapier@gentoo.org>2005-02-20 22:07:23 +0000
commit619c20201eb7d3b031b2a12a8989539f5658d79b (patch)
tree9d70aa2d7fb372022bfc115666c260dd8fb0d9ce /app-emulation
parentEnable compressed folder support via --enable-compressed (diff)
downloadhistorical-619c20201eb7d3b031b2a12a8989539f5658d79b.tar.gz
historical-619c20201eb7d3b031b2a12a8989539f5658d79b.tar.bz2
historical-619c20201eb7d3b031b2a12a8989539f5658d79b.zip
make sure perl is built with USE=ithreads #82706
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/crossover-office-bin/Manifest4
-rw-r--r--app-emulation/crossover-office-bin/crossover-office-bin-4.1.ebuild7
2 files changed, 8 insertions, 3 deletions
diff --git a/app-emulation/crossover-office-bin/Manifest b/app-emulation/crossover-office-bin/Manifest
index 85178dd08ded..dfe64f710a47 100644
--- a/app-emulation/crossover-office-bin/Manifest
+++ b/app-emulation/crossover-office-bin/Manifest
@@ -2,7 +2,7 @@ MD5 5df0258c789a4066c4f2b3bc4a86622b ChangeLog 709
MD5 997ddc2652e6cae5855d072a50433223 crossover-office-bin-3.0.1.ebuild 891
MD5 6e817c3f6b82338028366853fddccf5f metadata.xml 157
MD5 7e7b0a67dc41fbabc83be8032856bb42 crossover-office-bin-4.0.ebuild 889
-MD5 1aa66fdb29ae845e381caec3c6a1af2e crossover-office-bin-4.1.ebuild 889
-MD5 cd3ffa8407ac094aa56c0d80edb96e61 files/digest-crossover-office-bin-3.0.1 82
+MD5 b01a1f1d8f038587881e7babc90d697a crossover-office-bin-4.1.ebuild 1002
MD5 7ecc5ba7b6c1138905b6f352ec7e6e9d files/digest-crossover-office-bin-4.0 80
+MD5 cd3ffa8407ac094aa56c0d80edb96e61 files/digest-crossover-office-bin-3.0.1 82
MD5 f381c74d9cb69f7e54447e0ebe1680b9 files/digest-crossover-office-bin-4.1 80
diff --git a/app-emulation/crossover-office-bin/crossover-office-bin-4.1.ebuild b/app-emulation/crossover-office-bin/crossover-office-bin-4.1.ebuild
index d9f3c7e04d23..874713e68e06 100644
--- a/app-emulation/crossover-office-bin/crossover-office-bin-4.1.ebuild
+++ b/app-emulation/crossover-office-bin/crossover-office-bin-4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/crossover-office-bin/crossover-office-bin-4.1.ebuild,v 1.2 2005/01/01 14:09:10 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/crossover-office-bin/crossover-office-bin-4.1.ebuild,v 1.3 2005/02/20 22:07:23 vapier Exp $
inherit eutils
@@ -24,6 +24,11 @@ pkg_nofetch() {
einfo "and place ${A} in ${DISTDIR}"
}
+pkg_setup() {
+ ! built_with_use dev-lang/perl ithreads \
+ && die "you need to have perl built with USE=ithreads"
+}
+
src_unpack() {
unpack_makeself
}