summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Marineau <marineam@gentoo.org>2007-06-25 22:27:57 +0000
committerMichael Marineau <marineam@gentoo.org>2007-06-25 22:27:57 +0000
commit2e77826d4a2be96cf356fff9840299fd8e3485ae (patch)
tree84ff76aff31d68e678f3b8c221199c24c83b64dc /app-emulation
parentFix -fno-pie in xen-tools (diff)
downloadhistorical-2e77826d4a2be96cf356fff9840299fd8e3485ae.tar.gz
historical-2e77826d4a2be96cf356fff9840299fd8e3485ae.tar.bz2
historical-2e77826d4a2be96cf356fff9840299fd8e3485ae.zip
Fix -fno-pie in xen
Package-Manager: portage-2.1.2.2
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/xen/ChangeLog5
-rw-r--r--app-emulation/xen/xen-3.0.4_p1.ebuild4
2 files changed, 6 insertions, 3 deletions
diff --git a/app-emulation/xen/ChangeLog b/app-emulation/xen/ChangeLog
index 1ebb8eac90c4..adf1aff37ee2 100644
--- a/app-emulation/xen/ChangeLog
+++ b/app-emulation/xen/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-emulation/xen
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/ChangeLog,v 1.44 2007/05/02 04:27:24 marineam Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/ChangeLog,v 1.45 2007/06/25 22:27:57 marineam Exp $
+
+ 25 Jun 2007; Michael Marineau <marineam@gentoo.org> xen-3.0.4_p1.ebuild:
+ Fix typo in -fno-pie flag.
*xen-3.0.4_p1 (02 May 2007)
diff --git a/app-emulation/xen/xen-3.0.4_p1.ebuild b/app-emulation/xen/xen-3.0.4_p1.ebuild
index 93aab2dcd1bf..faaa18c70be3 100644
--- a/app-emulation/xen/xen-3.0.4_p1.ebuild
+++ b/app-emulation/xen/xen-3.0.4_p1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/xen-3.0.4_p1.ebuild,v 1.1 2007/05/02 04:27:24 marineam Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/xen-3.0.4_p1.ebuild,v 1.2 2007/06/25 22:27:57 marineam Exp $
inherit mount-boot flag-o-matic
@@ -54,7 +54,7 @@ src_unpack() {
# xen tries to be smart and filter out CFLAGs not supported by gcc.
# It doesn't handle no* flags though, but flag-o-matic's test-flag-CC does.
- for FLAG in -nopie -fno-stack-protector -fno-stack-protector-all; do
+ for FLAG in -fno-pie -fno-stack-protector -fno-stack-protector-all; do
test-flag-CC ${FLAG} && HARDFLAGS="${HARDFLAGS} ${FLAG}"
done
sed -i "s/^CFLAGS-y.*__XEN__.*$/& ${HARDFLAGS}/" \