summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-10-13 19:21:06 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-10-13 19:21:06 +0000
commit2495f58e8905cd30aab1cdba846ce824ac362897 (patch)
tree0b7d28e043f348435dc606356e18b04c05807aea /app-emulation/xen/xen-4.1.1-r2.ebuild
parentRemove broken version. Add missing global variable overlay_list (diff)
downloadhistorical-2495f58e8905cd30aab1cdba846ce824ac362897.tar.gz
historical-2495f58e8905cd30aab1cdba846ce824ac362897.tar.bz2
historical-2495f58e8905cd30aab1cdba846ce824ac362897.zip
[app-emulation/xen] Drop old. Alternate fix to -Werror, fixes bug 362303, patch by Markus Peloquin
Package-Manager: portage-2.2.0_alpha67/cvs/Linux x86_64
Diffstat (limited to 'app-emulation/xen/xen-4.1.1-r2.ebuild')
-rw-r--r--app-emulation/xen/xen-4.1.1-r2.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/app-emulation/xen/xen-4.1.1-r2.ebuild b/app-emulation/xen/xen-4.1.1-r2.ebuild
index b593d4d01415..d5d5ab1b7333 100644
--- a/app-emulation/xen/xen-4.1.1-r2.ebuild
+++ b/app-emulation/xen/xen-4.1.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/xen-4.1.1-r2.ebuild,v 1.2 2011/09/25 01:45:03 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/xen-4.1.1-r2.ebuild,v 1.3 2011/10/13 19:21:06 alexxy Exp $
EAPI="4"
@@ -73,6 +73,13 @@ src_prepare() {
-e 's/CFLAGS\(.*\)=\(.*\)-O2\(.*\)/CFLAGS\1=\2\3/' \
-i {} \;
fi
+
+ # remove -Werror for gcc-4.6's sake
+ find ${S} -name 'Makefile*' -o -name '*.mk' -o -name 'common.make' | \
+ xargs sed -i 's/ *-Werror */ /'
+ # not strictly necessary to fix this
+ sed -i 's/, "-Werror"//' ${S}/tools/python/setup.py
+
# Add sccurity fix bug #379241
epatch "${FILESDIR}/${P}-iommu_sec_fix.patch"
}