summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-08-03 18:43:25 +0000
committerMike Frysinger <vapier@gentoo.org>2010-08-03 18:43:25 +0000
commit83a276ae7d379ca7d7f6e5d8903cc6da7dae4f62 (patch)
treee24d91e7f57761ee49ef7e1f7f3e2d97d2aa40f5 /app-emulation/wine/wine-9999.ebuild
parentold (diff)
downloadhistorical-83a276ae7d379ca7d7f6e5d8903cc6da7dae4f62.tar.gz
historical-83a276ae7d379ca7d7f6e5d8903cc6da7dae4f62.tar.bz2
historical-83a276ae7d379ca7d7f6e5d8903cc6da7dae4f62.zip
Add USE=pulseaudio to live versions and tweak multilib deps for USE="win32 win64" #331001 by Sven.
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'app-emulation/wine/wine-9999.ebuild')
-rw-r--r--app-emulation/wine/wine-9999.ebuild42
1 files changed, 27 insertions, 15 deletions
diff --git a/app-emulation/wine/wine-9999.ebuild b/app-emulation/wine/wine-9999.ebuild
index 5c56cc98035a..185d987f618e 100644
--- a/app-emulation/wine/wine-9999.ebuild
+++ b/app-emulation/wine/wine-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-9999.ebuild,v 1.56 2010/07/24 04:42:23 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-9999.ebuild,v 1.57 2010/08/03 18:43:25 vapier Exp $
EAPI="2"
@@ -8,27 +8,42 @@ inherit eutils flag-o-matic multilib
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://source.winehq.org/git/wine.git"
- inherit git
+ inherit git autotools
SRC_URI=""
#KEYWORDS=""
else
+ AUTOTOOLS_AUTO_DEPEND="no"
+ inherit autotools
MY_P="${PN}-${PV/_/-}"
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
KEYWORDS="-* ~amd64 ~x86 ~x86-fbsd"
S=${WORKDIR}/${MY_P}
fi
+pulse_patches() { echo "$1"/winepulse-{0.36,0.35-configure.ac,0.38-winecfg}.patch ; }
GV="1.0.0-x86"
DESCRIPTION="free implementation of Windows(tm) on Unix"
HOMEPAGE="http://www.winehq.org/"
SRC_URI="${SRC_URI}
- gecko? ( mirror://sourceforge/wine/wine_gecko-${GV}.cab )"
+ gecko? ( mirror://sourceforge/wine/wine_gecko-${GV}.cab )
+ pulseaudio? ( `pulse_patches http://art.ified.ca/downloads/winepulse` )"
LICENSE="LGPL-2.1"
SLOT="0"
-IUSE="alsa capi cups custom-cflags dbus esd fontconfig +gecko gnutls gphoto2 gsm hal jack jpeg lcms ldap mp3 nas ncurses openal +opengl +oss +perl png samba scanner ssl test +threads +truetype +win32 +win64 +X xcomposite xinerama xml"
+IUSE="alsa capi cups custom-cflags dbus esd fontconfig +gecko gnutls gphoto2 gsm hal jack jpeg lcms ldap mp3 nas ncurses openal +opengl +oss +perl png pulseaudio samba scanner ssl test +threads +truetype +win32 +win64 +X xcomposite xinerama xml"
RESTRICT="test" #72375
+MLIB_DEPS="amd64? (
+ truetype? ( >=app-emulation/emul-linux-x86-xlibs-2.1 )
+ X? (
+ >=app-emulation/emul-linux-x86-xlibs-2.1
+ >=app-emulation/emul-linux-x86-soundlibs-2.1
+ )
+ openal? ( app-emulation/emul-linux-x86-sdl )
+ opengl? ( app-emulation/emul-linux-x86-opengl )
+ app-emulation/emul-linux-x86-baselibs
+ >=sys-kernel/linux-headers-2.6
+ )"
RDEPEND="truetype? ( >=media-libs/freetype-2.0.0 media-fonts/corefonts )
perl? ( dev-lang/perl dev-perl/XML-Simple )
capi? ( net-dialup/capi4k-utils )
@@ -54,6 +69,7 @@ RDEPEND="truetype? ( >=media-libs/freetype-2.0.0 media-fonts/corefonts )
nas? ( media-libs/nas )
cups? ( net-print/cups )
opengl? ( virtual/opengl )
+ pulseaudio? ( media-sound/pulseaudio ${AUTOTOOLS_DEPEND} )
gsm? ( media-sound/gsm )
jpeg? ( media-libs/jpeg )
ldap? ( net-nds/openldap )
@@ -64,17 +80,8 @@ RDEPEND="truetype? ( >=media-libs/freetype-2.0.0 media-fonts/corefonts )
scanner? ( media-gfx/sane-backends )
ssl? ( dev-libs/openssl )
png? ( media-libs/libpng )
- !win64? ( amd64? (
- truetype? ( >=app-emulation/emul-linux-x86-xlibs-2.1 )
- X? (
- >=app-emulation/emul-linux-x86-xlibs-2.1
- >=app-emulation/emul-linux-x86-soundlibs-2.1
- )
- openal? ( app-emulation/emul-linux-x86-sdl )
- opengl? ( app-emulation/emul-linux-x86-opengl )
- app-emulation/emul-linux-x86-baselibs
- >=sys-kernel/linux-headers-2.6
- ) )
+ !win64? ( ${MLIB_DEPS} )
+ win32? ( ${MLIB_DEPS} )
xcomposite? ( x11-libs/libXcomposite ) "
DEPEND="${RDEPEND}
X? (
@@ -99,6 +106,10 @@ src_unpack() {
}
src_prepare() {
+ if use pulseaudio ; then
+ EPATCH_OPTS=-p1 epatch `pulse_patches "${DISTDIR}"`
+ eautoreconf
+ fi
epatch "${FILESDIR}"/${PN}-1.1.15-winegcc.patch #260726
epatch_user #282735
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in || die
@@ -135,6 +146,7 @@ do_configure() {
$(use_with oss) \
$(use_with png) \
$(use_with threads pthread) \
+ $(use pulseaudio && use_with pulseaudio pulse) \
$(use_with scanner sane) \
$(use_enable test tests) \
$(use_with truetype freetype) \