summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-06-24 23:23:11 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-06-24 23:23:11 +0000
commit2f3fc46b77958a02dfe4d791b4825aeb9b172116 (patch)
tree8f7c4228cc6beb34abdafbe8d89eb45d782b4f2e /app-emulation/wine/wine-9999.ebuild
parentEnable wine[udisks] for desktop users. (diff)
downloadhistorical-2f3fc46b77958a02dfe4d791b4825aeb9b172116.tar.gz
historical-2f3fc46b77958a02dfe4d791b4825aeb9b172116.tar.bz2
historical-2f3fc46b77958a02dfe4d791b4825aeb9b172116.zip
Bump, see http://www.winehq.org/announce/1.5.7 and http://www.winehq.org/announce/1.4.1 for the announcements. Enable optional native pulseaudio support for 1.5.7 (bug #421365, thanks to Lee Trager). Fix emul-linux-x86-soundlibs dependency (bug #423093, thanks to Pacho Ramos).
Package-Manager: portage-2.2.0_alpha112/cvs/Linux x86_64
Diffstat (limited to 'app-emulation/wine/wine-9999.ebuild')
-rw-r--r--app-emulation/wine/wine-9999.ebuild17
1 files changed, 11 insertions, 6 deletions
diff --git a/app-emulation/wine/wine-9999.ebuild b/app-emulation/wine/wine-9999.ebuild
index 98d5f1277e83..ac107810c2c0 100644
--- a/app-emulation/wine/wine-9999.ebuild
+++ b/app-emulation/wine/wine-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-9999.ebuild,v 1.109 2012/06/10 03:24:21 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-9999.ebuild,v 1.110 2012/06/24 23:23:11 tetromino Exp $
EAPI="4"
@@ -18,8 +18,9 @@ else
S=${WORKDIR}/${MY_P}
fi
-GV="1.5"
+GV="1.6"
MV="0.0.4"
+PULSE_PATCH="winepulse-2012.06.15.patch"
DESCRIPTION="free implementation of Windows(tm) on Unix"
HOMEPAGE="http://www.winehq.org/"
SRC_URI="${SRC_URI}
@@ -27,11 +28,12 @@ SRC_URI="${SRC_URI}
mirror://sourceforge/${PN}/Wine%20Gecko/${GV}/wine_gecko-${GV}-x86.msi
win64? ( mirror://sourceforge/${PN}/Wine%20Gecko/${GV}/wine_gecko-${GV}-x86_64.msi )
)
- mono? ( mirror://sourceforge/${PN}/Wine%20Mono/${MV}/wine-mono-${MV}.msi )"
+ mono? ( mirror://sourceforge/${PN}/Wine%20Mono/${MV}/wine-mono-${MV}.msi )
+ http://source.winehq.org/patches/data/87234 -> ${PULSE_PATCH}"
LICENSE="LGPL-2.1"
SLOT="0"
-IUSE="alsa capi cups custom-cflags elibc_glibc fontconfig +gecko gnutls gphoto2 gsm gstreamer hardened jpeg lcms ldap +mono mp3 ncurses nls odbc openal opencl +opengl +oss +perl png samba scanner selinux ssl test +threads +truetype udisks v4l +win32 +win64 +X xcomposite xinerama xml"
+IUSE="alsa capi cups custom-cflags elibc_glibc fontconfig +gecko gnutls gphoto2 gsm gstreamer hardened jpeg lcms ldap +mono mp3 ncurses nls odbc openal opencl +opengl +oss +perl png pulseaudio samba scanner selinux ssl test +threads +truetype udisks v4l +win32 +win64 +X xcomposite xinerama xml"
REQUIRED_USE="elibc_glibc? ( threads )
mono? ( || ( win32 !win64 ) )" #286560
RESTRICT="test" #72375
@@ -40,7 +42,7 @@ MLIB_DEPS="amd64? (
truetype? ( >=app-emulation/emul-linux-x86-xlibs-2.1 )
X? (
>=app-emulation/emul-linux-x86-xlibs-2.1
- >=app-emulation/emul-linux-x86-soundlibs-2.1
+ >=app-emulation/emul-linux-x86-soundlibs-2.1[pulseaudio(+)?]
)
mp3? ( app-emulation/emul-linux-x86-soundlibs )
odbc? ( app-emulation/emul-linux-x86-db )
@@ -60,7 +62,7 @@ RDEPEND="truetype? ( >=media-libs/freetype-2.0.0 media-fonts/corefonts )
openal? ( media-libs/openal )
udisks? (
sys-apps/dbus
- sys-fs/udisks:0
+ sys-fs/udisks:2
)
gnutls? ( net-libs/gnutls )
gstreamer? ( media-libs/gstreamer media-libs/gst-plugins-base )
@@ -84,6 +86,7 @@ RDEPEND="truetype? ( >=media-libs/freetype-2.0.0 media-fonts/corefonts )
mp3? ( >=media-sound/mpg123-1.5.0 )
nls? ( sys-devel/gettext )
odbc? ( dev-db/unixODBC )
+ pulseaudio? ( media-sound/pulseaudio )
samba? ( >=net-fs/samba-3.0.25 )
selinux? ( sec-policy/selinux-wine )
xml? ( dev-libs/libxml2 dev-libs/libxslt )
@@ -127,6 +130,7 @@ src_unpack() {
src_prepare() {
epatch "${FILESDIR}"/${PN}-1.1.15-winegcc.patch #260726
epatch "${FILESDIR}"/${PN}-1.4_rc2-multilib-portage.patch #395615
+ epatch "${DISTDIR}/${PULSE_PATCH}" #421365
epatch_user #282735
eautoreconf
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in || die
@@ -164,6 +168,7 @@ do_configure() {
$(use_with oss) \
$(use_with png) \
$(use_with threads pthread) \
+ $(use_with pulseaudio pulse) \
$(use_with scanner sane) \
$(use_enable test tests) \
$(use_with truetype freetype) \