summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-10-19 01:41:50 +0000
committerMike Frysinger <vapier@gentoo.org>2009-10-19 01:41:50 +0000
commit0092234ed62aa3a9ed10af887acd2333b882f611 (patch)
treec8072b9d45ac6ca8f5b5e92272518aa453cf4f5b /app-emulation/wine/wine-9999.ebuild
parentstable x86, bug 288836 (diff)
downloadhistorical-0092234ed62aa3a9ed10af887acd2333b882f611.tar.gz
historical-0092234ed62aa3a9ed10af887acd2333b882f611.tar.bz2
historical-0092234ed62aa3a9ed10af887acd2333b882f611.zip
Version bump #289121 by ScytheMan and add IUSE=perl by Andrew Church #267642.
Package-Manager: portage-2.2_rc46/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'app-emulation/wine/wine-9999.ebuild')
-rw-r--r--app-emulation/wine/wine-9999.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/app-emulation/wine/wine-9999.ebuild b/app-emulation/wine/wine-9999.ebuild
index e4d32817d092..f7034c168702 100644
--- a/app-emulation/wine/wine-9999.ebuild
+++ b/app-emulation/wine/wine-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-9999.ebuild,v 1.44 2009/09/27 06:58:14 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-9999.ebuild,v 1.45 2009/10/19 01:41:50 vapier Exp $
EAPI="2"
@@ -26,13 +26,12 @@ SRC_URI="${SRC_URI}
LICENSE="LGPL-2.1"
SLOT="0"
-IUSE="alsa capi cups dbus esd fontconfig +gecko gnutls gphoto2 gsm hal jack jpeg lcms ldap mp3 nas ncurses openal +opengl oss png samba scanner ssl test +threads win64 +X xcomposite xinerama xml"
+IUSE="alsa capi cups dbus esd fontconfig +gecko gnutls gphoto2 gsm hal jack jpeg lcms ldap mp3 nas ncurses openal +opengl oss +perl png samba scanner ssl test +threads win64 +X xcomposite xinerama xml"
RESTRICT="test" #72375
RDEPEND=">=media-libs/freetype-2.0.0
media-fonts/corefonts
- dev-lang/perl
- dev-perl/XML-Simple
+ perl? ( dev-lang/perl dev-perl/XML-Simple )
capi? ( net-dialup/capi4k-utils )
ncurses? ( >=sys-libs/ncurses-5.2 )
fontconfig? ( media-libs/fontconfig )
@@ -151,4 +150,7 @@ src_install() {
insinto /usr/share/wine/gecko
doins "${DISTDIR}"/wine_gecko-${GV}.cab || die
fi
+ if ! use perl ; then
+ rm "${D}"/usr/bin/{wine{dump,maker},function_grep.pl} "${D}"/usr/share/man/man1/wine{dump,maker}.1 || die
+ fi
}