summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2011-02-19 08:37:58 +0000
committerLars Wendler <polynomial-c@gentoo.org>2011-02-19 08:37:58 +0000
commit043cc6aa613bc5b39c8c78ee33cf409c1a733326 (patch)
treedd4c3acf5d3636778a5fb6b459e178aa78b85eac /app-emulation/virtualbox
parentVersion bump. Removed old. (diff)
downloadhistorical-043cc6aa613bc5b39c8c78ee33cf409c1a733326.tar.gz
historical-043cc6aa613bc5b39c8c78ee33cf409c1a733326.tar.bz2
historical-043cc6aa613bc5b39c8c78ee33cf409c1a733326.zip
Version bump. Removed old.
Package-Manager: portage-2.2.0_alpha24/cvs/Linux x86_64
Diffstat (limited to 'app-emulation/virtualbox')
-rw-r--r--app-emulation/virtualbox/ChangeLog11
-rw-r--r--app-emulation/virtualbox/files/virtualbox-4-vnc.patch101
-rw-r--r--app-emulation/virtualbox/files/virtualbox-4.0.0-restore_old_machines_dir.patch12
-rw-r--r--app-emulation/virtualbox/virtualbox-4.0.4.ebuild (renamed from app-emulation/virtualbox/virtualbox-4.0.0-r1.ebuild)18
4 files changed, 124 insertions, 18 deletions
diff --git a/app-emulation/virtualbox/ChangeLog b/app-emulation/virtualbox/ChangeLog
index 1a7b3d7adf95..260841b1d7f8 100644
--- a/app-emulation/virtualbox/ChangeLog
+++ b/app-emulation/virtualbox/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-emulation/virtualbox
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtualbox/ChangeLog,v 1.60 2011/02/03 07:50:14 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtualbox/ChangeLog,v 1.61 2011/02/19 08:35:21 polynomial-c Exp $
+
+*virtualbox-4.0.4 (18 Feb 2011)
+
+ 18 Feb 2011; Lars Wendler <polynomial-c@gentoo.org>
+ -virtualbox-4.0.0-r1.ebuild,
+ -files/virtualbox-4.0.0-restore_old_machines_dir.patch,
+ +virtualbox-4.0.4.ebuild, +files/virtualbox-4-vnc.patch:
+ Version bump. Removed old. Readded vnc USE flag as requested by Branko Majic
+ in bug #355481.
03 Feb 2011; Thomas Kahle <tomka@gentoo.org> virtualbox-3.2.12-r4.ebuild:
x86 stable per bug 336465
diff --git a/app-emulation/virtualbox/files/virtualbox-4-vnc.patch b/app-emulation/virtualbox/files/virtualbox-4-vnc.patch
new file mode 100644
index 000000000000..76e2c68524b7
--- /dev/null
+++ b/app-emulation/virtualbox/files/virtualbox-4-vnc.patch
@@ -0,0 +1,101 @@
+--- configure.old 2011-02-18 20:22:18.879463002 +0100
++++ configure 2011-02-18 20:30:22.355463011 +0100
+@@ -88,6 +88,7 @@
+ WITH_OPENGL=1
+ WITH_HARDENING=1
+ WITH_VDE=0
++WITH_VNC=0
+ WITH_DOCS=1
+ BUILD_LIBXML2=
+ BUILD_LIBXSLT=
+@@ -123,6 +124,8 @@
+ MESA="-lGL"
+ INCZ=""
+ LIBZ="-lz"
++INCVNCSERVER=""
++LIBVNCSERVER="-lvncserver"
+ CXX_FLAGS=""
+ if [ "$OS" = "freebsd" ]; then
+ INCCURL="-I/usr/local/include"
+@@ -956,6 +959,47 @@
+ }
+
+ #
++# Check for libvncserver, needed for VNC in OSE
++#
++check_vncserver()
++{
++ test_header libvncserver
++ cat > $ODIR.tmp_src.cc <<EOF
++#include <cstdio>
++#include <rfb/rfbconfig.h>
++
++extern "C" int main()
++{
++ const char* v=LIBVNCSERVER_VERSION;
++ unsigned int major = 0, minor = 0, micro = 0;
++
++ for (; *v !='.' && *v != '\0'; v++) major = major*10 + *v-'0';
++ if (*v == '.') v++;
++ for (; *v !='.' && *v != '\0'; v++) minor = minor*10 + *v-'0';
++ if (*v == '.') v++;
++ for (; *v !='.' && *v != '\0'; v++) micro = micro*10 + *v-'0';
++
++ printf("found version %s", LIBVNCSERVER_PACKAGE_VERSION);
++ if (major*10000 + minor*100 + micro >= 907)
++ {
++ printf(", OK.\n");
++ return 0;
++ }
++ else
++ {
++ printf(", expected version 0.9.7 or higher\n");
++ return 1;
++ }
++}
++EOF
++ if test_compile "$LIBVNCSERVER $INCVNCSERVER" libvncserver libvncserver; then
++ if test_execute; then
++ cnf_append "VBOX_WITH_VNC" "1"
++ fi
++ fi
++}
++
++#
+ # Check for libcurl, needed by S3
+ #
+ check_curl()
+@@ -2115,6 +2159,7 @@
+ [ $WITH_KMODS -eq 1 ] && echo " --disable-kmods don't build Linux kernel modules (host and guest)"
+ [ $WITH_OPENGL -eq 1 ] && echo " --disable-opengl disable OpenGL support (2D & 3D)"
+ [ $WITH_GSOAP -eq 0 ] && echo " --enable-webservice enable the webservice stuff"
++[ $OSE -eq 1 ] && echo " --enable-vnc enable the VNC server"
+ [ $WITH_DOCS -eq 1 ] && echo " --disable-docs don't build the documentation"
+ [ "$OS" = "linux" -o "$OS" = "freebsd" ] && echo " --enable-vde enable VDE networking"
+ cat << EOF
+@@ -2280,6 +2325,9 @@
+ --enable-webservice)
+ [ $WITH_GSOAP -eq 0 ] && WITH_GSOAP=1
+ ;;
++ --enable-vnc)
++ WITH_VNC=1
++ ;;
+ --disable-hardening)
+ WITH_HARDENING=0
+ ;;
+@@ -2553,6 +2601,15 @@
+ cnf_append "VBOX_WITH_DOCS_PACKING" ""
+ fi
+
++# VNC server support
++if [ $OSE -ge 1 ]; then
++ if [ $WITH_VNC = 1 ]; then
++ check_vncserver
++ else
++ cnf_append "VBOX_WITH_VNC" ""
++ fi
++fi
++
+ # success!
+ echo
+ echo "Successfully generated '$CNF' and '$ENV'."
diff --git a/app-emulation/virtualbox/files/virtualbox-4.0.0-restore_old_machines_dir.patch b/app-emulation/virtualbox/files/virtualbox-4.0.0-restore_old_machines_dir.patch
deleted file mode 100644
index a6770f455cf9..000000000000
--- a/app-emulation/virtualbox/files/virtualbox-4.0.0-restore_old_machines_dir.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- VirtualBox-4.0.0_OSE/src/VBox/Main/SystemPropertiesImpl.cpp
-+++ VirtualBox-4.0.0_OSE/src/VBox/Main/SystemPropertiesImpl.cpp
-@@ -1035,7 +1035,8 @@
- // new default with VirtualBox 4.0: "$HOME/VirtualBox VMs"
- HRESULT rc = getUserHomeDirectory(path);
- if (FAILED(rc)) return rc;
-- path += RTPATH_SLASH_STR "VirtualBox VMs";
-+ path += RTPATH_SLASH_STR ".VirtualBox";
-+ path += RTPATH_SLASH_STR "Machines";
- }
-
- if (!RTPathStartsWithRoot(path.c_str()))
diff --git a/app-emulation/virtualbox/virtualbox-4.0.0-r1.ebuild b/app-emulation/virtualbox/virtualbox-4.0.4.ebuild
index 16071e0fcdb8..cdedae57445c 100644
--- a/app-emulation/virtualbox/virtualbox-4.0.0-r1.ebuild
+++ b/app-emulation/virtualbox/virtualbox-4.0.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtualbox/virtualbox-4.0.0-r1.ebuild,v 1.6 2011/01/21 16:52:47 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtualbox/virtualbox-4.0.4.ebuild,v 1.1 2011/02/19 08:35:21 polynomial-c Exp $
EAPI=2
@@ -22,7 +22,7 @@ HOMEPAGE="http://www.virtualbox.org/"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="+additions alsa doc extensions headless java pulseaudio +opengl python +qt4 sdk vboxwebsrv"
+IUSE="+additions alsa doc extensions headless java pulseaudio +opengl python +qt4 sdk vboxwebsrv vnc"
RDEPEND="!app-emulation/virtualbox-bin
~app-emulation/virtualbox-modules-${PV}
@@ -46,7 +46,8 @@ RDEPEND="!app-emulation/virtualbox-bin
x11-libs/libXmu
x11-libs/libXt
media-libs/libsdl[X,video]
- )"
+ )
+ vnc? ( >=net-libs/libvncserver-0.9.7 )"
DEPEND="${RDEPEND}
>=dev-util/kbuild-0.1.5-r1
>=dev-lang/yasm-0.6.2
@@ -144,7 +145,10 @@ src_prepare() {
-i Config.kmk src/libs/xpcom18a4/Config.kmk || die
# We still want to use ${HOME}/.VirtualBox/Machines as machines dir.
- epatch "${FILESDIR}/${PN}-4.0.0-restore_old_machines_dir.patch"
+ epatch "${FILESDIR}/${PN}-4.0.2-restore_old_machines_dir.patch"
+
+ # add the --enable-vnc option to configure script (bug #348204)
+ epatch "${FILESDIR}/${PN}-4-vnc.patch"
# add correct java path
if use java ; then
@@ -161,6 +165,7 @@ src_configure() {
use python || myconf+=" --disable-python"
use java || myconf+=" --disable-java"
use vboxwebsrv && myconf+=" --enable-webservice"
+ use vnc && myconf+=" --enable-vnc"
use doc || myconf+=" --disable-docs"
if ! use headless ; then
use qt4 || myconf+=" --disable-qt4"
@@ -189,8 +194,8 @@ src_compile() {
TOOL_GCC3_AS="$(tc-getCC)" TOOL_GCC3_AR="$(tc-getAR)" \
TOOL_GCC3_LD="$(tc-getCXX)" TOOL_GCC3_LD_SYSMOD="$(tc-getLD)" \
TOOL_GCC3_CFLAGS="${CFLAGS}" TOOL_GCC3_CXXFLAGS="${CXXFLAGS}" \
- TOOL_YASM_AS=yasm KBUILD_PATH="${S}/kBuild" \
VBOX_GCC_OPT="${CXXFLAGS}" \
+ TOOL_YASM_AS=yasm KBUILD_PATH="${S}/kBuild" \
all || die "kmk failed"
}
@@ -291,6 +296,9 @@ src_install() {
doins -r nls
fi
+ # VRDPAuth only works with this (bug #351949)
+ dosym VBoxAuth.so /usr/$(get_libdir)/${PN}/VRDPAuth.so
+
# set an env-variable for 3rd party tools
echo -n "VBOX_APP_HOME=/usr/$(get_libdir)/${PN}" > "${T}/90virtualbox"
doenvd "${T}/90virtualbox"