summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarol Wojtaszek <sekretarz@gentoo.org>2004-09-01 10:57:28 +0000
committerKarol Wojtaszek <sekretarz@gentoo.org>2004-09-01 10:57:28 +0000
commita88b48171767e7e486a807a3d972b88439cb03f8 (patch)
tree561df6e4d25d9dc64a3b98a4bc7d680c441f50c9 /app-emulation/tiger
parentA new snapshot and remove some old ebuilds (diff)
downloadhistorical-a88b48171767e7e486a807a3d972b88439cb03f8.tar.gz
historical-a88b48171767e7e486a807a3d972b88439cb03f8.tar.bz2
historical-a88b48171767e7e486a807a3d972b88439cb03f8.zip
Fixed gcc-3.4 compile problems. Bug #57274
Diffstat (limited to 'app-emulation/tiger')
-rw-r--r--app-emulation/tiger/ChangeLog6
-rw-r--r--app-emulation/tiger/Manifest15
-rw-r--r--app-emulation/tiger/files/tiger-0.8-gcc34.patch154
-rw-r--r--app-emulation/tiger/tiger-0.8.ebuild10
4 files changed, 171 insertions, 14 deletions
diff --git a/app-emulation/tiger/ChangeLog b/app-emulation/tiger/ChangeLog
index 5a2252324166..6ef973a54f63 100644
--- a/app-emulation/tiger/ChangeLog
+++ b/app-emulation/tiger/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/tiger
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/tiger/ChangeLog,v 1.4 2004/06/24 22:34:51 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/tiger/ChangeLog,v 1.5 2004/09/01 10:57:28 sekretarz Exp $
+
+ 01 Sep 2004; Karol Wojtaszek <sekretarz@gentoo.org>
+ +files/tiger-0.8-gcc34.patch, tiger-0.8.ebuild:
+ Fixed gcc-3.4 compile problems. Bug #57274
07 Jun 2004; Daniel Black <dragonheart@gentoo.org> +metadata.xml,
tiger-0.8.ebuild:
diff --git a/app-emulation/tiger/Manifest b/app-emulation/tiger/Manifest
index ff2b0ad82ffa..d7df9d054f1b 100644
--- a/app-emulation/tiger/Manifest
+++ b/app-emulation/tiger/Manifest
@@ -1,14 +1,5 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 657e43d6bce80833c77f1915689f44a9 ChangeLog 565
-MD5 ae55a9fd74b17232f506ba9dabea2e52 tiger-0.8.ebuild 606
+MD5 d3e6c0ce94ba44ade6549e0b490d9fb4 tiger-0.8.ebuild 706
+MD5 4d052095c7f6052f822d41acbbcf4af5 ChangeLog 716
MD5 1652522405f5936eb29776ef8d5ffa5b metadata.xml 310
MD5 2562769aeaf65f8fe4470e2aaef79a9a files/digest-tiger-0.8 60
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.9.8 (GNU/Linux)
-
-iD8DBQFA31M1HTu7gpaalycRAtrjAJ9dJ5VOsUi4TX0vwu0vsS62ph4tlwCgoPYE
-HHBQtXy+sjOjWUpocIJSpLA=
-=dvWy
------END PGP SIGNATURE-----
+MD5 c29ab5cc6e1ca0b291613e36b8f57a19 files/tiger-0.8-gcc34.patch 4986
diff --git a/app-emulation/tiger/files/tiger-0.8-gcc34.patch b/app-emulation/tiger/files/tiger-0.8-gcc34.patch
new file mode 100644
index 000000000000..cabb53d5fe9a
--- /dev/null
+++ b/app-emulation/tiger/files/tiger-0.8-gcc34.patch
@@ -0,0 +1,154 @@
+diff -Naur tiger-0.8.orig/cmdinterface.c tiger-0.8/cmdinterface.c
+--- tiger-0.8.orig/cmdinterface.c 2001-02-01 01:23:51.000000000 +0100
++++ tiger-0.8/cmdinterface.c 2004-07-16 20:04:31.370101384 +0200
+@@ -19,6 +19,7 @@
+ #include "core.h"
+
+ #include "globinfo.h"
++#include "xspecific.h"
+
+ char *varNames[0x15] = {"EXPR", "", "", "", "LIST", "", "MAT", "", "", "", "DATA", "TEXT", "STRING", "GDB",
+ "FIG", "", "PIC", "", "PRGM", "FUNC", "MAC" };
+@@ -36,11 +37,11 @@
+
+ char currDir[128] = "";
+
+-int do_command(unsigned char *cmd, unsigned char *arg1);
+-
++/* Declaration of functions */
++void prompt_commands(void);
+
+ void cmd_update_progbar(int size) {
+- static cnt = 0;
++ static int cnt = 0;
+ if((cnt++)&1) {
+ printf(".");
+ fflush(stdout);
+diff -Naur tiger-0.8.orig/cmdinterface.h tiger-0.8/cmdinterface.h
+--- tiger-0.8.orig/cmdinterface.h 2001-02-01 01:23:51.000000000 +0100
++++ tiger-0.8/cmdinterface.h 2004-07-16 20:04:31.373100928 +0200
+@@ -1,4 +1,5 @@
+-
++void load_cfg_file(char *name);
++int do_command(unsigned char *cmd, unsigned char *arg1);
+ extern void cmd_update_progbar(int size);
+ extern void cmd_link_progress(int type, char *name, int size);
+ extern void enter_command(void);
+diff -Naur tiger-0.8.orig/core.h tiger-0.8/core.h
+--- tiger-0.8.orig/core.h 2001-02-01 01:23:51.000000000 +0100
++++ tiger-0.8/core.h 2004-07-16 20:12:18.013160856 +0200
+@@ -112,4 +112,4 @@
+ 0x44, 0x61, 0x6e, 0x20, 0x45, 0x62, 0x6c, 0x65, 0x2e, 0x20, 0x41, 0x6c,
+ 0x6c, 0x20, 0x72, 0x69, 0x67, 0x68, 0x74, 0x73, 0x20, 0x72, 0x65, 0x73,
+ 0x65, 0x72, 0x76, 0x65, 0x64, 0x2e, 0x4e, 0x71
+-};
+\ No newline at end of file
++};
+diff -Naur tiger-0.8.orig/gencpu.c tiger-0.8/gencpu.c
+--- tiger-0.8.orig/gencpu.c 2001-02-01 01:23:51.000000000 +0100
++++ tiger-0.8/gencpu.c 2004-07-16 20:04:31.381099712 +0200
+@@ -1682,7 +1682,7 @@
+ printf("#include \"memory.h\"\n");
+ /* printf("#include \"custom.h\"\n"); */
+ printf("#include \"newcpu.h\"\n");
+- printf("#include \"cputbl.h\"\n");
++/* printf("#include \"cputbl.h\"\n");*/
+ for(opcode=from; opcode < to; opcode++) {
+ if (table68k[opcode].mnemo == i_ILLG) {
+ illg++;
+diff -Naur tiger-0.8.orig/hardware.h tiger-0.8/hardware.h
+--- tiger-0.8.orig/hardware.h 2001-02-01 01:23:51.000000000 +0100
++++ tiger-0.8/hardware.h 2004-07-16 20:06:38.277808480 +0200
+@@ -1,3 +1,4 @@
++int link_checkread(void);
+
+ extern void update_contrast(void);
+ extern void update_timer(UBYTE arg);
+diff -Naur tiger-0.8.orig/include/newcpu.h tiger-0.8/include/newcpu.h
+--- tiger-0.8.orig/include/newcpu.h 2001-02-01 01:23:51.000000000 +0100
++++ tiger-0.8/include/newcpu.h 2004-07-16 20:04:31.389098496 +0200
+@@ -45,7 +45,7 @@
+ extern struct cputbl smallcputbl[];
+
+ extern cpuop_func *cpufunctbl[65536];
+-extern void op_illg(ULONG) REGPARAM;
++extern void op_illg(ULONG);
+
+ typedef char flagtype;
+
+diff -Naur tiger-0.8.orig/include/options.h tiger-0.8/include/options.h
+--- tiger-0.8.orig/include/options.h 2001-02-01 01:23:51.000000000 +0100
++++ tiger-0.8/include/options.h 2004-07-16 20:04:31.392098040 +0200
+@@ -1,3 +1,6 @@
++#include <stdio.h>
++#include <string.h>
++
+ /*
+ * UAE - The Un*x Amiga Emulator
+ *
+diff -Naur tiger-0.8.orig/main.c tiger-0.8/main.c
+--- tiger-0.8.orig/main.c 2001-02-01 01:23:51.000000000 +0100
++++ tiger-0.8/main.c 2004-07-16 20:04:31.395097584 +0200
+@@ -14,7 +14,8 @@
+ #include "hardware.h"
+ #include "specific.h"
+ #include "globinfo.h"
+-
++#include "cmdinterface.h"
++#include "keyboard.h"
+
+ struct GlobalInformation globInf;
+
+diff -Naur tiger-0.8.orig/readcpu.c tiger-0.8/readcpu.c
+--- tiger-0.8.orig/readcpu.c 2001-02-01 01:23:51.000000000 +0100
++++ tiger-0.8/readcpu.c 2004-07-16 20:10:00.749028176 +0200
+@@ -174,10 +174,10 @@
+ int srcgather = 0, dstgather = 0;
+ int usesrc = 0, usedst = 0;
+ int srctype = 0;
+- int srcpos, dstpos;
++ int srcpos = 0, dstpos = 0;
+
+ amodes srcmode = am_unknown, destmode = am_unknown;
+- int srcreg, destreg;
++ int srcreg = 0, destreg = 0;
+
+ for(i = 0; i < lastbit; i++)
+ bitcnt[i] = bitval[i] = 0;
+diff -Naur tiger-0.8.orig/xspecific.c tiger-0.8/xspecific.c
+--- tiger-0.8.orig/xspecific.c 2001-02-01 01:23:51.000000000 +0100
++++ tiger-0.8/xspecific.c 2004-07-16 20:04:31.399096976 +0200
+@@ -19,6 +19,8 @@
+ #include <ggi/ggi.h>
+ #include <ggi/keyboard.h>
+
++#include "xspecific.h"
++
+ ggi_visual_t v;
+ int using_dbuf;
+
+@@ -48,12 +50,10 @@
+ int emuState = 0;
+
+
+-void set_colors(void);
+ int OpenTigerWin(void);
+ void CloseTigerWin(void);
+ void PutImage(void);
+ int x_to_ti(int key);
+-void update_progbar(int size);
+
+ void update_progbar(int size) {
+ cmd_update_progbar(size);
+diff -Naur tiger-0.8.orig/xspecific.h tiger-0.8/xspecific.h
+--- tiger-0.8.orig/xspecific.h 1970-01-01 01:00:00.000000000 +0100
++++ tiger-0.8/xspecific.h 2004-07-16 20:04:31.402096520 +0200
+@@ -0,0 +1,8 @@
++#ifndef __XSPECIFIC_H__
++#define __XSPECIFIC_H__
++
++void update_progbar(int size);
++void set_colors(void);
++
++#endif /* __XSPECIFIC_H__ */
++
diff --git a/app-emulation/tiger/tiger-0.8.ebuild b/app-emulation/tiger/tiger-0.8.ebuild
index 7c5914ab443d..6475b2645a9e 100644
--- a/app-emulation/tiger/tiger-0.8.ebuild
+++ b/app-emulation/tiger/tiger-0.8.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/tiger/tiger-0.8.ebuild,v 1.6 2004/06/27 23:07:16 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/tiger/tiger-0.8.ebuild,v 1.7 2004/09/01 10:57:28 sekretarz Exp $
+
+inherit eutils gcc
DESCRIPTION="Ti-92 Graphing Calculator Emulator"
HOMEPAGE="http://xtiger.sourceforge.net/"
@@ -14,6 +16,12 @@ IUSE=""
DEPEND="virtual/libc
media-libs/libggi"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gcc34.patch
+}
+
src_compile() {
emake || die
}