summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2013-01-24 04:18:49 +0000
committerDoug Goldstein <cardoe@gentoo.org>2013-01-24 04:18:49 +0000
commit85ee4e4ad7830bc30880e356daaddffdb3203793 (patch)
treefa5310362b07445b15adb601dcca7dff5ebb69bf /app-emulation/libvirt/libvirt-1.0.1.ebuild
parentStable on amd64, wrt bug #453716 (diff)
downloadhistorical-85ee4e4ad7830bc30880e356daaddffdb3203793.tar.gz
historical-85ee4e4ad7830bc30880e356daaddffdb3203793.tar.bz2
historical-85ee4e4ad7830bc30880e356daaddffdb3203793.zip
Tweak Xen depends to make bug #446572 not bite people.
Package-Manager: portage-2.2.0_alpha159/cvs/Linux x86_64
Diffstat (limited to 'app-emulation/libvirt/libvirt-1.0.1.ebuild')
-rw-r--r--app-emulation/libvirt/libvirt-1.0.1.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/app-emulation/libvirt/libvirt-1.0.1.ebuild b/app-emulation/libvirt/libvirt-1.0.1.ebuild
index 332ac39ddeda..8d50b3c6b3df 100644
--- a/app-emulation/libvirt/libvirt-1.0.1.ebuild
+++ b/app-emulation/libvirt/libvirt-1.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/libvirt-1.0.1.ebuild,v 1.2 2013/01/11 23:37:55 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/libvirt-1.0.1.ebuild,v 1.3 2013/01/24 04:18:47 cardoe Exp $
EAPI=4
@@ -224,9 +224,12 @@ src_configure() {
## hypervisors on the local host
myconf="${myconf} $(use_with xen) $(use_with xen xen-inotify)"
- # leave it automagic as it depends on the version of xen used.
- use xen || myconf+=" --without-libxl"
- use xen || myconf+=" --without-xenapi"
+ myconf+=" $(use_with xen xenapi)"
+ if use xen && has_version ">=app-emulation/xen-tools-4.2.0"; then
+ myconf+=" --with-libxl"
+ else
+ myconf+=" --without-libxl"
+ fi
myconf="${myconf} $(use_with openvz)"
myconf="${myconf} $(use_with lxc)"
if use virtualbox && has_version app-emulation/virtualbox-ose; then