summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2003-09-10 07:42:53 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2003-09-10 07:42:53 +0000
commit3eedcee912f2f7208901cccb3643a0118ceaa70f (patch)
tree9ef75f2c7e044e775645b1d754b53d1a9ebc0bae /app-emacs/xrdb-mode/xrdb-mode-2.31.ebuild
parentinitial import. bug 26367 (diff)
downloadhistorical-3eedcee912f2f7208901cccb3643a0118ceaa70f.tar.gz
historical-3eedcee912f2f7208901cccb3643a0118ceaa70f.tar.bz2
historical-3eedcee912f2f7208901cccb3643a0118ceaa70f.zip
initial import. bug 26367
Diffstat (limited to 'app-emacs/xrdb-mode/xrdb-mode-2.31.ebuild')
-rw-r--r--app-emacs/xrdb-mode/xrdb-mode-2.31.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-emacs/xrdb-mode/xrdb-mode-2.31.ebuild b/app-emacs/xrdb-mode/xrdb-mode-2.31.ebuild
new file mode 100644
index 000000000000..b3612d74207d
--- /dev/null
+++ b/app-emacs/xrdb-mode/xrdb-mode-2.31.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/xrdb-mode/xrdb-mode-2.31.ebuild,v 1.1 2003/09/10 07:42:50 mkennedy Exp $
+
+inherit elisp
+
+DESCRIPTION="An Emacs major mode for editing X resource database files"
+HOMEPAGE="http://www.python.org/emacs/"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="virtual/emacs"
+S=${WORKDIR}/${P}
+
+SITEFILE=70xrdb-mode-gentoo.el
+
+src_compile() {
+ emacs --no-site-file --no-init-file -batch -f batch-byte-compile *.el
+}
+
+src_install() {
+ elisp-install xrdb-mode *.el *.elc
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+}