summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2007-10-07 07:40:38 +0000
committerUlrich Müller <ulm@gentoo.org>2007-10-07 07:40:38 +0000
commitcc49076896e9fba93e2d2a3fcd913a5d4fe2b877 (patch)
treee6fd63186ce724e18b0fc744cbb8be9b7b5c187b /app-emacs/mpg123-el/mpg123-el-1.47.ebuild
parentRemove redundant SIMPLE_ELISP and DEPEND=virtual/emacs. Quote some variables. (diff)
downloadhistorical-cc49076896e9fba93e2d2a3fcd913a5d4fe2b877.tar.gz
historical-cc49076896e9fba93e2d2a3fcd913a5d4fe2b877.tar.bz2
historical-cc49076896e9fba93e2d2a3fcd913a5d4fe2b877.zip
Remove quotes around tc-getCC command substitution. Remove old.
Package-Manager: portage-2.1.3.12
Diffstat (limited to 'app-emacs/mpg123-el/mpg123-el-1.47.ebuild')
-rw-r--r--app-emacs/mpg123-el/mpg123-el-1.47.ebuild19
1 files changed, 9 insertions, 10 deletions
diff --git a/app-emacs/mpg123-el/mpg123-el-1.47.ebuild b/app-emacs/mpg123-el/mpg123-el-1.47.ebuild
index bf4ceb867d72..2af182a0b0ca 100644
--- a/app-emacs/mpg123-el/mpg123-el-1.47.ebuild
+++ b/app-emacs/mpg123-el/mpg123-el-1.47.ebuild
@@ -1,31 +1,30 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/mpg123-el/mpg123-el-1.47.ebuild,v 1.3 2007/03/30 22:11:08 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/mpg123-el/mpg123-el-1.47.ebuild,v 1.4 2007/10/07 07:40:38 ulm Exp $
inherit elisp toolchain-funcs
-IUSE="vorbis"
-
DESCRIPTION="Emacs front-end to mpg123 audio player and OggVorbis audio player"
HOMEPAGE="http://www.gentei.org/~yuuji/software/mpg123el/"
SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE="vorbis"
+
DEPEND=""
RDEPEND="${DEPEND}
virtual/mpg123
media-sound/aumix
vorbis? ( media-sound/vorbis-tools )"
-SLOT="0"
-LICENSE="freedist"
-KEYWORDS="~amd64 ~ppc x86"
-
-SITEFILE="50mpg123-el-gentoo.el"
+SITEFILE=50${PN}-gentoo.el
src_compile(){
sed -i -e "s/\(mainloop:\)/\1 ;/" tagput.c || die
- "$(tc-getCC)" ${CFLAGS} -o tagput tagput.c || die
- "$(tc-getCC)" ${CFLAGS} -o id3put id3put.c || die
+ $(tc-getCC) ${CFLAGS} -o tagput tagput.c || die
+ $(tc-getCC) ${CFLAGS} -o id3put id3put.c || die
elisp-compile *.el
}