summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-11-01 02:52:02 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-11-01 02:52:02 +0000
commitce2fa6f6c4951c11ef10627b81603f112c0b62a8 (patch)
tree3f697c6e444c56ff856d2d5e5300c606d2462d12 /app-emacs/htmlfontify
parentmasked app-emacs/monk (incomplete for now) (diff)
downloadhistorical-ce2fa6f6c4951c11ef10627b81603f112c0b62a8.tar.gz
historical-ce2fa6f6c4951c11ef10627b81603f112c0b62a8.tar.bz2
historical-ce2fa6f6c4951c11ef10627b81603f112c0b62a8.zip
looks like an app-emacs/ import to me
Diffstat (limited to 'app-emacs/htmlfontify')
-rw-r--r--app-emacs/htmlfontify/ChangeLog11
-rw-r--r--app-emacs/htmlfontify/files/50htmlfontify-gentoo.el5
-rw-r--r--app-emacs/htmlfontify/files/digest-htmlfontify-0.171
-rw-r--r--app-emacs/htmlfontify/htmlfontify-0.17.ebuild43
4 files changed, 60 insertions, 0 deletions
diff --git a/app-emacs/htmlfontify/ChangeLog b/app-emacs/htmlfontify/ChangeLog
new file mode 100644
index 000000000000..74c379e75a8a
--- /dev/null
+++ b/app-emacs/htmlfontify/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-emacs/htmlfontify
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/htmlfontify/ChangeLog,v 1.1 2002/11/01 02:52:01 mkennedy Exp $
+
+*htmlfontify-0.17 (31 Oct 2002)
+
+ 31 Oct 2002; Matthew Kennedy <mkennedy@gentoo.org> ChangeLog,
+ htmlfontify-0.17.ebuild, files/50htmlfontify-gentoo.el,
+ files/digest-htmlfontify-0.17 :
+
+ Initial import.
diff --git a/app-emacs/htmlfontify/files/50htmlfontify-gentoo.el b/app-emacs/htmlfontify/files/50htmlfontify-gentoo.el
new file mode 100644
index 000000000000..0bebd800b6f5
--- /dev/null
+++ b/app-emacs/htmlfontify/files/50htmlfontify-gentoo.el
@@ -0,0 +1,5 @@
+
+;;; htmlfontify site-lisp configuration
+
+(setq load-path (cons "@SITELISP@" load-path))
+(require 'htmlfontify)
diff --git a/app-emacs/htmlfontify/files/digest-htmlfontify-0.17 b/app-emacs/htmlfontify/files/digest-htmlfontify-0.17
new file mode 100644
index 000000000000..4be931069930
--- /dev/null
+++ b/app-emacs/htmlfontify/files/digest-htmlfontify-0.17
@@ -0,0 +1 @@
+MD5 40122c2eed63c58afa2d646e17c19788 htmlfontify_0.17+texinfo.tar.gz 56228
diff --git a/app-emacs/htmlfontify/htmlfontify-0.17.ebuild b/app-emacs/htmlfontify/htmlfontify-0.17.ebuild
new file mode 100644
index 000000000000..9b7a98f41caf
--- /dev/null
+++ b/app-emacs/htmlfontify/htmlfontify-0.17.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/htmlfontify/htmlfontify-0.17.ebuild,v 1.1 2002/11/01 02:52:01 mkennedy Exp $
+
+inherit elisp
+
+IUSE=""
+
+FUNKY_P=${PN}_${PV}+texinfo
+
+DESCRIPTION="Turn an Emacs buffer into display-equivalent HTML"
+HOMEPAGE="mirror://gentoo/${P}.tar.gz"
+SRC_URI="http://rtfm.etla.org/emacs/htmlfontify/${FUNKY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/emacs"
+
+S="${WORKDIR}/${FUNKY_P/_/-}"
+
+SITEFILE=50htmlfontify-gentoo.el
+
+src_compile() {
+ emacs --batch -f batch-byte-compile --no-site-file --no-init-file *.el
+ makeinfo htmlfontify.texi
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+
+ dodoc LICENSE
+ doinfo htmlfontify.info
+}
+
+pkg_postinst() {
+ elisp-site-regen
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}