summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-03-13 19:01:27 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-03-13 19:01:27 +0000
commitaf283024c10301b03fc9916509c98d95501f89dd (patch)
treea87640ceed7b1c4ff676eb2a298f27a9c9f2abee /app-emacs/erc/erc-5.0.2.ebuild
parent(commit aborted midway, fixing) kdebase-data ebuild: replaces kdebase-{l10n,p... (diff)
downloadhistorical-af283024c10301b03fc9916509c98d95501f89dd.tar.gz
historical-af283024c10301b03fc9916509c98d95501f89dd.tar.bz2
historical-af283024c10301b03fc9916509c98d95501f89dd.zip
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'app-emacs/erc/erc-5.0.2.ebuild')
-rw-r--r--app-emacs/erc/erc-5.0.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-emacs/erc/erc-5.0.2.ebuild b/app-emacs/erc/erc-5.0.2.ebuild
new file mode 100644
index 000000000000..fcbca8b9dc17
--- /dev/null
+++ b/app-emacs/erc/erc-5.0.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/erc/erc-5.0.2.ebuild,v 1.1 2005/03/13 19:01:27 mkennedy Exp $
+
+inherit elisp
+
+DESCRIPTION="ERC - The Emacs IRC Client"
+HOMEPAGE="http://emacswiki.org/cgi-bin/wiki.pl?EmacsIRCClient"
+SRC_URI="mirror://sourceforge/erc/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+DEPEND="virtual/emacs"
+
+S=${WORKDIR}/${P/_*/}
+
+src_compile() {
+ make || die
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install ${FILESDIR}/${PV}/50erc-gentoo.el
+ dodoc AUTHORS CREDITS HISTORY ChangeLog servers.pl README
+}